summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2011-06-14 18:52:46 +0000
committerSebastian Pipping <sping@gentoo.org>2011-06-14 18:52:46 +0000
commit7a6ebf8aef0b82d5a89115f45542f6fc13a0ae03 (patch)
tree0000b091adab6a6816f2930349f9dbcb3aa60571 /dev-libs/uriparser
parentversion bump to 1.1.7 (diff)
downloadgentoo-2-7a6ebf8aef0b82d5a89115f45542f6fc13a0ae03.tar.gz
gentoo-2-7a6ebf8aef0b82d5a89115f45542f6fc13a0ae03.tar.bz2
gentoo-2-7a6ebf8aef0b82d5a89115f45542f6fc13a0ae03.zip
dev-libs/uriparser: No longer try installing missing .gif files (bug #350131)
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/uriparser')
-rw-r--r--dev-libs/uriparser/ChangeLog8
-rw-r--r--dev-libs/uriparser/files/uriparser-0.7.5-no-gifs.patch38
-rw-r--r--dev-libs/uriparser/uriparser-0.7.5.ebuild24
3 files changed, 60 insertions, 10 deletions
diff --git a/dev-libs/uriparser/ChangeLog b/dev-libs/uriparser/ChangeLog
index ba3650ddac92..ac21c74bc81f 100644
--- a/dev-libs/uriparser/ChangeLog
+++ b/dev-libs/uriparser/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/uriparser
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/uriparser/ChangeLog,v 1.29 2010/01/18 16:22:50 rbu Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/uriparser/ChangeLog,v 1.30 2011/06/14 18:52:46 sping Exp $
+
+ 14 Jun 2011; Sebastian Pipping <sping@gentoo.org> uriparser-0.7.5.ebuild,
+ +files/uriparser-0.7.5-no-gifs.patch:
+ No longer try installing missing .gif files (bug #350131)
18 Jan 2010; Robert Buchholz <rbu@gentoo.org> metadata.xml:
Dropping maintenance, adding sping
diff --git a/dev-libs/uriparser/files/uriparser-0.7.5-no-gifs.patch b/dev-libs/uriparser/files/uriparser-0.7.5-no-gifs.patch
new file mode 100644
index 000000000000..931559c3a155
--- /dev/null
+++ b/dev-libs/uriparser/files/uriparser-0.7.5-no-gifs.patch
@@ -0,0 +1,38 @@
+From 98272c1fc5c8451dcc43be70cdfb1070e3d72f3a Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Tue, 14 Jun 2011 20:28:43 +0200
+Subject: [PATCH] No longer copy Doxygen .gif files
+
+---
+ doc/Makefile.am | 2 +-
+ doc/release.sh.in | 1 -
+ 2 files changed, 1 insertions(+), 2 deletions(-)
+
+diff --git a/doc/Makefile.am b/doc/Makefile.am
+index 4e63062..d29b77c 100644
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -27,7 +27,7 @@ distclean-local:
+ ## Install doc files
+ install-data-local:
+ $(MKDIR_P) "$(DESTDIR)$(docdir)/html" ## Didn't work with installdirs-local
+- $(INSTALL_DATA) html/*.{css,gif,html,png} "$(DESTDIR)$(docdir)/html/"
++ $(INSTALL_DATA) html/*.{css,html,png} "$(DESTDIR)$(docdir)/html/"
+
+
+ ## Uninstall doc files
+diff --git a/doc/release.sh.in b/doc/release.sh.in
+index 59afb70..a930e64 100755
+--- a/doc/release.sh.in
++++ b/doc/release.sh.in
+@@ -15,7 +15,6 @@ rm -Rf "${distdir}" "${distdir}.zip"
+ mkdir -p "${distdir}/html"
+ cp \
+ html/*.css \
+- html/*.gif \
+ html/*.html \
+ html/*.png \
+ \
+--
+1.7.5.3
+
diff --git a/dev-libs/uriparser/uriparser-0.7.5.ebuild b/dev-libs/uriparser/uriparser-0.7.5.ebuild
index d422aad11e63..9200561a28ab 100644
--- a/dev-libs/uriparser/uriparser-0.7.5.ebuild
+++ b/dev-libs/uriparser/uriparser-0.7.5.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/uriparser/uriparser-0.7.5.ebuild,v 1.8 2010/01/14 21:28:17 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/uriparser/uriparser-0.7.5.ebuild,v 1.9 2011/06/14 18:52:46 sping Exp $
EAPI=2
+inherit eutils autotools
+
DESCRIPTION="Uriparser is a strictly RFC 3986 compliant URI parsing library in C"
HOMEPAGE="http://uriparser.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
@@ -11,14 +13,21 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-IUSE="doc test"
+IUSE="doc qt4 test"
RDEPEND=""
DEPEND="dev-util/pkgconfig
doc? ( >=app-doc/doxygen-1.5.8
- x11-libs/qt-assistant )
+ qt4? ( x11-libs/qt-assistant ) )
test? ( dev-util/cpptest )"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-gifs.patch
+
+ cd doc || die
+ eautoreconf
+}
+
src_configure() {
econf \
$(use_enable doc) \
@@ -29,11 +38,10 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog THANKS doc/*.txt
- dohtml doc/*.htm
+ dodoc AUTHORS ChangeLog THANKS doc/*.txt || die
- if use doc; then
+ if use doc && use qt4; then
insinto /usr/share/doc/${PF}/
- doins doc/*.qch # Avoiding dodoc's compression
+ doins doc/*.qch || die # Using doins to avoiding dodoc's compression
fi
}