summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-05-25 01:33:58 +0000
committerMarien Zwart <marienz@gentoo.org>2006-05-25 01:33:58 +0000
commit88019036080963ac42649e191c9a003d561db2d1 (patch)
tree4c786ef078e3adc641922c31e033e8c934f3cca0 /dev-libs/xapian-bindings
parent3.1.3 version bump. Marking 3.0.1 x86 stable. (diff)
downloadgentoo-2-88019036080963ac42649e191c9a003d561db2d1.tar.gz
gentoo-2-88019036080963ac42649e191c9a003d561db2d1.tar.bz2
gentoo-2-88019036080963ac42649e191c9a003d561db2d1.zip
Version bump with new ruby bindings. Now also builds the java bindings if requested. Ebuild cleanup based on suggestions from Olly Betts (<olly@survex.com>).
(Portage version: 2.1_rc2-r2)
Diffstat (limited to 'dev-libs/xapian-bindings')
-rw-r--r--dev-libs/xapian-bindings/ChangeLog14
-rw-r--r--dev-libs/xapian-bindings/files/digest-xapian-bindings-0.9.63
-rw-r--r--dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-java-array-delete.patch22
-rw-r--r--dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-parallel-make.patch13
-rw-r--r--dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-php-tests-2.patch10
-rw-r--r--dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-php-tests.patch97
-rw-r--r--dev-libs/xapian-bindings/xapian-bindings-0.9.6.ebuild82
7 files changed, 240 insertions, 1 deletions
diff --git a/dev-libs/xapian-bindings/ChangeLog b/dev-libs/xapian-bindings/ChangeLog
index 657f9211d5e6..a0a86bd405bd 100644
--- a/dev-libs/xapian-bindings/ChangeLog
+++ b/dev-libs/xapian-bindings/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for dev-libs/xapian-bindings
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian-bindings/ChangeLog,v 1.1 2006/05/05 16:04:57 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian-bindings/ChangeLog,v 1.2 2006/05/25 01:33:58 marienz Exp $
+
+*xapian-bindings-0.9.6 (25 May 2006)
+
+ 25 May 2006; Marien Zwart <marienz@gentoo.org>
+ +files/xapian-bindings-0.9.6-java-array-delete.patch,
+ +files/xapian-bindings-0.9.6-parallel-make.patch,
+ +files/xapian-bindings-0.9.6-php-tests.patch,
+ +files/xapian-bindings-0.9.6-php-tests-2.patch,
+ +xapian-bindings-0.9.6.ebuild:
+ Version bump with new ruby bindings. Now also builds the java bindings if
+ requested. Ebuild cleanup based on suggestions from Olly Betts
+ (<olly@survex.com>).
*xapian-bindings-0.9.5 (05 May 2006)
diff --git a/dev-libs/xapian-bindings/files/digest-xapian-bindings-0.9.6 b/dev-libs/xapian-bindings/files/digest-xapian-bindings-0.9.6
new file mode 100644
index 000000000000..753185edcf3c
--- /dev/null
+++ b/dev-libs/xapian-bindings/files/digest-xapian-bindings-0.9.6
@@ -0,0 +1,3 @@
+MD5 f404b6a9c9e86a9ec6dfbbe38909b2cf xapian-bindings-0.9.6.tar.gz 792703
+RMD160 7320856c454e8ba675d168baccb92be022e2a24e xapian-bindings-0.9.6.tar.gz 792703
+SHA256 758765bde18817a7e4fde5d21742be5fb154f77ba211fe93d3dd00523e1657ed xapian-bindings-0.9.6.tar.gz 792703
diff --git a/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-java-array-delete.patch b/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-java-array-delete.patch
new file mode 100644
index 000000000000..13b1aa79ce73
--- /dev/null
+++ b/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-java-array-delete.patch
@@ -0,0 +1,22 @@
+Index: native/Query.cc
+===================================================================
+--- native/Query.cc (revision 6993)
++++ native/Query.cc (working copy)
+@@ -110,7 +110,7 @@
+ jsize size = env->GetArrayLength(terms);
+ string *array = toArray(env, terms, size);
+ Query *q = new Query(op_table[op-1], array, array+size);
+- delete array;
++ delete[] array;
+ return _query->put(q);
+ CATCH(-1)
+ }
+@@ -124,7 +124,7 @@
+ queries[x] = _query->get(qid_ptr[x]);
+ }
+ Query *q = new Query(op_table[op-1], queries, queries+len);
+- delete queries;
++ delete[] queries;
+ return _query->put(q);
+ CATCH(-1)
+ }
diff --git a/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-parallel-make.patch b/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-parallel-make.patch
new file mode 100644
index 000000000000..882b0dd0daca
--- /dev/null
+++ b/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-parallel-make.patch
@@ -0,0 +1,13 @@
+=== modified file 'python/Makefile.am'
+--- python/Makefile.am
++++ python/Makefile.am
+@@ -49,7 +49,7 @@
+ # the .py file to the build directory instead. We "import _xapian" first
+ # so that if we fail to import the glue library we don't generate a broken
+ # xapian.pyc.
+-xapian.pyc: xapian.py
++xapian.pyc: xapian.py _xapian.la
+ PYTHONPATH=".$(PYTHON_PATHSEP).libs" $(PYTHON) -c "import _xapian;import xapian"
+
+ xapian.py: @PYTHON_MODERN_OR_OLDE@/xapian.py
+
diff --git a/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-php-tests-2.patch b/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-php-tests-2.patch
new file mode 100644
index 000000000000..fd43d7f39bfc
--- /dev/null
+++ b/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-php-tests-2.patch
@@ -0,0 +1,10 @@
+--- smoketest5.php.orig 2006-05-24 17:31:13.000000000 +0200
++++ smoketest5.php 2006-05-24 17:37:19.000000000 +0200
+@@ -26,6 +26,6 @@
+ print "Retrieved non-existent document\n";
+ exit(1);
+ }
+-} catch (e) {
++} catch (Exception $e) {
+ }
+ ?>
diff --git a/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-php-tests.patch b/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-php-tests.patch
new file mode 100644
index 000000000000..ce5a2bd9c3c1
--- /dev/null
+++ b/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-php-tests.patch
@@ -0,0 +1,97 @@
+Index: smoketest.php
+===================================================================
+--- smoketest.php (revision 7002)
++++ smoketest.php (working copy)
+@@ -108,17 +108,7 @@
+ exit(1);
+ }
+
+-# Check PHP4 handling of Xapian::DocNotFoundError
+-$old_error_reporting = error_reporting();
+-if ($old_error_reporting & E_WARNING)
+- error_reporting($old_error_reporting ^ E_WARNING);
+-$doc2 = Database_get_document($db, 2);
+-if ($doc2 != null) {
+- print "Retrieved non-existent document\n";
+- exit(1);
+-}
+-if ($old_error_reporting & E_WARNING)
+- error_reporting($old_error_reporting);
++include "smoketest".substr(PHP_VERSION, 0, 1).".php";
+
+ # Regression test - overload resolution involving boolean types failed.
+ Enquire_set_sort_by_value($enq, 1, TRUE);
+Index: smoketest4.php
+===================================================================
+--- smoketest4.php (revision 0)
++++ smoketest4.php (revision 0)
+@@ -0,0 +1,33 @@
++<?php
++/* PHP4 specific tests.
++ *
++ * Copyright (C) 2006 Olly Betts
++ *
++ * This program is free software; you can redistribute it and/or
++ * modify it under the terms of the GNU General Public License as
++ * published by the Free Software Foundation; either version 2 of the
++ * License, or (at your option) any later version.
++ *
++ * This program is distributed in the hope that it will be useful,
++ * but WITHOUT ANY WARRANTY; without even the implied warranty of
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++ * GNU General Public License for more details.
++ *
++ * You should have received a copy of the GNU General Public License
++ * along with this program; if not, write to the Free Software
++ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301
++ * USA
++ */
++
++# Check PHP4 handling of Xapian::DocNotFoundError
++$old_error_reporting = error_reporting();
++if ($old_error_reporting & E_WARNING)
++ error_reporting($old_error_reporting ^ E_WARNING);
++$doc2 = Database_get_document($db, 2);
++if ($doc2 != null) {
++ print "Retrieved non-existent document\n";
++ exit(1);
++}
++if ($old_error_reporting & E_WARNING)
++ error_reporting($old_error_reporting);
++?>
+Index: smoketest5.php
+===================================================================
+--- smoketest5.php (revision 0)
++++ smoketest5.php (revision 0)
+@@ -0,0 +1,31 @@
++<?php
++/* PHP5 specific tests.
++ *
++ * Copyright (C) 2006 Olly Betts
++ *
++ * This program is free software; you can redistribute it and/or
++ * modify it under the terms of the GNU General Public License as
++ * published by the Free Software Foundation; either version 2 of the
++ * License, or (at your option) any later version.
++ *
++ * This program is distributed in the hope that it will be useful,
++ * but WITHOUT ANY WARRANTY; without even the implied warranty of
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++ * GNU General Public License for more details.
++ *
++ * You should have received a copy of the GNU General Public License
++ * along with this program; if not, write to the Free Software
++ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301
++ * USA
++ */
++
++# Check PHP5 handling of Xapian::DocNotFoundError
++try {
++ $doc2 = Database_get_document($db, 2);
++ if ($doc2 != null) {
++ print "Retrieved non-existent document\n";
++ exit(1);
++ }
++} catch (e) {
++}
++?>
diff --git a/dev-libs/xapian-bindings/xapian-bindings-0.9.6.ebuild b/dev-libs/xapian-bindings/xapian-bindings-0.9.6.ebuild
new file mode 100644
index 000000000000..7c086f42c1ea
--- /dev/null
+++ b/dev-libs/xapian-bindings/xapian-bindings-0.9.6.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian-bindings/xapian-bindings-0.9.6.ebuild,v 1.1 2006/05/25 01:33:58 marienz Exp $
+
+inherit mono eutils autotools java-pkg
+
+DESCRIPTION="SWIG and JNI bindings for Xapian"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://www.oligarchy.co.uk/xapian/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="python php tcltk mono java ruby"
+
+COMMONDEPEND="=dev-libs/xapian-${PV}
+ python? ( >=dev-lang/python-2.1 )
+ php? ( >=dev-lang/php-4 )
+ tcltk? ( >=dev-lang/tcl-8.1 )
+ mono? ( >=dev-lang/mono-1.0.8 )
+ ruby? ( dev-lang/ruby )"
+
+DEPEND="${COMMONDEPEND}
+ java? ( >=virtual/jdk-1.3 )"
+
+RDEPEND="${COMMONDEPEND}
+ java? ( >=virtual/jre-1.3 )"
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # applied upstream
+ epatch "${FILESDIR}/${P}-parallel-make.patch"
+ cd java
+ # from upstream
+ epatch "${FILESDIR}/${P}-java-array-delete.patch"
+ cd ../php
+ # from upstream
+ epatch "${FILESDIR}/${P}-php-tests.patch"
+ # submitted upstream
+ epatch "${FILESDIR}/${P}-php-tests-2.patch"
+ cd ..
+
+ eautoreconf
+}
+
+src_compile() {
+ if use java; then
+ CXXFLAGS="${CXXFLAGS} -I${JAVA_HOME}/include"
+ CXXFLAGS="${CXXFLAGS} -I${JAVA_HOME}/include/linux"
+ fi
+ econf \
+ $(use_with python) \
+ $(use_with php) \
+ $(use_with tcltk tcl) \
+ $(use_with mono csharp) \
+ $(use_with java) \
+ $(use_with ruby) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake -j1 DESTDIR="${D}" install || die
+
+ if use java; then
+ java-pkg_dojar java/built/xapian_jni.jar
+ # TODO: make the build system not install this...
+ java-pkg_doso "${D}/${S}/java/built/libxapian_jni.so"
+ rm "${D}/${S}/java/built/libxapian_jni.so"
+ rmdir -p "${D}/${S}/java/built"
+ fi
+
+ # For some USE combos this directory is not created
+ if [[ -d "${D}/usr/share/doc/xapian-bindings" ]]; then
+ mv "${D}/usr/share/doc/xapian-bindings" "${D}/usr/share/doc/${PF}"
+ fi
+
+ dodoc AUTHORS HACKING NEWS TODO README
+}