summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn P. Davis <zhen@gentoo.org>2004-10-04 15:58:16 +0000
committerJohn P. Davis <zhen@gentoo.org>2004-10-04 15:58:16 +0000
commit3d1e676a66331dabdd091b1bef5654b72d9d0a1b (patch)
tree37641bcf5e1e55b05d4a6adc72614278c7df97b7 /dev-libs/xerces-c/xerces-c-2.6.0.ebuild
parentmake gcc-config give an error message if the current profile doesnt exist (Ma... (diff)
downloadgentoo-2-3d1e676a66331dabdd091b1bef5654b72d9d0a1b.tar.gz
gentoo-2-3d1e676a66331dabdd091b1bef5654b72d9d0a1b.tar.bz2
gentoo-2-3d1e676a66331dabdd091b1bef5654b72d9d0a1b.zip
security bump bug #66303
Diffstat (limited to 'dev-libs/xerces-c/xerces-c-2.6.0.ebuild')
-rw-r--r--dev-libs/xerces-c/xerces-c-2.6.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/xerces-c/xerces-c-2.6.0.ebuild b/dev-libs/xerces-c/xerces-c-2.6.0.ebuild
new file mode 100644
index 000000000000..6e998b8d3939
--- /dev/null
+++ b/dev-libs/xerces-c/xerces-c-2.6.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xerces-c/xerces-c-2.6.0.ebuild,v 1.1 2004/10/04 15:58:16 zhen Exp $
+
+MY_PV=${PV//./_}
+MY_P=${PN}-src_${MY_PV}
+DESCRIPTION="Xerces-C++ is a validating XML parser written in a portable subset of C++."
+HOMEPAGE="http://xml.apache.org/xerces-c/index.html"
+SRC_URI="http://www.apache.org/dist/xml/xerces-c/${MY_P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc amd64"
+IUSE="doc"
+
+DEPEND="virtual/libc
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ export XERCESCROOT=${S}
+ cd src/xercesc
+ econf || die
+ emake -j1 || die
+}
+
+src_install () {
+ export XERCESCROOT=${S}
+ cd ${S}/src/xercesc
+ make DESTDIR=${D} install || die
+
+ if use doc; then
+ dodir /usr/share/doc/${P}
+ cp -a ${S}/samples ${D}/usr/share/doc/${P}
+ cd ${S}/doc; doxygen
+ dohtml -r html
+ fi
+
+ cd ${S}
+ dodoc STATUS credits.txt version.incl
+ dohtml Readme.html
+
+ unset XERCESCROOT
+}