summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2012-05-24 19:37:01 +0000
committerTiziano Müller <dev-zero@gentoo.org>2012-05-24 19:37:01 +0000
commit1997984cdb89650406b8a4e53f2526703003db50 (patch)
tree580e0e994a6c6837297e4e75a81c8f4bfeb31c2b /dev-libs/xerces-c/xerces-c-3.0.0-r1.ebuild
parentWhitespace to shutup repoman. (diff)
downloadgentoo-2-1997984cdb89650406b8a4e53f2526703003db50.tar.gz
gentoo-2-1997984cdb89650406b8a4e53f2526703003db50.tar.bz2
gentoo-2-1997984cdb89650406b8a4e53f2526703003db50.zip
Dropped old unused versions and it's patches (fixes bug #248966).
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/xerces-c/xerces-c-3.0.0-r1.ebuild')
-rw-r--r--dev-libs/xerces-c/xerces-c-3.0.0-r1.ebuild90
1 files changed, 0 insertions, 90 deletions
diff --git a/dev-libs/xerces-c/xerces-c-3.0.0-r1.ebuild b/dev-libs/xerces-c/xerces-c-3.0.0-r1.ebuild
deleted file mode 100644
index 74695aff15ab..000000000000
--- a/dev-libs/xerces-c/xerces-c-3.0.0-r1.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xerces-c/xerces-c-3.0.0-r1.ebuild,v 1.9 2008/12/14 12:43:46 maekke Exp $
-
-inherit eutils
-
-DESCRIPTION="A validating XML parser written in a portable subset of C++."
-HOMEPAGE="http://xerces.apache.org/xerces-c/"
-SRC_URI="mirror://apache/xerces/c/3/sources/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 ~hppa ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="curl debug doc iconv icu libwww threads elibc_Darwin elibc_FreeBSD"
-
-RDEPEND="icu? ( dev-libs/icu )
- curl? ( net-misc/curl )
- libwww? ( net-libs/libwww )
- virtual/libiconv"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-pkg_setup() {
- export ICUROOT="/usr"
-
- if use iconv && use icu ; then
- ewarn "This package can use iconv or icu for loading messages"
- ewarn "and transcoding, but not both. ICU will precede."
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- sed -i \
- -e 's|$(prefix)/msg|$(DESTDIR)/$(prefix)/share/xerces-c/msg|' \
- src/xercesc/util/MsgLoaders/MsgCatalog/Makefile.in || die "sed failed"
-}
-
-src_compile() {
- local mloader="inmemory"
- use iconv && mloader="iconv"
- use icu && mloader="icu"
-
- local transcoder="gnuiconv"
- use elibc_FreeBSD && transcoder="iconv"
- use elibc_Darwin && transcoder="macosunicodeconverter"
- use icu && transcoder="icu"
-
- # 'cfurl' is only available on OSX and 'socket' isn't supposed to work.
- # But the docs aren't clear about it, so we would need some testing...
- local netaccessor="socket"
- use elibc_Darwin && netaccessor="cfurl"
- use libwww && netaccessor="libwww"
- use curl && netaccessor="curl"
-
- econf \
- $(use_enable debug) \
- $(use_enable threads) \
- --enable-msgloader-${mloader} \
- --enable-netaccessor-${netaccessor} \
- --enable-transcoder-${transcoder} \
- || die "econf failed"
-
- emake || die "emake failed"
-
- if use doc ; then
- cd "${S}/doc"
- doxygen || die "making docs failed"
- fi
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake failed"
-
- cd "${S}"
- doenvd "${FILESDIR}/50xerces-c"
-
- if use doc; then
- insinto /usr/share/doc/${PF}
- rm -rf samples/config* samples/Makefile* samples/runConfigure \
- samples/install-sh samples/*/Makefile* samples/.libs
- rm samples/*
- doins -r samples
- dohtml -r doc/html/*
- fi
-
- dodoc CREDITS KEYS NOTICE README version.incl
-}