summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2007-01-30 09:44:33 +0000
committerBenedikt Boehm <hollow@gentoo.org>2007-01-30 09:44:33 +0000
commit6d35355bfaabb2e996fa31746a9db64775e9f4fd (patch)
tree984aa95d34d1ae9c582e0ab26bceb74a53b8937d /dev-libs/xmlrpc-c/xmlrpc-c-1.09.00.ebuild
parentadded kdehiddenvisibility thanks to suggestion by Lukas Grygera <grygera@lib.... (diff)
downloadgentoo-2-6d35355bfaabb2e996fa31746a9db64775e9f4fd.tar.gz
gentoo-2-6d35355bfaabb2e996fa31746a9db64775e9f4fd.tar.bz2
gentoo-2-6d35355bfaabb2e996fa31746a9db64775e9f4fd.zip
version bump; remove old version
(Portage version: 2.1.2-r4)
Diffstat (limited to 'dev-libs/xmlrpc-c/xmlrpc-c-1.09.00.ebuild')
-rw-r--r--dev-libs/xmlrpc-c/xmlrpc-c-1.09.00.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/xmlrpc-c/xmlrpc-c-1.09.00.ebuild b/dev-libs/xmlrpc-c/xmlrpc-c-1.09.00.ebuild
new file mode 100644
index 000000000000..a1efbf8f6c81
--- /dev/null
+++ b/dev-libs/xmlrpc-c/xmlrpc-c-1.09.00.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xmlrpc-c/xmlrpc-c-1.09.00.ebuild,v 1.1 2007/01/30 09:44:33 hollow Exp $
+
+inherit eutils
+
+DESCRIPTION="A lightweigt RPC library based on XML and HTTP"
+SRC_URI="mirror://sourceforge/xmlrpc-c/${P}.tgz"
+HOMEPAGE="http://xmlrpc-c.sourceforge.net/"
+
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="curl libwww threads"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="dev-libs/libxml2
+ libwww? ( net-libs/libwww )
+ curl? ( net-misc/curl )"
+
+pkg_setup() {
+ # paralell make doesn't work
+ MAKEOPTS="-j1"
+
+ if ! use curl && ! use libwww; then
+ ewarn "Neither CURL nor libwww support was selected"
+ ewarn "No client library will be be built"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.05-pic.patch
+ epatch "${FILESDIR}"/${PN}-1.06.02-threadupdatestatus.patch
+}
+
+src_compile() {
+ econf --disable-wininet-client --enable-libxml2-backend \
+ $(use_enable threads abyss-threads) \
+ $(use_enable curl curl-client) \
+ $(use_enable libwww libwww-client) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}