summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-08-24 19:50:12 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-08-24 19:50:12 +0000
commitadefbd7f83b5bac3aa9921d6b93a0cb6ff63dcd9 (patch)
tree2eda99590a883ab5244f09a10c760709a69050ea /dev-libs/xmlrpc-c/xmlrpc-c-1.15.05.ebuild
parentStable on alpha, bug #235589 (diff)
downloadgentoo-2-adefbd7f83b5bac3aa9921d6b93a0cb6ff63dcd9.tar.gz
gentoo-2-adefbd7f83b5bac3aa9921d6b93a0cb6ff63dcd9.tar.bz2
gentoo-2-adefbd7f83b5bac3aa9921d6b93a0cb6ff63dcd9.zip
Bump to 1.15.05, remove old
(Portage version: 2.2_rc8/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'dev-libs/xmlrpc-c/xmlrpc-c-1.15.05.ebuild')
-rw-r--r--dev-libs/xmlrpc-c/xmlrpc-c-1.15.05.ebuild87
1 files changed, 87 insertions, 0 deletions
diff --git a/dev-libs/xmlrpc-c/xmlrpc-c-1.15.05.ebuild b/dev-libs/xmlrpc-c/xmlrpc-c-1.15.05.ebuild
new file mode 100644
index 000000000000..df321a49bab6
--- /dev/null
+++ b/dev-libs/xmlrpc-c/xmlrpc-c-1.15.05.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xmlrpc-c/xmlrpc-c-1.15.05.ebuild,v 1.1 2008/08/24 19:50:12 loki_val Exp $
+
+EAPI=1
+
+inherit eutils multilib base
+
+DESCRIPTION="A lightweigt RPC library based on XML and HTTP"
+SRC_URI="mirror://gentoo/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://xmlrpc-c.sourceforge.net/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="+curl +cxx"
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="dev-libs/libxml2
+ curl? ( net-misc/curl )"
+
+pkg_setup() {
+ if ! use curl
+ then
+ ewarn "Curl support disabled: No client library will be be built"
+ fi
+}
+
+#FAIL
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${PN}-1.14.07-abyss-disable.patch" )
+
+src_unpack() {
+ base_src_unpack
+ cd "${S}"
+
+ # Respect the user's CFLAGS/CXXFLAGS.
+ sed -i \
+ -e "/CFLAGS_COMMON/s:-g -O3$:${CFLAGS}:" \
+ -e "/CXXFLAGS_COMMON/s:-g$:${CXXFLAGS}:" \
+ "${S}"/common.mk || die "404. File not found while sedding"
+
+ sed -i \
+ -e "/^LIBINST_DIR = / s:\$(PREFIX)/lib:\$(PREFIX)/$(get_libdir):" \
+ config.mk.in
+}
+
+src_compile() {
+ #Bug 214137: We need to filter this.
+ unset SRCDIR
+
+ # Respect the user's LDFLAGS.
+ export LADD=${LDFLAGS}
+ econf --disable-wininet-client \
+ --enable-libxml2-backend \
+ --disable-libwww-client \
+ --disable-abyss-server \
+ --enable-cgi-server \
+ --disable-abyss-threads \
+ $(use_enable cxx cplusplus) \
+ $(use_enable curl curl-client) \
+ || die "econf failed"
+ emake -j1 || die "emake failed"
+}
+
+src_test() {
+ unset LDFLAGS LADD SRCDIR
+ cd "${S}"/src/test/
+ einfo "Building general tests"
+ make || die "Make of general tests failed"
+ einfo "Running general tests"
+ ./test || die "General tests failed"
+
+ cd "${S}"/src/cpp/test
+ einfo "Building C++ tests"
+ make || die "Make of C++ tests failed"
+ einfo "Running C++ tests"
+ ./test || die "C++ tests failed"
+}
+
+src_install() {
+ unset SRCDIR
+ emake -j1 DESTDIR="${D}" install || die "installation failed"
+
+ dodoc README doc/CREDITS doc/DEVELOPING doc/HISTORY doc/SECURITY doc/TESTING \
+ doc/TODO || die "installing docs failed"
+}