summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2008-01-17 19:33:13 +0000
committerRyan Hill <dirtyepic@gentoo.org>2008-01-17 19:33:13 +0000
commit52d1ac2ea870cc5b88da9c783c8ba2209a9fb76a (patch)
tree2298c0a5d020bb0d56e0d39a473802b2f223b6c1 /dev-libs/xxl/xxl-1.0.1.ebuild
parentold (diff)
downloadgentoo-2-52d1ac2ea870cc5b88da9c783c8ba2209a9fb76a.tar.gz
gentoo-2-52d1ac2ea870cc5b88da9c783c8ba2209a9fb76a.tar.bz2
gentoo-2-52d1ac2ea870cc5b88da9c783c8ba2209a9fb76a.zip
Add patch by Grigory Dorokhov fixing test failure and adding support for
more than two nested try blocks. Bug #165558. (Portage version: 2.1.4)
Diffstat (limited to 'dev-libs/xxl/xxl-1.0.1.ebuild')
-rw-r--r--dev-libs/xxl/xxl-1.0.1.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/dev-libs/xxl/xxl-1.0.1.ebuild b/dev-libs/xxl/xxl-1.0.1.ebuild
index 572733489cd4..e08f71afd6b1 100644
--- a/dev-libs/xxl/xxl-1.0.1.ebuild
+++ b/dev-libs/xxl/xxl-1.0.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xxl/xxl-1.0.1.ebuild,v 1.3 2007/11/17 23:06:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xxl/xxl-1.0.1.ebuild,v 1.4 2008/01/17 19:33:12 dirtyepic Exp $
+
+inherit eutils
DESCRIPTION="C/C++ library that provides exception handling and asset management"
HOMEPAGE="http://www.zork.org/xxl/"
@@ -11,6 +13,13 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-nested-exception.patch
+}
+
src_install() {
emake DESTDIR="${D}" install || die "make install failed"
dodoc README