summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-06-23 22:19:25 +0000
committerMichael Weber <xmw@gentoo.org>2013-06-23 22:19:25 +0000
commitd58cb41325bef3b50d8c563ea4f880c2e5ef966f (patch)
treecf02ace80a2c345622ba0253c5040659a2373075 /dev-libs/yajl
parentUpdate PIL imports and depend on virtual/python-imaging, bug 471514. (diff)
downloadgentoo-2-d58cb41325bef3b50d8c563ea4f880c2e5ef966f.tar.gz
gentoo-2-d58cb41325bef3b50d8c563ea4f880c2e5ef966f.tar.bz2
gentoo-2-d58cb41325bef3b50d8c563ea4f880c2e5ef966f.zip
Revbump, USE=static-libs (bug 447376, thanks ago), fix multilib test (bug 467808, thanks Alphat-PC). Drop old.
(Portage version: 2.2.0_alpha183/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'dev-libs/yajl')
-rw-r--r--dev-libs/yajl/ChangeLog10
-rw-r--r--dev-libs/yajl/files/yajl-2.0.4-remove_static_lib.patch28
-rw-r--r--dev-libs/yajl/yajl-1.0.11-r1.ebuild30
-rw-r--r--dev-libs/yajl/yajl-2.0.2.ebuild39
-rw-r--r--dev-libs/yajl/yajl-2.0.4-r2.ebuild (renamed from dev-libs/yajl/yajl-2.0.4.ebuild)26
5 files changed, 47 insertions, 86 deletions
diff --git a/dev-libs/yajl/ChangeLog b/dev-libs/yajl/ChangeLog
index d990644a22c3..dc09a8e31a88 100644
--- a/dev-libs/yajl/ChangeLog
+++ b/dev-libs/yajl/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/yajl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/yajl/ChangeLog,v 1.35 2013/04/25 19:38:48 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yajl/ChangeLog,v 1.36 2013/06/23 22:19:25 xmw Exp $
+
+*yajl-2.0.4-r2 (23 Jun 2013)
+
+ 23 Jun 2013; Michael Weber <xmw@gentoo.org>
+ +files/yajl-2.0.4-remove_static_lib.patch, +yajl-2.0.4-r2.ebuild,
+ -yajl-1.0.11-r1.ebuild, -yajl-2.0.2.ebuild, -yajl-2.0.4.ebuild:
+ Revbump, USE=static-libs (bug 447376, thanks ago), fix multilib test (bug
+ 467808, thanks Alphat-PC). Drop old.
*yajl-2.0.4-r1 (25 Apr 2013)
diff --git a/dev-libs/yajl/files/yajl-2.0.4-remove_static_lib.patch b/dev-libs/yajl/files/yajl-2.0.4-remove_static_lib.patch
new file mode 100644
index 000000000000..4309e5a2ee40
--- /dev/null
+++ b/dev-libs/yajl/files/yajl-2.0.4-remove_static_lib.patch
@@ -0,0 +1,28 @@
+--- yajl-2.0.4/src/CMakeLists.txt
++++ yajl-2.0.4/src/CMakeLists.txt
+@@ -35,8 +35,6 @@
+ # set the output path for libraries
+ SET(LIBRARY_OUTPUT_PATH ${libDir})
+
+-ADD_LIBRARY(yajl_s STATIC ${SRCS} ${HDRS} ${PUB_HDRS})
+-
+ ADD_LIBRARY(yajl SHARED ${SRCS} ${HDRS} ${PUB_HDRS})
+
+ #### setup shared library version number
+@@ -69,8 +67,6 @@
+
+ EXEC_PROGRAM(${CMAKE_COMMAND} ARGS -E copy_if_different ${header} ${incDir})
+
+- ADD_CUSTOM_COMMAND(TARGET yajl_s POST_BUILD
+- COMMAND ${CMAKE_COMMAND} -E copy_if_different ${header} ${incDir})
+ ENDFOREACH (header ${PUB_HDRS})
+
+ INCLUDE_DIRECTORIES(${incDir}/..)
+@@ -79,7 +75,6 @@
+ # at build time you may specify the cmake variable LIB_SUFFIX to handle
+ # 64-bit systems which use 'lib64'
+ INSTALL(TARGETS yajl LIBRARY DESTINATION lib${LIB_SUFFIX})
+- INSTALL(TARGETS yajl_s ARCHIVE DESTINATION lib${LIB_SUFFIX})
+ INSTALL(FILES ${PUB_HDRS} DESTINATION include/yajl)
+ INSTALL(FILES ${incDir}/yajl_version.h DESTINATION include/yajl)
+ INSTALL(FILES ${shareDir}/yajl.pc DESTINATION share/pkgconfig)
diff --git a/dev-libs/yajl/yajl-1.0.11-r1.ebuild b/dev-libs/yajl/yajl-1.0.11-r1.ebuild
deleted file mode 100644
index cf53b7068311..000000000000
--- a/dev-libs/yajl/yajl-1.0.11-r1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/yajl/yajl-1.0.11-r1.ebuild,v 1.1 2011/02/11 18:41:01 scarabeus Exp $
-
-EAPI=3
-
-inherit cmake-utils
-
-DESCRIPTION="Small event-driven (SAX-style) JSON parser"
-HOMEPAGE="http://lloyd.github.com/yajl/"
-SRC_URI="http://github.com/lloyd/yajl/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
-
-IUSE=""
-
-src_prepare() {
- cd "${WORKDIR}"/lloyd-${PN}-*
- S=$(pwd)
-
- epatch "${FILESDIR}"/${PN}-fix_static_linking.patch
-}
-
-src_test() {
- pushd "${CMAKE_BUILD_DIR}" > /dev/null
- emake test
- popd > /dev/null
-}
diff --git a/dev-libs/yajl/yajl-2.0.2.ebuild b/dev-libs/yajl/yajl-2.0.2.ebuild
deleted file mode 100644
index 7a66ee9eae07..000000000000
--- a/dev-libs/yajl/yajl-2.0.2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/yajl/yajl-2.0.2.ebuild,v 1.6 2011/10/23 12:03:00 scarabeus Exp $
-
-EAPI=4
-
-inherit base cmake-utils
-
-DESCRIPTION="Small event-driven (SAX-style) JSON parser"
-HOMEPAGE="http://lloyd.github.com/yajl/"
-SRC_URI="http://github.com/lloyd/yajl/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
-
-IUSE="static-libs"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-fix_static_linking.patch
-)
-
-src_unpack() {
- unpack ${A}
-
- cd "${WORKDIR}"/lloyd-${PN}-*
- S=$(pwd)
-}
-
-src_test() {
- pushd "${CMAKE_BUILD_DIR}" > /dev/null
- emake test
- popd > /dev/null
-}
-
-src_install() {
- cmake-utils_src_install
- use static-libs || find "${ED}" -name '*.a' -exec rm -f {} +
-}
diff --git a/dev-libs/yajl/yajl-2.0.4.ebuild b/dev-libs/yajl/yajl-2.0.4-r2.ebuild
index 045feeded388..8e8db9a3bf4c 100644
--- a/dev-libs/yajl/yajl-2.0.4.ebuild
+++ b/dev-libs/yajl/yajl-2.0.4-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/yajl/yajl-2.0.4.ebuild,v 1.5 2013/01/06 09:28:04 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yajl/yajl-2.0.4-r2.ebuild,v 1.1 2013/06/23 22:19:25 xmw Exp $
-EAPI=4
+EAPI=5
-inherit base cmake-utils
+inherit eutils cmake-multilib vcs-snapshot
DESCRIPTION="Small event-driven (SAX-style) JSON parser"
HOMEPAGE="http://lloyd.github.com/yajl/"
@@ -13,21 +13,15 @@ SRC_URI="http://github.com/lloyd/yajl/tarball/${PV} -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
+IUSE="static-libs"
-PATCHES=(
- "${FILESDIR}"/${PN}-fix_static_linking.patch
-)
-
-src_unpack() {
- unpack ${A}
- mv "${WORKDIR}"/lloyd-${PN}-* "${S}"
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-fix_static_linking.patch
+ if ! use static-libs ; then
+ epatch "${FILESDIR}"/${P}-remove_static_lib.patch
+ fi
}
src_test() {
- emake -C "${CMAKE_BUILD_DIR}" test
-}
-
-src_install() {
- cmake-utils_src_install
+ multilib_foreach_abi run_in_build_dir emake test
}