summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-04-18 18:49:57 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-04-18 18:49:57 +0000
commit0769ff3d1d825f03d5066f6f2604b53948ab3f45 (patch)
tree7007ba82c8b1d59d5fdafd34bdfd00ef782486b2 /dev-libs
parentVersion bump. (diff)
downloadgentoo-2-0769ff3d1d825f03d5066f6f2604b53948ab3f45.tar.gz
gentoo-2-0769ff3d1d825f03d5066f6f2604b53948ab3f45.tar.bz2
gentoo-2-0769ff3d1d825f03d5066f6f2604b53948ab3f45.zip
Revision bump: when both pcsc-lite and openct are disabled, build the dynamic CT-API interface only rather than error out. This is useful if you only care about the PKCS#11 utilities, rather than actual Smartcard access.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/opensc/ChangeLog10
-rw-r--r--dev-libs/opensc/metadata.xml41
-rw-r--r--dev-libs/opensc/opensc-0.12.0-r2.ebuild (renamed from dev-libs/opensc/opensc-0.12.0-r1.ebuild)22
3 files changed, 52 insertions, 21 deletions
diff --git a/dev-libs/opensc/ChangeLog b/dev-libs/opensc/ChangeLog
index 2d3575b59b39..cca37ee8352c 100644
--- a/dev-libs/opensc/ChangeLog
+++ b/dev-libs/opensc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/opensc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/opensc/ChangeLog,v 1.112 2011/04/12 20:07:44 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/opensc/ChangeLog,v 1.113 2011/04/18 18:49:57 flameeyes Exp $
+
+*opensc-0.12.0-r2 (18 Apr 2011)
+
+ 18 Apr 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ -opensc-0.12.0-r1.ebuild, +opensc-0.12.0-r2.ebuild, metadata.xml:
+ Revision bump: when both pcsc-lite and openct are disabled, build the dynamic
+ CT-API interface only rather than error out. This is useful if you only care
+ about the PKCS#11 utilities, rather than actual Smartcard access.
12 Apr 2011; Diego E. Pettenò <flameeyes@gentoo.org>
opensc-0.12.0-r1.ebuild:
diff --git a/dev-libs/opensc/metadata.xml b/dev-libs/opensc/metadata.xml
index 02167552fc28..195b2cb7eeda 100644
--- a/dev-libs/opensc/metadata.xml
+++ b/dev-libs/opensc/metadata.xml
@@ -1,21 +1,32 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>crypto</herd>
-<maintainer>
- <email>crypto@gentoo.org</email>
+ <herd>crypto</herd>
+ <maintainer>
+ <email>crypto@gentoo.org</email>
<name>Crypto Herd</name>
-</maintainer>
-<longdescription>
-OpenSC is a library for accessing SmartCard devices. It is also the core library of the OpenSC
-project.
+ </maintainer>
+ <longdescription>
+ OpenSC is a library for accessing SmartCard devices. It is also
+ the core library of the OpenSC project.
-Basic functionality (e.g. SELECT FILE, READ BINARY) should work on any ISO 7816-4 compatible SmartCard.
-Encryption and decryption using private keys on the SmartCard is possible with PKCS #15 compatible
-cards, such as the FINEID (Finnish Electronic IDentity) card.
-</longdescription>
-<use>
- <flag name='openct'>Build using <pkg>dev-libs/openct</pkg> compatibility</flag>
- <flag name='pcsc-lite'>Build with <pkg>sys-apps/pcsc-lite</pkg></flag>
-</use>
+ Basic functionality (e.g. SELECT FILE, READ BINARY) should work on
+ any ISO 7816-4 compatible SmartCard. Encryption and decryption
+ using private keys on the SmartCard is possible with PKCS #15
+ compatible cards, such as the FINEID (Finnish Electronic IDentity)
+ card.
+ </longdescription>
+ <use>
+ <flag name='openct'>
+ Use <pkg>dev-libs/openct</pkg> (and CT-API) for accessing
+ Smartcard hardware. If neither openct nor pcsc-lite are enabled,
+ only CT-API dynamic linking is enabled.
+ </flag>
+
+ <flag name='pcsc-lite'>
+ Use <pkg>sys-apps/pcsc-lite</pkg> (and PC/SC API) for accessing
+ Smartcard hardware. If neither openct nor pcsc-lite are enabled,
+ only CT-API dynamic linking is enabled.
+ </flag>
+ </use>
</pkgmetadata>
diff --git a/dev-libs/opensc/opensc-0.12.0-r1.ebuild b/dev-libs/opensc/opensc-0.12.0-r2.ebuild
index 7989b35c6f15..a8bcd70be6b3 100644
--- a/dev-libs/opensc/opensc-0.12.0-r1.ebuild
+++ b/dev-libs/opensc/opensc-0.12.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/opensc/opensc-0.12.0-r1.ebuild,v 1.2 2011/04/12 20:07:44 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/opensc/opensc-0.12.0-r2.ebuild,v 1.1 2011/04/18 18:49:57 flameeyes Exp $
EAPI="4"
@@ -26,19 +26,31 @@ DEPEND="${RDEPEND}
app-text/docbook-xsl-stylesheets
dev-libs/libxslt"
-REQUIRED_USE="^^ ( pcsc-lite openct )"
+REQUIRED_USE="
+ pcsc-lite? ( !openct )
+ openct? ( !pcsc-lite )"
src_configure() {
+ # disable everything, enable selectively
+ local myconf="--disable-pcsc --disable-openct --disable-ctapi"
+
+ if use pcsc-lite; then
+ myconf+=" --enable-pcsc"
+ elif use openct; then
+ myconf+=" --enable-openct"
+ else
+ myconf+=" --enable-ctapi"
+ fi
+
econf \
--docdir="/usr/share/doc/${PF}" \
--htmldir="/usr/share/doc/${PF}/html" \
--disable-static \
$(use_enable doc) \
$(use_enable openct) \
- $(use_enable pcsc-lite pcsc) \
$(use_enable readline) \
- $(use_enable ssl openssl) \
- $(use_enable zlib)
+ $(use_enable zlib) \
+ ${myconf}
}
src_install() {