summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-05-15 11:03:33 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-05-15 11:03:33 +0000
commit09f8ef988a653f7938c155c106c0581d64095f7b (patch)
treeab52d97eb6c690876a526cd79c3885b64db462c5 /dev-libs
parentRevert QA removal, bug #324961, thank Dustin Polke for report. (diff)
downloadgentoo-2-09f8ef988a653f7938c155c106c0581d64095f7b.tar.gz
gentoo-2-09f8ef988a653f7938c155c106c0581d64095f7b.tar.bz2
gentoo-2-09f8ef988a653f7938c155c106c0581d64095f7b.zip
Add patch to build against python 3.2. Bug #367245
(Portage version: 2.1.9.47/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/boost/ChangeLog6
-rw-r--r--dev-libs/boost/boost-1.46.1.ebuild5
-rw-r--r--dev-libs/boost/files/boost-1.46.1-python32.patch16
3 files changed, 25 insertions, 2 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 3d90b76e3ad9..b5536a26961e 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/boost
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.219 2011/04/16 11:30:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.220 2011/05/15 11:03:33 hwoarang Exp $
+
+ 15 May 2011; Markos Chandras <hwoarang@gentoo.org> boost-1.46.1.ebuild,
+ +files/boost-1.46.1-python32.patch:
+ Add patch to build against python 3.2. Bug #367245
16 Apr 2011; Raúl Porcel <armin76@gentoo.org> boost-1.42.0-r2.ebuild:
ia64/s390/sh stable wrt #344677
diff --git a/dev-libs/boost/boost-1.46.1.ebuild b/dev-libs/boost/boost-1.46.1.ebuild
index 53549a9fa394..7ef031adcbfd 100644
--- a/dev-libs/boost/boost-1.46.1.ebuild
+++ b/dev-libs/boost/boost-1.46.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.46.1.ebuild,v 1.3 2011/04/05 05:23:28 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.46.1.ebuild,v 1.4 2011/05/15 11:03:33 hwoarang Exp $
EAPI="2"
@@ -86,6 +86,9 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}/remove-toolset-${PV}.patch"
epatch "${FILESDIR}/${PN}-1.45.0-lambda_bind.patch"
+
+ # Compile against python 3.2. Bug #367245
+ epatch "${FILESDIR}"/${P}-python32.patch
# This enables building the boost.random library with /dev/urandom support
if [[ -e /dev/urandom ]] ; then
diff --git a/dev-libs/boost/files/boost-1.46.1-python32.patch b/dev-libs/boost/files/boost-1.46.1-python32.patch
new file mode 100644
index 000000000000..5e0583af0f6e
--- /dev/null
+++ b/dev-libs/boost/files/boost-1.46.1-python32.patch
@@ -0,0 +1,16 @@
+Index: libs/python/src/converter/builtin_converters.cpp
+===================================================================
+--- libs/python/src/converter/builtin_converters.cpp (revision 67279)
++++ libs/python/src/converter/builtin_converters.cpp (working copy)
+@@ -431,7 +431,11 @@
+ if (!result.empty())
+ {
+ int err = PyUnicode_AsWideChar(
++#if PY_VERSION_HEX >= 0x03020000
++ intermediate
++#else
+ (PyUnicodeObject *)intermediate
++#endif
+ , &result[0]
+ , result.size());
+