summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-01-26 13:51:06 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-01-26 13:51:06 +0000
commit0c416c9ad26cf27fcbd6a165b674c974a3fe9f46 (patch)
tree5954db8a8a793fe2a3a00c7510701778a8ff5aba /dev-libs
parentAdd kernel.org klibc directory to HOMEPAGE. (diff)
downloadgentoo-2-0c416c9ad26cf27fcbd6a165b674c974a3fe9f46.tar.gz
gentoo-2-0c416c9ad26cf27fcbd6a165b674c974a3fe9f46.tar.bz2
gentoo-2-0c416c9ad26cf27fcbd6a165b674c974a3fe9f46.zip
Build with fox:1.7, bug #494090
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/hidapi/ChangeLog8
-rw-r--r--dev-libs/hidapi/hidapi-0.8.0_pre20130121-r1.ebuild64
-rw-r--r--dev-libs/hidapi/hidapi-0.8.0_pre20130121.ebuild4
3 files changed, 73 insertions, 3 deletions
diff --git a/dev-libs/hidapi/ChangeLog b/dev-libs/hidapi/ChangeLog
index 9e2e0a920577..28ff9ea2b3e8 100644
--- a/dev-libs/hidapi/ChangeLog
+++ b/dev-libs/hidapi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/hidapi
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/hidapi/ChangeLog,v 1.5 2014/01/26 11:44:57 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/hidapi/ChangeLog,v 1.6 2014/01/26 13:51:06 blueness Exp $
+
+*hidapi-0.8.0_pre20130121-r1 (26 Jan 2014)
+
+ 26 Jan 2014; Anthony G. Basile <blueness@gentoo.org>
+ +hidapi-0.8.0_pre20130121-r1.ebuild, hidapi-0.8.0_pre20130121.ebuild:
+ Build with fox:1.7, bug #494090
26 Jan 2014; Agostino Sarubbo <ago@gentoo.org>
hidapi-0.8.0_pre20130121.ebuild:
diff --git a/dev-libs/hidapi/hidapi-0.8.0_pre20130121-r1.ebuild b/dev-libs/hidapi/hidapi-0.8.0_pre20130121-r1.ebuild
new file mode 100644
index 000000000000..dca51c95205a
--- /dev/null
+++ b/dev-libs/hidapi/hidapi-0.8.0_pre20130121-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/hidapi/hidapi-0.8.0_pre20130121-r1.ebuild,v 1.1 2014/01/26 13:51:06 blueness Exp $
+
+EAPI=5
+
+inherit autotools eutils #git-2
+
+# If github is desired, the following may be used.
+#EGIT_REPO_URI="git://github.com/signal11/hidapi.git"
+#EGIT_BRANCH="master"
+#EGIT_COMMIT="119135b8ce0e8db668ec171723d6e56d4394166a"
+
+DESCRIPTION="A multi-platform library for USB and Bluetooth HID-Class devices"
+HOMEPAGE="http://www.signal11.us/oss/hidapi/"
+SRC_URI="http://public.callutheran.edu/~abarker/${P}.tar.xz"
+# When 0.8.0 is officially available the following link should be used.
+#SRC_URI="mirror://github/signal11/${PN}/${P}.zip"
+
+LICENSE="|| ( BSD GPL-3 HIDAPI )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc static-libs X"
+
+# S is only needed for the pre_package
+S=${WORKDIR}/${PN}
+RDEPEND="virtual/libusb:0"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig
+ X? ( x11-libs/fox )"
+
+src_prepare() {
+ if use X && has_version x11-libs/fox:1.7 ; then
+ sed -i -e 's:PKG_CHECK_MODULES(\[fox\], \[fox\]):PKG_CHECK_MODULES(\[fox\], \[fox17\]):' \
+ configure.ac || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable X testgui)
+}
+
+src_compile() {
+ emake
+
+ if use doc; then
+ doxygen doxygen/Doxyfile || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use doc; then
+ dohtml -r html/*
+ fi
+
+ prune_libtool_files
+}
diff --git a/dev-libs/hidapi/hidapi-0.8.0_pre20130121.ebuild b/dev-libs/hidapi/hidapi-0.8.0_pre20130121.ebuild
index e84d56742bf2..fa26c2d717b3 100644
--- a/dev-libs/hidapi/hidapi-0.8.0_pre20130121.ebuild
+++ b/dev-libs/hidapi/hidapi-0.8.0_pre20130121.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/hidapi/hidapi-0.8.0_pre20130121.ebuild,v 1.4 2014/01/26 11:44:57 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/hidapi/hidapi-0.8.0_pre20130121.ebuild,v 1.5 2014/01/26 13:51:06 blueness Exp $
EAPI=4
@@ -28,7 +28,7 @@ RDEPEND="virtual/libusb:0"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
virtual/pkgconfig
- X? ( x11-libs/fox )"
+ X? ( x11-libs/fox:1.6 )"
src_prepare() {
eautoreconf