summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2010-11-18 14:14:59 +0000
committerThomas Sachau <tommy@gentoo.org>2010-11-18 14:14:59 +0000
commit24f4389596c04c8f14e6c53c10893b64134262e4 (patch)
treef5d3127989f4a9f985f430cd6f9eae4a52ad6cbd /dev-libs
parentInitial commit, based on ebuild in enlightenment overlay (diff)
downloadgentoo-2-24f4389596c04c8f14e6c53c10893b64134262e4.tar.gz
gentoo-2-24f4389596c04c8f14e6c53c10893b64134262e4.tar.bz2
gentoo-2-24f4389596c04c8f14e6c53c10893b64134262e4.zip
Initial commit, based on ebuild in enlightenment overlay
(Portage version: 2.2.0_alpha2-r1/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/e_dbus/ChangeLog10
-rw-r--r--dev-libs/e_dbus/e_dbus-1.0.0_beta2.ebuild38
-rw-r--r--dev-libs/e_dbus/metadata.xml13
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/e_dbus/ChangeLog b/dev-libs/e_dbus/ChangeLog
new file mode 100644
index 000000000000..8da9ec31a6e5
--- /dev/null
+++ b/dev-libs/e_dbus/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-libs/e_dbus
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/e_dbus/ChangeLog,v 1.1 2010/11/18 14:14:59 tommy Exp $
+
+*e_dbus-1.0.0_beta2 (18 Nov 2010)
+
+ 18 Nov 2010; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +e_dbus-1.0.0_beta2.ebuild, +metadata.xml:
+ Initial commit, based on ebuild in enlightenment overlay
+
diff --git a/dev-libs/e_dbus/e_dbus-1.0.0_beta2.ebuild b/dev-libs/e_dbus/e_dbus-1.0.0_beta2.ebuild
new file mode 100644
index 000000000000..e60a61be4ff5
--- /dev/null
+++ b/dev-libs/e_dbus/e_dbus-1.0.0_beta2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/e_dbus/e_dbus-1.0.0_beta2.ebuild,v 1.1 2010/11/18 14:14:59 tommy Exp $
+
+EAPI="2"
+
+MY_P=${P/_beta/.beta}
+
+inherit enlightenment
+
+DESCRIPTION="Enlightenment's (Ecore) integration to DBus"
+SRC_URI="http://download.enlightenment.org/releases/${MY_P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth +connman +hal +libnotify ofono static-libs ukit"
+
+RDEPEND=">=dev-libs/eina-1.0.0_beta
+ >=dev-libs/ecore-1.0.0_beta
+ sys-apps/dbus
+ libnotify? ( >=media-libs/evas-1.0.0_beta )
+ hal? ( sys-apps/hal )
+ ukit? ( sys-power/upower sys-fs/udisks )
+"
+DEPEND="${RDEPEND}"
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ MY_ECONF="
+ $(use_enable bluetooth ebluez)
+ $(use_enable connman econnman)
+ $(use_enable doc)
+ $(use_enable hal ehal)
+ $(use_enable libnotify enotify)
+ $(use_enable ofono eofono)
+ $(use_enable ukit eukit)
+ "
+ enlightenment_src_configure
+}
diff --git a/dev-libs/e_dbus/metadata.xml b/dev-libs/e_dbus/metadata.xml
new file mode 100644
index 000000000000..3c8a84ec01c4
--- /dev/null
+++ b/dev-libs/e_dbus/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>enlightenment</herd>
+<use>
+ <flag name="ukit">Enable interfacing with <pkg>sys-power/upower</pkg> and <pkg>sys-fs/udisks</pkg> DBus API.</flag>
+ <flag name="hal">Enable interfacing with <pkg>sys-apps/hal</pkg> DBus API.</flag>
+ <flag name="connman">Enable interfacing with <pkg>net-misc/connman</pkg> DBus API.</flag>
+ <flag name="libnotify">Enable interfacing with <pkg>x11-libs/libnotify</pkg> DBus API.</flag>
+ <flag name="bluetooth">Enable interfacing with <pkg>net-wireless/bluez</pkg> DBus API.</flag>
+ <flag name="ofono">Enable interfacing with <pkg>net-misc/ofono</pkg> DBus API.</flag>
+</use>
+</pkgmetadata>