summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2004-12-11 18:03:34 +0000
committerDaniel Goller <morfic@gentoo.org>2004-12-11 18:03:34 +0000
commit277f833ee9a31d013b52679a875989cdc610ee07 (patch)
tree7de34a9013add267632a07dd8bffcbd46d24793f /dev-libs
parent (Manifest recommit) (diff)
downloadgentoo-2-277f833ee9a31d013b52679a875989cdc610ee07.tar.gz
gentoo-2-277f833ee9a31d013b52679a875989cdc610ee07.tar.bz2
gentoo-2-277f833ee9a31d013b52679a875989cdc610ee07.zip
fixed up ${arch} for amd64
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/boost/ChangeLog5
-rw-r--r--dev-libs/boost/boost-1.32.0.ebuild11
2 files changed, 13 insertions, 3 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index a8ba92b1e7ff..371e30321e11 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.24 2004/12/11 17:31:52 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.25 2004/12/11 18:03:34 morfic Exp $
+
+ 11 Dec 2004; Daniel Goller <morfic@gentoo.org> boost-1.32.0.ebuild:
+ fixed up ${arch} to cover amd64 as not being recognized
11 Dec 2004; Daniel Goller <morfic@gentoo.org> boost-1.32.0.ebuild:
Added ${arch} to bjam path
diff --git a/dev-libs/boost/boost-1.32.0.ebuild b/dev-libs/boost/boost-1.32.0.ebuild
index 0844c81e47d3..6bdb628782a0 100644
--- a/dev-libs/boost/boost-1.32.0.ebuild
+++ b/dev-libs/boost/boost-1.32.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.32.0.ebuild,v 1.2 2004/12/11 17:31:52 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.32.0.ebuild,v 1.3 2004/12/11 18:03:34 morfic Exp $
# This ebuild was generated by Ebuilder v0.4.
@@ -20,6 +20,13 @@ KEYWORDS="~x86 ~ppc ~amd64 ~sparc ~ppc64"
src_compile() {
local PYTHON_VERSION=$(/usr/bin/python -V 2>&1 | sed 's/Python \([0-9][0-9]*\.[0-9][0-9]*\)\..*/\1/')
+ local arch
+
+ if [ "${ARCH}" == "amd64" ]; then
+ arch=
+ else
+ arch=${ARCH}
+ fi
# Build bjam, a jam variant, which is used instead of make
cd ${S}/tools/build/jam_src
@@ -40,7 +47,7 @@ src_compile() {
src_install () {
local PYTHON_VERSION=$(/usr/bin/python -V 2>&1 | sed 's/Python \([0-9][0-9]*\.[0-9][0-9]*\)\..*/\1/')
- ./tools/build/jam_src/bin.linux${arch}/bjam \
+ ./tools/build/jam_src/bin.linux${arch}/bjam ${MAKEOPTS} \
-sBOOST_ROOT=${S} \
-sPYTHON_ROOT=/usr \
-sPYTHON_VERSION=${PYTHON_VERSION} \