summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2009-05-05 13:25:23 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2009-05-05 13:25:23 +0000
commit2df172ecb546254e80fc94ae8f4d5b61864fab93 (patch)
tree64cc54d85318cdaac73dbda38a21002d3a5adc2c /dev-libs
parentMarked ~hppa (bug #268615). (diff)
downloadgentoo-2-2df172ecb546254e80fc94ae8f4d5b61864fab93.tar.gz
gentoo-2-2df172ecb546254e80fc94ae8f4d5b61864fab93.tar.bz2
gentoo-2-2df172ecb546254e80fc94ae8f4d5b61864fab93.zip
dev-util/gtk-doc-1.11 is in-tree (bug 267940), re-add USE=doc. Also,
fix RESTRICT=test, upstream bgnomeo 577774 (Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/totem-pl-parser/ChangeLog8
-rw-r--r--dev-libs/totem-pl-parser/files/totem-pl-parser-2.26.1-fix-tests-without-gtk-doc.patch11
-rw-r--r--dev-libs/totem-pl-parser/totem-pl-parser-2.26.1.ebuild34
3 files changed, 42 insertions, 11 deletions
diff --git a/dev-libs/totem-pl-parser/ChangeLog b/dev-libs/totem-pl-parser/ChangeLog
index 78391014a465..525bbcdaa833 100644
--- a/dev-libs/totem-pl-parser/ChangeLog
+++ b/dev-libs/totem-pl-parser/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/totem-pl-parser
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/totem-pl-parser/ChangeLog,v 1.27 2009/04/30 15:51:21 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/totem-pl-parser/ChangeLog,v 1.28 2009/05/05 13:25:23 nirbheek Exp $
+
+ 05 May 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
+ totem-pl-parser-2.26.1.ebuild,
+ +files/totem-pl-parser-2.26.1-fix-tests-without-gtk-doc.patch:
+ dev-util/gtk-doc-1.11 is in-tree (bug 267940), re-add USE=doc. Also,
+ fix RESTRICT=test, upstream bgnomeo 577774
30 Apr 2009; Daniel Gryniewicz <dang@gentoo.org>
totem-pl-parser-2.26.1.ebuild:
diff --git a/dev-libs/totem-pl-parser/files/totem-pl-parser-2.26.1-fix-tests-without-gtk-doc.patch b/dev-libs/totem-pl-parser/files/totem-pl-parser-2.26.1-fix-tests-without-gtk-doc.patch
new file mode 100644
index 000000000000..6d38c4de4ce3
--- /dev/null
+++ b/dev-libs/totem-pl-parser/files/totem-pl-parser-2.26.1-fix-tests-without-gtk-doc.patch
@@ -0,0 +1,11 @@
+diff -Naur totem-pl-parser-2.26.1/docs/reference/Makefile.am totem-pl-parser-2.26.1.new/docs/reference/Makefile.am
+--- totem-pl-parser-2.26.1/docs/reference/Makefile.am 2009-03-23 20:03:17.000000000 +0530
++++ totem-pl-parser-2.26.1.new/docs/reference/Makefile.am 2009-05-05 17:23:56.184865429 +0530
+@@ -96,5 +96,7 @@
+ # e.g. EXTRA_DIST += version.xml.in
+ EXTRA_DIST += version.xml.in
+
++if ENABLE_GTK_DOC
+ TESTS_ENVIRONMENT = cd $(srcdir) &&
+ TESTS = $(GTKDOC_CHECK)
++endif
diff --git a/dev-libs/totem-pl-parser/totem-pl-parser-2.26.1.ebuild b/dev-libs/totem-pl-parser/totem-pl-parser-2.26.1.ebuild
index c56f30236693..081821b3aca6 100644
--- a/dev-libs/totem-pl-parser/totem-pl-parser-2.26.1.ebuild
+++ b/dev-libs/totem-pl-parser/totem-pl-parser-2.26.1.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/totem-pl-parser/totem-pl-parser-2.26.1.ebuild,v 1.2 2009/04/30 15:51:21 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/totem-pl-parser/totem-pl-parser-2.26.1.ebuild,v 1.3 2009/05/05 13:25:23 nirbheek Exp $
+
+EAPI="2"
GCONF_DEBUG="no"
-inherit gnome2
+inherit autotools eutils gnome2
DESCRIPTION="Playlist parsing library"
HOMEPAGE="http://www.gnome.org/projects/totem/"
@@ -12,22 +14,34 @@ HOMEPAGE="http://www.gnome.org/projects/totem/"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="hal"
+IUSE="doc hal test"
RDEPEND=">=dev-libs/glib-2.17.3
>=x11-libs/gtk+-2.12
>=gnome-extra/evolution-data-server-1.12"
DEPEND="${RDEPEND}
!<media-video/totem-2.21
- >=dev-util/intltool-0.35"
-# re-enable doc when gtk-doc-1.11 gets in the tree
-# doc? ( >=dev-util/gtk-doc-1.11 )"
-
-# FIXME: tests broken with USE="-doc" upstream bug #577774
-RESTRICT="test"
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1.11 )"
G2CONF="${G2CONF} --disable-static"
+src_prepare() {
+ gnome2_src_prepare
+
+ # Conditional patching is purely to avoid eautoreconf
+ if use test && ! use doc; then
+ epatch "${FILESDIR}/${P}-fix-tests-without-gtk-doc.patch"
+ eautoreconf
+ fi
+}
+
src_install() {
- emake DESTDIR="${D}" install || die "install failed"
+ if use test && ! use doc; then
+ # Weird bug with empty GTKDOC_REBASE because of above patch
+ local gtkdoc_rebase="! which gtkdoc-rebase >/dev/null 2>&1 || gtkdoc-rebase"
+ emake DESTDIR="${D}" GTKDOC_REBASE="${gtkdoc_rebase}" install || die "install failed"
+ else
+ emake DESTDIR="${D}" install || die "install failed"
+ fi
}