summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-05-30 07:06:24 +0000
committerTim Harder <radhermit@gentoo.org>2012-05-30 07:06:24 +0000
commit38f9044f8ae293ab34285a0f24dadcc2549248b1 (patch)
treebe5bd19eda565dfd9227d840d29a0f4017e7fe15 /dev-libs
parentmarked x86 per bug 417607 (diff)
downloadgentoo-2-38f9044f8ae293ab34285a0f24dadcc2549248b1.tar.gz
gentoo-2-38f9044f8ae293ab34285a0f24dadcc2549248b1.tar.bz2
gentoo-2-38f9044f8ae293ab34285a0f24dadcc2549248b1.zip
Version bump.
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libexplain/ChangeLog7
-rw-r--r--dev-libs/libexplain/libexplain-1.0.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-libs/libexplain/ChangeLog b/dev-libs/libexplain/ChangeLog
index 165ca06a3b81..97a02cb09066 100644
--- a/dev-libs/libexplain/ChangeLog
+++ b/dev-libs/libexplain/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libexplain
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libexplain/ChangeLog,v 1.19 2012/03/04 22:15:29 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libexplain/ChangeLog,v 1.20 2012/05/30 07:06:24 radhermit Exp $
+
+*libexplain-1.0 (30 May 2012)
+
+ 30 May 2012; Tim Harder <radhermit@gentoo.org> +libexplain-1.0.ebuild:
+ Version bump.
04 Mar 2012; Tim Harder <radhermit@gentoo.org> -libexplain-0.50.ebuild:
Remove old.
diff --git a/dev-libs/libexplain/libexplain-1.0.ebuild b/dev-libs/libexplain/libexplain-1.0.ebuild
new file mode 100644
index 000000000000..b098ba0ace2c
--- /dev/null
+++ b/dev-libs/libexplain/libexplain-1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libexplain/libexplain-1.0.ebuild,v 1.1 2012/05/30 07:06:24 radhermit Exp $
+
+EAPI=4
+AUTOTOOLS_AUTORECONF=yes
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils
+
+MY_P="${P}.D001"
+
+DESCRIPTION="Library which may be used to explain Unix and Linux system call errors"
+HOMEPAGE="http://libexplain.sourceforge.net/"
+SRC_URI="http://libexplain.sourceforge.net/${MY_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+IUSE="static-libs"
+
+DEPEND="
+ >=sys-kernel/linux-headers-2.6.35
+ sys-libs/libcap
+ >=sys-libs/glibc-2.11"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.45-configure.patch
+)
+
+src_prepare() {
+ # Portage incompatible test
+ sed \
+ -e '/t0524a/d' \
+ -e '/t0363a/d' \
+ -i Makefile.in || die
+
+ cp "${S}"/etc/configure.ac "${S}"
+
+ autotools-utils_src_prepare
+}