summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-10-28 21:15:38 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-10-28 21:15:38 +0000
commit3a0ceaf9f0dcbb657864b0c09d22581d6976205b (patch)
tree645d26849c7aed9ec14801d1f234e40fa7525508 /dev-libs
parentamd64/ppc64 stable wrt #343155 (diff)
downloadgentoo-2-3a0ceaf9f0dcbb657864b0c09d22581d6976205b.tar.gz
gentoo-2-3a0ceaf9f0dcbb657864b0c09d22581d6976205b.tar.bz2
gentoo-2-3a0ceaf9f0dcbb657864b0c09d22581d6976205b.zip
Version bump. Fix various ebuild issues and most notably html tutorial generation, bug #340198.
(Portage version: 2.2.0_alpha1/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/gmime/ChangeLog9
-rw-r--r--dev-libs/gmime/gmime-2.4.19.ebuild27
-rw-r--r--dev-libs/gmime/gmime-2.4.20.ebuild82
3 files changed, 109 insertions, 9 deletions
diff --git a/dev-libs/gmime/ChangeLog b/dev-libs/gmime/ChangeLog
index 0f0e01d49e1a..62543d850200 100644
--- a/dev-libs/gmime/ChangeLog
+++ b/dev-libs/gmime/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/gmime
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/ChangeLog,v 1.124 2010/09/13 16:33:47 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/ChangeLog,v 1.125 2010/10/28 21:15:38 eva Exp $
+
+*gmime-2.4.20 (28 Oct 2010)
+
+ 28 Oct 2010; Gilles Dartiguelongue <eva@gentoo.org> gmime-2.4.19.ebuild,
+ +gmime-2.4.20.ebuild:
+ Version bump. Fix various ebuild issues and most notably html tutorial
+ generation, bug #340198.
*gmime-2.4.19 (13 Sep 2010)
diff --git a/dev-libs/gmime/gmime-2.4.19.ebuild b/dev-libs/gmime/gmime-2.4.19.ebuild
index ed48651248dc..679810958904 100644
--- a/dev-libs/gmime/gmime-2.4.19.ebuild
+++ b/dev-libs/gmime/gmime-2.4.19.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/gmime-2.4.19.ebuild,v 1.1 2010/09/13 16:33:47 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/gmime-2.4.19.ebuild,v 1.2 2010/10/28 21:15:38 eva Exp $
+
+EAPI="2"
inherit gnome2 eutils mono libtool
@@ -24,17 +26,18 @@ DEPEND="${RDEPEND}
app-text/docbook-sgml-utils )
mono? ( dev-dotnet/gtk-sharp-gapi )"
-DOCS="AUTHORS ChangeLog NEWS PORTING README TODO doc/html/"
+DOCS="AUTHORS ChangeLog NEWS PORTING README TODO"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
+ gnome2_src_prepare
if use doc ; then
# db2html should be docbook2html
+ sed -i -e 's:db2html:docbook2html:' \
+ configure.in configure || die "sed failed (1)"
sed -i -e 's:db2html:docbook2html -o gmime-tut:g' \
docs/tutorial/Makefile.am docs/tutorial/Makefile.in \
- || die "sed failed (1)"
+ || die "sed failed (2)"
# Fix doc targets (bug #97154)
sed -i -e 's!\<\(tmpl-build.stamp\): !\1 $(srcdir)/tmpl/*.sgml: !' \
gtk-doc.make docs/reference/Makefile.in || die "sed failed (3)"
@@ -44,14 +47,20 @@ src_unpack() {
sed -i -e 's:^libdir.*:libdir=@libdir@:' \
-e 's:^prefix=:exec_prefix=:' \
-e 's:prefix)/lib:libdir):' \
- mono/gmime-sharp-2.4.pc.in mono/Makefile.{am,in} || die "sed failed (2)"
+ mono/gmime-sharp-2.4.pc.in mono/Makefile.{am,in} || die "sed failed (4)"
elibtoolize
}
-src_compile() {
+src_configure() {
econf $(use_enable mono) $(use_enable doc gtk-doc) --enable-cryptography
+}
+
+src_compile() {
MONO_PATH="${S}" emake || die "emake failed"
+ if use doc; then
+ emake -C docs/tutorial html || die "emake html failed"
+ fi
}
src_install() {
@@ -64,6 +73,8 @@ src_install() {
doins docs/tutorial/html/*
fi
+ dodoc $DOCS || die "dodoc failed"
+
# rename these two, so they don't conflict with app-arch/sharutils
# (bug #70392) Ticho, 2004-11-10
mv "${D}/usr/bin/uuencode" "${D}/usr/bin/gmime-uuencode-${SLOT}"
diff --git a/dev-libs/gmime/gmime-2.4.20.ebuild b/dev-libs/gmime/gmime-2.4.20.ebuild
new file mode 100644
index 000000000000..41044a4f7543
--- /dev/null
+++ b/dev-libs/gmime/gmime-2.4.20.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/gmime-2.4.20.ebuild,v 1.1 2010/10/28 21:15:38 eva Exp $
+
+EAPI="2"
+
+inherit gnome2 eutils mono libtool
+
+DESCRIPTION="Utilities for creating and parsing messages using MIME"
+HOMEPAGE="http://spruce.sourceforge.net/gmime/"
+
+SLOT="2.4"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc mono"
+
+RDEPEND=">=dev-libs/glib-2.12
+ sys-libs/zlib
+ mono? (
+ dev-lang/mono
+ >=dev-dotnet/gtk-sharp-2.4.0 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? (
+ >=dev-util/gtk-doc-1.8
+ app-text/docbook-sgml-utils )
+ mono? ( dev-dotnet/gtk-sharp-gapi )"
+
+DOCS="AUTHORS ChangeLog NEWS PORTING README TODO"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ if use doc ; then
+ # db2html should be docbook2html
+ sed -i -e 's:db2html:docbook2html:' \
+ configure.in configure || die "sed failed (1)"
+ sed -i -e 's:db2html:docbook2html -o gmime-tut:g' \
+ docs/tutorial/Makefile.am docs/tutorial/Makefile.in \
+ || die "sed failed (2)"
+ # Fix doc targets (bug #97154)
+ sed -i -e 's!\<\(tmpl-build.stamp\): !\1 $(srcdir)/tmpl/*.sgml: !' \
+ gtk-doc.make docs/reference/Makefile.in || die "sed failed (3)"
+ fi
+
+ # Use correct libdir for mono assembly
+ sed -i -e 's:^libdir.*:libdir=@libdir@:' \
+ -e 's:^prefix=:exec_prefix=:' \
+ -e 's:prefix)/lib:libdir):' \
+ mono/gmime-sharp-2.4.pc.in mono/Makefile.{am,in} || die "sed failed (4)"
+
+ elibtoolize
+}
+
+src_configure() {
+ econf $(use_enable mono) $(use_enable doc gtk-doc) --enable-cryptography
+}
+
+src_compile() {
+ MONO_PATH="${S}" emake || die "emake failed"
+ if use doc; then
+ emake -C docs/tutorial html || die "emake html failed"
+ fi
+}
+
+src_install() {
+ emake GACUTIL_FLAGS="/root '${D}/usr/$(get_libdir)' /gacdir /usr/$(get_libdir) /package ${PN}" \
+ DESTDIR="${D}" install || die "installation failed"
+
+ if use doc ; then
+ # we don't use docinto/dodoc, because we don't want html doc gzipped
+ insinto /usr/share/doc/${PF}/tutorial
+ doins docs/tutorial/html/*
+ fi
+
+ dodoc $DOCS || die "dodoc failed"
+
+ # rename these two, so they don't conflict with app-arch/sharutils
+ # (bug #70392) Ticho, 2004-11-10
+ mv "${D}/usr/bin/uuencode" "${D}/usr/bin/gmime-uuencode-${SLOT}"
+ mv "${D}/usr/bin/uudecode" "${D}/usr/bin/gmime-uudecode-${SLOT}"
+}