summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-03 03:24:29 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-03 03:24:29 +0000
commit3aae3c7733142fa48f5b3b9768c1f0f567d364e6 (patch)
tree559a3909a7cf6bc3b50f5924374f6065c0c8e47c /dev-libs
parentstabilize (diff)
downloadgentoo-2-3aae3c7733142fa48f5b3b9768c1f0f567d364e6.tar.gz
gentoo-2-3aae3c7733142fa48f5b3b9768c1f0f567d364e6.tar.bz2
gentoo-2-3aae3c7733142fa48f5b3b9768c1f0f567d364e6.zip
Fixes by Bruce Guenter to build a shared library #124692.
(Portage version: 2.1_pre5-r2)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libtommath/ChangeLog10
-rw-r--r--dev-libs/libtommath/files/digest-libtommath-0.36-r11
-rw-r--r--dev-libs/libtommath/files/libtommath-0.36-shared-lib.patch18
-rw-r--r--dev-libs/libtommath/libtommath-0.36-r1.ebuild33
-rw-r--r--dev-libs/libtommath/libtommath-0.36.ebuild4
5 files changed, 62 insertions, 4 deletions
diff --git a/dev-libs/libtommath/ChangeLog b/dev-libs/libtommath/ChangeLog
index 8753f688e1ad..618f3fcc5907 100644
--- a/dev-libs/libtommath/ChangeLog
+++ b/dev-libs/libtommath/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libtommath
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/ChangeLog,v 1.14 2005/10/11 18:39:17 grobian Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/ChangeLog,v 1.15 2006/03/03 03:24:28 vapier Exp $
+
+*libtommath-0.36-r1 (03 Mar 2006)
+
+ 03 Mar 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/libtommath-0.36-shared-lib.patch, +libtommath-0.36-r1.ebuild:
+ Fixes by Bruce Guenter to build a shared library #124692.
11 Oct 2005; Fabian Groffen <grobian@gentoo.org> libtommath-0.36.ebuild:
Marked ~ppc-macos (bug #108462)
diff --git a/dev-libs/libtommath/files/digest-libtommath-0.36-r1 b/dev-libs/libtommath/files/digest-libtommath-0.36-r1
new file mode 100644
index 000000000000..ca35fa04a92c
--- /dev/null
+++ b/dev-libs/libtommath/files/digest-libtommath-0.36-r1
@@ -0,0 +1 @@
+MD5 cd4f9305e1b721b3c3eb7bcdc25abfc6 ltm-0.36.tar.bz2 1924150
diff --git a/dev-libs/libtommath/files/libtommath-0.36-shared-lib.patch b/dev-libs/libtommath/files/libtommath-0.36-shared-lib.patch
new file mode 100644
index 000000000000..4ad81df66f39
--- /dev/null
+++ b/dev-libs/libtommath/files/libtommath-0.36-shared-lib.patch
@@ -0,0 +1,18 @@
+patch by Bruce Guenter
+
+http://bugs.gentoo.org/124692
+
+--- libtommath-0.36/makefile.shared
++++ libtommath-0.36/makefile.shared
+@@ -84,7 +84,10 @@
+ libtool --mode=link gcc *.lo -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION)
+ libtool --mode=link gcc *.o -o $(LIBNAME_S)
+ ranlib $(LIBNAME_S)
+- libtool --mode=install install -c $(LIBNAME) $(LIBPATH)/$@
++
++install: $(LIBNAME) $(HEADERS)
++ install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(LIBPATH)
++ libtool --mode=install install -c $(LIBNAME) $(DESTDIR)$(LIBPATH)/$@
+ install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(INCPATH)
+ install -g $(GROUP) -o $(USER) $(HEADERS) $(DESTDIR)$(INCPATH)
+
diff --git a/dev-libs/libtommath/libtommath-0.36-r1.ebuild b/dev-libs/libtommath/libtommath-0.36-r1.ebuild
new file mode 100644
index 000000000000..9a0603ec33b7
--- /dev/null
+++ b/dev-libs/libtommath/libtommath-0.36-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/libtommath-0.36-r1.ebuild,v 1.1 2006/03/03 03:24:28 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="highly optimized and portable routines for integer based number theoretic applications"
+HOMEPAGE="http://math.libtomcrypt.org/"
+SRC_URI="http://math.libtomcrypt.org/files/ltm-${PV}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~x86"
+IUSE=""
+
+DEPEND="sys-devel/libtool"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-shared-lib.patch
+}
+
+src_compile() {
+ emake -f makefile.shared IGNORE_SPEED=1 || die
+}
+
+src_install() {
+ make -f makefile.shared install DESTDIR="${D}" || die
+ dodoc changes.txt *.pdf
+ docinto demo ; dodoc demo/*
+}
diff --git a/dev-libs/libtommath/libtommath-0.36.ebuild b/dev-libs/libtommath/libtommath-0.36.ebuild
index d74a0558daac..d22f064b9f65 100644
--- a/dev-libs/libtommath/libtommath-0.36.ebuild
+++ b/dev-libs/libtommath/libtommath-0.36.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/libtommath-0.36.ebuild,v 1.4 2006/03/03 03:24:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/libtommath-0.36.ebuild,v 1.5 2006/03/03 03:24:28 vapier Exp $
DESCRIPTION="highly optimized and portable routines for integer based number theoretic applications"
HOMEPAGE="http://math.libtomcrypt.org/"