summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2010-02-26 07:56:48 +0000
committerTiziano Müller <dev-zero@gentoo.org>2010-02-26 07:56:48 +0000
commit4dcde2c3668899e0a85036e8bc18989b2d34f33b (patch)
tree92d2d398fe0b95712660a0746929afbdd584de67 /dev-libs
parentConvert to ruby-fakegem. (diff)
downloadgentoo-2-4dcde2c3668899e0a85036e8bc18989b2d34f33b.tar.gz
gentoo-2-4dcde2c3668899e0a85036e8bc18989b2d34f33b.tar.bz2
gentoo-2-4dcde2c3668899e0a85036e8bc18989b2d34f33b.zip
Version bump. Fixes compilation with xerces-c-3.1.0.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xqilla/ChangeLog8
-rw-r--r--dev-libs/xqilla/files/2.2.3-xerces-c-3.1.0.patch21
-rw-r--r--dev-libs/xqilla/xqilla-2.2.0.ebuild6
-rw-r--r--dev-libs/xqilla/xqilla-2.2.3.ebuild62
4 files changed, 93 insertions, 4 deletions
diff --git a/dev-libs/xqilla/ChangeLog b/dev-libs/xqilla/ChangeLog
index 748600662df0..b3f290a338aa 100644
--- a/dev-libs/xqilla/ChangeLog
+++ b/dev-libs/xqilla/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/xqilla
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xqilla/ChangeLog,v 1.9 2010/02/26 05:41:34 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xqilla/ChangeLog,v 1.10 2010/02/26 07:56:47 dev-zero Exp $
+
+*xqilla-2.2.3 (26 Feb 2010)
+
+ 26 Feb 2010; Tiziano Müller <dev-zero@gentoo.org> xqilla-2.2.0.ebuild,
+ +xqilla-2.2.3.ebuild, +files/2.2.3-xerces-c-3.1.0.patch:
+ Version bump. Fixes compilation with xerces-c-3.1.0.
26 Feb 2010; Mark Loeser <halcy0n@gentoo.org> -xqilla-2.1.3-r1.ebuild:
Drop old versions that depend on <xerces-c-3
diff --git a/dev-libs/xqilla/files/2.2.3-xerces-c-3.1.0.patch b/dev-libs/xqilla/files/2.2.3-xerces-c-3.1.0.patch
new file mode 100644
index 000000000000..cd5d73529f7b
--- /dev/null
+++ b/dev-libs/xqilla/files/2.2.3-xerces-c-3.1.0.patch
@@ -0,0 +1,21 @@
+diff -Naur XQilla-2.2.3.orig/src/schema/SchemaValidatorFilter.cpp XQilla-2.2.3/src/schema/SchemaValidatorFilter.cpp
+--- XQilla-2.2.3.orig/src/schema/SchemaValidatorFilter.cpp 2010-02-26 08:11:53.899266592 +0100
++++ XQilla-2.2.3/src/schema/SchemaValidatorFilter.cpp 2010-02-26 08:43:08.309105237 +0100
+@@ -710,7 +710,7 @@
+
+ if(prefixColonPos == -1) {
+ bool unknown = false;
+- return fElemStack.mapPrefixToURI(XMLUni::fgZeroLenString, (ElemStack::MapModes) mode, unknown);
++ return fElemStack.mapPrefixToURI(XMLUni::fgZeroLenString, unknown);
+ }
+ else {
+ prefixBuf.set(qName, prefixColonPos);
+@@ -726,7 +726,7 @@
+ }
+ else {
+ bool unknown = false;
+- unsigned int uriId = fElemStack.mapPrefixToURI(prefixBuf.getRawBuffer(), (ElemStack::MapModes) mode, unknown);
++ unsigned int uriId = fElemStack.mapPrefixToURI(prefixBuf.getRawBuffer(), unknown);
+
+ if(unknown)
+ emitError(XMLErrs::UnknownPrefix, prefixBuf.getRawBuffer());
diff --git a/dev-libs/xqilla/xqilla-2.2.0.ebuild b/dev-libs/xqilla/xqilla-2.2.0.ebuild
index 1e2b71f21f1e..5bead0cf55c8 100644
--- a/dev-libs/xqilla/xqilla-2.2.0.ebuild
+++ b/dev-libs/xqilla/xqilla-2.2.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xqilla/xqilla-2.2.0.ebuild,v 1.2 2009/08/10 12:40:06 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xqilla/xqilla-2.2.0.ebuild,v 1.3 2010/02/26 07:56:47 dev-zero Exp $
EAPI="2"
inherit eutils
@@ -20,7 +20,7 @@ IUSE="debug doc faxpp htmltidy"
# - yajl, moderately patched
# There's currently no way to unbundle those
-RDEPEND=">=dev-libs/xerces-c-3.0.1
+RDEPEND="=dev-libs/xerces-c-3.0*
faxpp? ( dev-libs/faxpp )
htmltidy? ( app-text/htmltidy )"
DEPEND="${RDEPEND}
diff --git a/dev-libs/xqilla/xqilla-2.2.3.ebuild b/dev-libs/xqilla/xqilla-2.2.3.ebuild
new file mode 100644
index 000000000000..8eecce8533a2
--- /dev/null
+++ b/dev-libs/xqilla/xqilla-2.2.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xqilla/xqilla-2.2.3.ebuild,v 1.1 2010/02/26 07:56:47 dev-zero Exp $
+
+EAPI="2"
+inherit eutils
+
+MY_P="XQilla-${PV}"
+
+DESCRIPTION="An XQuery and XPath 2 library and command line utility written in C++."
+HOMEPAGE="http://xqilla.sourceforge.net/HomePage"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc faxpp htmltidy"
+
+# XQilla bundles two libraries:
+# - mapm, heavily patched
+# - yajl, moderately patched
+# There's currently no way to unbundle those
+
+RDEPEND=">=dev-libs/xerces-c-3.1.0
+ faxpp? ( dev-libs/faxpp )
+ htmltidy? ( app-text/htmltidy )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-xerces-c-3.1.0.patch"
+ sed -i -e 's|^LDFLAGS =|LDFLAGS +=|' Makefile.in || die "sed failed"
+}
+
+src_configure() {
+ econf \
+ --with-xerces=/usr \
+ $(use_enable debug) \
+ $(use_with htmltidy tidy) \
+ $(use_with faxpp faxpp /usr)
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ emake docs || die "emake docs failed"
+ emake devdocs || die "emake devdocs failed"
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake docs failed"
+
+ dodoc ChangeLog TODO
+
+ if use doc; then
+ cd docs
+ dohtml -r dev-api dom3-api simple-api
+ fi
+}