summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Stewart <vericgar@gentoo.org>2006-10-15 20:22:29 +0000
committerMichael Stewart <vericgar@gentoo.org>2006-10-15 20:22:29 +0000
commit620fdd04dba2e4fd349d1c8e484d83cf106cb9c4 (patch)
treec5003be9682ad8604fd25794135647beb03bcc2b /dev-libs
parentUpdate to Linux 2.6.17.14 (diff)
downloadgentoo-2-620fdd04dba2e4fd349d1c8e484d83cf106cb9c4.tar.gz
gentoo-2-620fdd04dba2e4fd349d1c8e484d83cf106cb9c4.tar.bz2
gentoo-2-620fdd04dba2e4fd349d1c8e484d83cf106cb9c4.zip
Remove aprutil.exp as it's not used and causes collisions between SLOTs
(Portage version: 2.1.2_pre2)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/apr-util/ChangeLog6
-rw-r--r--dev-libs/apr-util/apr-util-0.9.12.ebuild7
-rw-r--r--dev-libs/apr-util/apr-util-1.2.7.ebuild6
3 files changed, 16 insertions, 3 deletions
diff --git a/dev-libs/apr-util/ChangeLog b/dev-libs/apr-util/ChangeLog
index c263a1bf6318..6c2dc3dc0593 100644
--- a/dev-libs/apr-util/ChangeLog
+++ b/dev-libs/apr-util/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/apr-util
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.63 2006/09/10 17:32:36 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.64 2006/10/15 20:22:29 vericgar Exp $
+
+ 15 Oct 2006; Michael Stewart <vericgar@gentoo.org> apr-util-0.9.12.ebuild,
+ apr-util-1.2.7.ebuild:
+ Remove aprutil.exp as it's not used and causes collisions between SLOTs
10 Sep 2006; Javier Villavicencio <the_paya@gentoo.org>
apr-util-1.2.7.ebuild:
diff --git a/dev-libs/apr-util/apr-util-0.9.12.ebuild b/dev-libs/apr-util/apr-util-0.9.12.ebuild
index fb0f7cd62fb1..518814513463 100644
--- a/dev-libs/apr-util/apr-util-0.9.12.ebuild
+++ b/dev-libs/apr-util/apr-util-0.9.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-0.9.12.ebuild,v 1.15 2006/09/05 05:21:56 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-0.9.12.ebuild,v 1.16 2006/10/15 20:22:29 vericgar Exp $
inherit eutils flag-o-matic libtool db-use
@@ -66,4 +66,9 @@ src_install() {
# Will install as portage user when using userpriv. Fixing
chown -R root:0 ${D}/usr/include/apr-0/
+
+ # This file is only used on AIX systems, which gentoo is not,
+ # and causes collisions between the SLOTs, so kill it
+ rm ${D}/usr/$(get_libdir)/aprutil.exp
+
}
diff --git a/dev-libs/apr-util/apr-util-1.2.7.ebuild b/dev-libs/apr-util/apr-util-1.2.7.ebuild
index 2b91b9d8f0e8..fe5fd3cbf6d3 100644
--- a/dev-libs/apr-util/apr-util-1.2.7.ebuild
+++ b/dev-libs/apr-util/apr-util-1.2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-1.2.7.ebuild,v 1.6 2006/09/10 17:32:36 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-1.2.7.ebuild,v 1.7 2006/10/15 20:22:29 vericgar Exp $
inherit eutils flag-o-matic libtool db-use
@@ -60,4 +60,8 @@ src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc CHANGES NOTICE
+
+ # This file is only used on AIX systems, which gentoo is not,
+ # and causes collisions between the SLOTs, so kill it
+ rm ${D}/usr/$(get_libdir)/aprutil.exp
}