summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2011-07-31 11:47:57 +0000
committerPatrick Lauer <patrick@gentoo.org>2011-07-31 11:47:57 +0000
commit78ae19b45adc4123c4352c783419143e0e0ece4a (patch)
treeb72af38072390b68dfdd9c5623ad3557b68c6532 /dev-libs
parentalpha/arm/ia64/s390/sh/sparc stable wrt #374589 (diff)
downloadgentoo-2-78ae19b45adc4123c4352c783419143e0e0ece4a.tar.gz
gentoo-2-78ae19b45adc4123c4352c783419143e0e0ece4a.tar.bz2
gentoo-2-78ae19b45adc4123c4352c783419143e0e0ece4a.zip
Bump for #352078
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/distorm64/ChangeLog9
-rw-r--r--dev-libs/distorm64/distorm64-3.1.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-libs/distorm64/ChangeLog b/dev-libs/distorm64/ChangeLog
index 3d9611f1c451..409b9cb3d235 100644
--- a/dev-libs/distorm64/ChangeLog
+++ b/dev-libs/distorm64/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/distorm64
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/distorm64/ChangeLog,v 1.4 2009/11/22 18:55:26 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/distorm64/ChangeLog,v 1.5 2011/07/31 11:47:57 patrick Exp $
+
+*distorm64-3.1 (31 Jul 2011)
+
+ 31 Jul 2011; Patrick Lauer <patrick@gentoo.org> +distorm64-3.1.ebuild:
+ Bump for #352078
22 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
distorm64-1.7.30-r1.ebuild:
diff --git a/dev-libs/distorm64/distorm64-3.1.ebuild b/dev-libs/distorm64/distorm64-3.1.ebuild
new file mode 100644
index 000000000000..ec6bc8b38637
--- /dev/null
+++ b/dev-libs/distorm64/distorm64-3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/distorm64/distorm64-3.1.ebuild,v 1.1 2011/07/31 11:47:57 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit eutils distutils python
+
+DESCRIPTION="The ultimate disassembler library (X86-32, X86-64)"
+HOMEPAGE="http://www.ragestorm.net/distorm/"
+
+# This is not nice - hardcoding is bad
+SRC_URI="http://distorm.googlecode.com/files/distorm3-1.0.zip"
+S="${WORKDIR}/distorm3-1.0"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+
+pkg_setup() {
+ python_pkg_setup
+}
+
+src_compile() {
+ distutils_src_compile
+}