summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-30 03:53:56 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-30 03:53:56 +0000
commit875a0d0402c5ec7ddc6889a830db19226d8b6ff6 (patch)
treea22e308f8f876e8b1ba32469ee6073aa8dca7dc8 /dev-libs
parentNew ebuild, moved from the gnome overlay, used by empathy-3.2. (diff)
downloadgentoo-2-875a0d0402c5ec7ddc6889a830db19226d8b6ff6.tar.gz
gentoo-2-875a0d0402c5ec7ddc6889a830db19226d8b6ff6.tar.bz2
gentoo-2-875a0d0402c5ec7ddc6889a830db19226d8b6ff6.zip
Bump to 3.2.0 from the gnome overlay. Notable changes: updates for gtk+-3.2.
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/gdl/ChangeLog7
-rw-r--r--dev-libs/gdl/gdl-3.2.0.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-libs/gdl/ChangeLog b/dev-libs/gdl/ChangeLog
index e47ee80fea8b..fb6931423d1f 100644
--- a/dev-libs/gdl/ChangeLog
+++ b/dev-libs/gdl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/gdl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gdl/ChangeLog,v 1.65 2011/09/26 11:35:33 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gdl/ChangeLog,v 1.66 2011/10/30 03:53:56 tetromino Exp $
+
+*gdl-3.2.0 (30 Oct 2011)
+
+ 30 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org> +gdl-3.2.0.ebuild:
+ Bump to 3.2.0 from the gnome overlay. Notable changes: updates for gtk+-3.2.
26 Sep 2011; Pacho Ramos <pacho@gentoo.org> -gdl-3.0.0.ebuild,
-gdl-3.0.1.ebuild, gdl-3.0.2.ebuild:
diff --git a/dev-libs/gdl/gdl-3.2.0.ebuild b/dev-libs/gdl/gdl-3.2.0.ebuild
new file mode 100644
index 000000000000..e0634aa5fa6e
--- /dev/null
+++ b/dev-libs/gdl/gdl-3.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gdl/gdl-3.2.0.ebuild,v 1.1 2011/10/30 03:53:56 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="The Gnome Devtool Libraries"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc +introspection"
+
+RDEPEND="dev-libs/glib:2
+ >=x11-libs/gtk+-3.0.0:3[introspection?]
+ >=dev-libs/libxml2-2.4:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-devel/gettext-0.17
+ >=dev-util/intltool-0.40.1
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable introspection)"
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+}