summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-06-18 17:48:09 +0000
committerPacho Ramos <pacho@gentoo.org>2013-06-18 17:48:09 +0000
commit89d21a3a20ceb7e790702d19bc4fce04ba7c5187 (patch)
tree4dbcc18330aed8c8396b1fd5a3aa8e7d44eab5af /dev-libs
parentpuppet CVE-2013-3567 bug 473720 fixes (diff)
downloadgentoo-2-89d21a3a20ceb7e790702d19bc4fce04ba7c5187.tar.gz
gentoo-2-89d21a3a20ceb7e790702d19bc4fce04ba7c5187.tar.bz2
gentoo-2-89d21a3a20ceb7e790702d19bc4fce04ba7c5187.zip
Version bump
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/link-grammar/ChangeLog7
-rw-r--r--dev-libs/link-grammar/link-grammar-4.7.13.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-libs/link-grammar/ChangeLog b/dev-libs/link-grammar/ChangeLog
index a90ca548f0e0..767c474fe656 100644
--- a/dev-libs/link-grammar/ChangeLog
+++ b/dev-libs/link-grammar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/link-grammar
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/link-grammar/ChangeLog,v 1.63 2013/05/28 19:05:31 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/link-grammar/ChangeLog,v 1.64 2013/06/18 17:48:09 pacho Exp $
+
+*link-grammar-4.7.13 (18 Jun 2013)
+
+ 18 Jun 2013; Pacho Ramos <pacho@gentoo.org> +link-grammar-4.7.13.ebuild:
+ Version bump
*link-grammar-4.7.12 (28 May 2013)
diff --git a/dev-libs/link-grammar/link-grammar-4.7.13.ebuild b/dev-libs/link-grammar/link-grammar-4.7.13.ebuild
new file mode 100644
index 000000000000..653821fd1fef
--- /dev/null
+++ b/dev-libs/link-grammar/link-grammar-4.7.13.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/link-grammar/link-grammar-4.7.13.ebuild,v 1.1 2013/06/18 17:48:09 pacho Exp $
+
+EAPI=5
+inherit java-pkg-opt-2 eutils
+
+DESCRIPTION="A Syntactic English parser"
+HOMEPAGE="http://www.abisource.com/projects/link-grammar/ http://www.link.cs.cmu.edu/link/"
+SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# Set the same default as used in app-text/enchant
+IUSE="aspell +hunspell java static-libs threads"
+
+DEPEND="aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell )
+ java? ( >=virtual/jdk-1.5
+ dev-java/ant-core )
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ java-pkg-opt-2_pkg_setup
+ if use aspell && use hunspell; then
+ ewarn "You have enabled 'aspell' and 'hunspell' support, but both cannot coexist,"
+ ewarn "only aspell will be build. Press Ctrl+C and set only 'hunspell' USE flag if"
+ ewarn "you want hunspell support."
+ fi
+}
+
+src_configure() {
+ local myconf
+
+ use hunspell && myconf="${myconf} --with-hunspell-dictdir=/usr/share/myspell"
+ econf \
+ --enable-shared \
+ $(use_enable aspell) \
+ $(use_enable hunspell) \
+ $(use_enable java java-bindings) \
+ $(use_enable static-libs static) \
+ $(use_enable threads pthreads) \
+ ${myconf}
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}