summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-04 01:03:27 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-04 01:03:27 +0000
commit945cc5667ef4c50f789bcdac023798d691bd3f95 (patch)
treeec7e30139f563752f39390905ebb4469a32cac73 /dev-libs
parentStable for PPC (bug #339640). (diff)
downloadgentoo-2-945cc5667ef4c50f789bcdac023798d691bd3f95.tar.gz
gentoo-2-945cc5667ef4c50f789bcdac023798d691bd3f95.tar.bz2
gentoo-2-945cc5667ef4c50f789bcdac023798d691bd3f95.zip
Version bump. Support Berkeley DB 5.1.
(Portage version: 2.2_rc88_p83/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/apr-util/ChangeLog9
-rw-r--r--dev-libs/apr-util/apr-util-1.3.10.ebuild91
-rw-r--r--dev-libs/apr-util/files/apr-util-1.3.10-support_berkeley_db-5.1.patch138
3 files changed, 237 insertions, 1 deletions
diff --git a/dev-libs/apr-util/ChangeLog b/dev-libs/apr-util/ChangeLog
index 67c96f068bd1..5a5bfb627c66 100644
--- a/dev-libs/apr-util/ChangeLog
+++ b/dev-libs/apr-util/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/apr-util
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.148 2010/08/06 13:28:37 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.149 2010/10/04 01:03:26 arfrever Exp $
+
+*apr-util-1.3.10 (04 Oct 2010)
+
+ 04 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +apr-util-1.3.10.ebuild,
+ +files/apr-util-1.3.10-support_berkeley_db-5.1.patch:
+ Version bump. Support Berkeley DB 5.1.
*apr-util-1.3.9-r1 (06 Aug 2010)
diff --git a/dev-libs/apr-util/apr-util-1.3.10.ebuild b/dev-libs/apr-util/apr-util-1.3.10.ebuild
new file mode 100644
index 000000000000..8d93a9062e94
--- /dev/null
+++ b/dev-libs/apr-util/apr-util-1.3.10.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-1.3.10.ebuild,v 1.1 2010/10/04 01:03:26 arfrever Exp $
+
+EAPI="3"
+
+# Usually apr-util has the same PV as apr, but in case of security fixes, this may change.
+#APR_PV=${PV}
+APR_PV="1.3.8"
+
+inherit autotools db-use eutils libtool multilib
+
+DESCRIPTION="Apache Portable Runtime Utility Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="berkdb doc freetds gdbm ldap mysql odbc postgres sqlite sqlite3"
+RESTRICT="test"
+
+RDEPEND="dev-libs/expat
+ >=dev-libs/apr-${APR_PV}:1
+ berkdb? ( >=sys-libs/db-4 )
+ freetds? ( dev-db/freetds )
+ gdbm? ( sys-libs/gdbm )
+ ldap? ( =net-nds/openldap-2* )
+ mysql? ( =virtual/mysql-5* )
+ odbc? ( dev-db/unixODBC )
+ postgres? ( dev-db/postgresql-base )
+ sqlite? ( dev-db/sqlite:0 )
+ sqlite3? ( dev-db/sqlite:3 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-support_berkeley_db-5.1.patch"
+ eautoreconf
+
+ elibtoolize
+}
+
+src_configure() {
+ local myconf
+
+ if use berkdb; then
+ local db_version
+ db_version="$(db_findver sys-libs/db)" || die "Unable to find Berkeley DB version"
+ db_version="$(db_ver_to_slot "${db_version}")"
+ db_version="${db_version/\./}"
+ myconf+=" --with-dbm=db${db_version} --with-berkeley-db=$(db_includedir 2> /dev/null):/usr/$(get_libdir)"
+ else
+ myconf+=" --without-berkeley-db"
+ fi
+
+ econf --datadir=/usr/share/apr-util-1 \
+ --with-apr=/usr \
+ --with-expat=/usr \
+ $(use_with freetds) \
+ $(use_with gdbm) \
+ $(use_with ldap) \
+ $(use_with mysql) \
+ $(use_with odbc) \
+ $(use_with postgres pgsql) \
+ $(use_with sqlite sqlite2) \
+ $(use_with sqlite3) \
+ ${myconf}
+}
+
+src_compile() {
+ emake CPPFLAGS="${CPPFLAGS}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
+
+ if use doc; then
+ emake dox || die "emake dox failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc CHANGES NOTICE README
+
+ if use doc; then
+ dohtml -r docs/dox/html/* || die "dohtml failed"
+ fi
+
+ # This file is only used on AIX systems, which Gentoo is not,
+ # and causes collisions between the SLOTs, so remove it.
+ rm -f "${D}usr/$(get_libdir)/aprutil.exp"
+}
diff --git a/dev-libs/apr-util/files/apr-util-1.3.10-support_berkeley_db-5.1.patch b/dev-libs/apr-util/files/apr-util-1.3.10-support_berkeley_db-5.1.patch
new file mode 100644
index 000000000000..40a366289dc9
--- /dev/null
+++ b/dev-libs/apr-util/files/apr-util-1.3.10-support_berkeley_db-5.1.patch
@@ -0,0 +1,138 @@
+https://svn.apache.org/viewvc?view=revision&revision=1003788
+
+--- build/dbm.m4
++++ build/dbm.m4
+@@ -560,6 +560,25 @@
+ apu_db_version=5
+ fi
+ ])
++dnl
++dnl APU_CHECK_DB51: is DB5.1 present?
++dnl
++dnl if present: sets apu_db_header, apu_db_lib, and apu_db_version
++dnl
++AC_DEFUN([APU_CHECK_DB51], [
++ places=$1
++ if test -z "$places"; then
++ places="std /usr/local/BerkeleyDB.5.1 /boot/home/config"
++ fi
++ APU_CHECK_BERKELEY_DB("5", "1", "-1",
++ "$places",
++ "db51/db.h db5/db.h db.h",
++ "db-5.1 db5-5.1 db51 db5 db"
++ )
++ if test "$apu_have_db" = "1"; then
++ apu_db_version=5
++ fi
++])
+
+ AC_DEFUN([APU_CHECK_DB], [
+ requested=$1
+@@ -656,6 +675,12 @@
+ AC_MSG_ERROR(Berkeley db5 not found)
+ fi
+ ;;
++ db51)
++ APU_CHECK_DB51("$check_places")
++ if test "$apu_db_version" != "5"; then
++ AC_MSG_ERROR(Berkeley db5 not found)
++ fi
++ ;;
+ default)
+ APU_CHECK_DB_ALL("$check_places")
+ ;;
+@@ -663,38 +688,41 @@
+ ])
+
+ dnl
+-dnl APU_CHECK_DB_ALL: Try all Berkeley DB versions, from 5.0 to 1.
++dnl APU_CHECK_DB_ALL: Try all Berkeley DB versions, from 5.1 to 1.
+ dnl
+ AC_DEFUN([APU_CHECK_DB_ALL], [
+ all_places=$1
+
+- APU_CHECK_DB50("$all_places")
++ APU_CHECK_DB51("$all_places")
+ if test "$apu_db_version" != "5"; then
+- APU_CHECK_DB48("$all_places")
+- if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB47("$all_places")
++ APU_CHECK_DB50("$all_places")
++ if test "$apu_db_version" != "5"; then
++ APU_CHECK_DB48("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB46("$all_places")
++ APU_CHECK_DB47("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB45("$all_places")
++ APU_CHECK_DB46("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB44("$all_places")
++ APU_CHECK_DB45("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB43("$all_places")
++ APU_CHECK_DB44("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB42("$all_places")
++ APU_CHECK_DB43("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB41("$all_places")
++ APU_CHECK_DB42("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB4("$all_places")
++ APU_CHECK_DB41("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB3("$all_places")
+- if test "$apu_db_version" != "3"; then
+- APU_CHECK_DB2("$all_places")
+- if test "$apu_db_version" != "2"; then
+- APU_CHECK_DB1("$all_places")
+- if test "$apu_db_version" != "1"; then
+- APU_CHECK_DB185("$all_places")
++ APU_CHECK_DB4("$all_places")
++ if test "$apu_db_version" != "4"; then
++ APU_CHECK_DB3("$all_places")
++ if test "$apu_db_version" != "3"; then
++ APU_CHECK_DB2("$all_places")
++ if test "$apu_db_version" != "2"; then
++ APU_CHECK_DB1("$all_places")
++ if test "$apu_db_version" != "1"; then
++ APU_CHECK_DB185("$all_places")
++ fi
+ fi
+ fi
+ fi
+@@ -735,11 +763,11 @@
+ apu_db_version=0
+
+ AC_ARG_WITH(dbm, [APR_HELP_STRING([--with-dbm=DBM], [choose the DBM type to use.
+- DBM={sdbm,gdbm,ndbm,db,db1,db185,db2,db3,db4,db41,db42,db43,db44,db45,db46,db47,db48,db50}])],
++ DBM={sdbm,gdbm,ndbm,db,db1,db185,db2,db3,db4,db41,db42,db43,db44,db45,db46,db47,db48,db50,db51}])],
+ [
+ if test "$withval" = "yes"; then
+ AC_MSG_ERROR([--with-dbm needs to specify a DBM type to use.
+- One of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44, db45, db46, db47, db48, db50])
++ One of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44, db45, db46, db47, db48, db50, db51])
+ fi
+ requested="$withval"
+ ], [
+@@ -946,6 +974,10 @@
+ apu_use_db=1
+ apu_default_dbm=db5
+ ;;
++ db51)
++ apu_use_db=1
++ apu_default_dbm=db5
++ ;;
+ default)
+ dnl ### use more sophisticated DBMs for the default?
+ apu_default_dbm="sdbm (default)"
+@@ -953,7 +985,7 @@
+ ;;
+ *)
+ AC_MSG_ERROR([--with-dbm=$look_for is an unknown DBM type.
+- Use one of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44, db45, db46, db47, db48, db50])
++ Use one of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44, db45, db46, db47, db48, db50, db51])
+ ;;
+ esac
+