summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-03-17 18:09:11 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-03-17 18:09:11 +0000
commit970d1b7a18a3201305a5e3ef2518888b0831e1e2 (patch)
treec8a819350ec2f6dbb44c721a7e471e1327e2656e /dev-libs
parentVersion bump (diff)
downloadgentoo-2-970d1b7a18a3201305a5e3ef2518888b0831e1e2.tar.gz
gentoo-2-970d1b7a18a3201305a5e3ef2518888b0831e1e2.tar.bz2
gentoo-2-970d1b7a18a3201305a5e3ef2518888b0831e1e2.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x2324E7B566DF2611!)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libinput/ChangeLog8
-rw-r--r--dev-libs/libinput/libinput-0.12.0.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-libs/libinput/ChangeLog b/dev-libs/libinput/ChangeLog
index 664b1550e105..81b507962f88 100644
--- a/dev-libs/libinput/ChangeLog
+++ b/dev-libs/libinput/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libinput
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libinput/ChangeLog,v 1.14 2015/03/17 17:25:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libinput/ChangeLog,v 1.15 2015/03/17 18:09:11 chithanh Exp $
+
+*libinput-0.12.0 (17 Mar 2015)
+
+ 17 Mar 2015; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +libinput-0.12.0.ebuild:
+ Version bump.
17 Mar 2015; Mike Frysinger <vapier@gentoo.org> libinput-0.9.0.ebuild:
Add arm64/ia64/m68k/s390/sh/sparc love #543582.
diff --git a/dev-libs/libinput/libinput-0.12.0.ebuild b/dev-libs/libinput/libinput-0.12.0.ebuild
new file mode 100644
index 000000000000..998edb95ada8
--- /dev/null
+++ b/dev-libs/libinput/libinput-0.12.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libinput/libinput-0.12.0.ebuild,v 1.1 2015/03/17 18:09:11 chithanh Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+# License appears to be a variant of libtiff
+LICENSE="libtiff"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-libs/libevdev-0.4
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # Doc handling in kinda strange but everything
+ # is available in the tarball already.
+ sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ # building documentation silently fails with graphviz syntax errors
+ econf \
+ --disable-documentation \
+ --disable-event-gui \
+ --disable-tests
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc -r doc/html
+ prune_libtool_files
+}