summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-17 00:34:44 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-17 00:34:44 +0000
commita47da59e06728c801aadb88ee95d5ed9e056bafc (patch)
tree11cebe76070493413519b483dff5213678096898 /dev-libs
parentfix build list since we inherit from linux now (diff)
downloadgentoo-2-a47da59e06728c801aadb88ee95d5ed9e056bafc.tar.gz
gentoo-2-a47da59e06728c801aadb88ee95d5ed9e056bafc.tar.bz2
gentoo-2-a47da59e06728c801aadb88ee95d5ed9e056bafc.zip
Kevin F. Quinn: fix PaX support #115100.
(Portage version: 2.0.53)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/elfutils/ChangeLog8
-rw-r--r--dev-libs/elfutils/elfutils-0.118.ebuild3
-rw-r--r--dev-libs/elfutils/files/elfutils-0.118-PaX-support.patch26
3 files changed, 34 insertions, 3 deletions
diff --git a/dev-libs/elfutils/ChangeLog b/dev-libs/elfutils/ChangeLog
index f525e3bd0c58..8e48e6e398d0 100644
--- a/dev-libs/elfutils/ChangeLog
+++ b/dev-libs/elfutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/elfutils
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/ChangeLog,v 1.70 2005/12/10 13:51:23 solar Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/ChangeLog,v 1.71 2005/12/17 00:34:44 vapier Exp $
+
+ 17 Dec 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/elfutils-0.118-PaX-support.patch, elfutils-0.118.ebuild:
+ Kevin F. Quinn: fix PaX support #115100.
10 Dec 2005; <solar@gentoo.org> elfutils-0.108-r1.ebuild,
elfutils-0.108.ebuild, elfutils-0.118.ebuild:
diff --git a/dev-libs/elfutils/elfutils-0.118.ebuild b/dev-libs/elfutils/elfutils-0.118.ebuild
index 4b22c37877e1..177658b6ec41 100644
--- a/dev-libs/elfutils/elfutils-0.118.ebuild
+++ b/dev-libs/elfutils/elfutils-0.118.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/elfutils-0.118.ebuild,v 1.2 2005/12/10 13:51:23 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/elfutils-0.118.ebuild,v 1.3 2005/12/17 00:34:44 vapier Exp $
inherit eutils
@@ -33,6 +33,7 @@ src_unpack() {
cd "${S}"
EPATCH_SUFFIX="patch" \
epatch "${WORKDIR}"/patch/
+ epatch "${FILESDIR}"/${P}-PaX-support.patch
# Needed by ${P}-portability.patch
autoreconf || die
diff --git a/dev-libs/elfutils/files/elfutils-0.118-PaX-support.patch b/dev-libs/elfutils/files/elfutils-0.118-PaX-support.patch
new file mode 100644
index 000000000000..083f32ff8553
--- /dev/null
+++ b/dev-libs/elfutils/files/elfutils-0.118-PaX-support.patch
@@ -0,0 +1,26 @@
+Add support for PaX ELF markings
+
+Patch by Kevin F. Quinn <kevquinn@gentoo.org>
+
+http://bugs.gentoo.org/115100
+
+--- libelf/elf.h
++++ libelf/elf.h
+@@ -568,6 +568,7 @@
+ #define PT_GNU_EH_FRAME 0x6474e550 /* GCC .eh_frame_hdr segment */
+ #define PT_GNU_STACK 0x6474e551 /* Indicates stack executability */
+ #define PT_GNU_RELRO 0x6474e552 /* Read-only after relocation */
++#define PT_PAX_FLAGS 0x65041580 /* Indicates PaX flag markings */
+ #define PT_LOSUNW 0x6ffffffa
+ #define PT_SUNWBSS 0x6ffffffa /* Sun Specific segment */
+ #define PT_SUNWSTACK 0x6ffffffb /* Stack segment */
+--- src/elflint.c
++++ src/elflint.c
+@@ -3187,6 +3187,7 @@
+
+ if (phdr->p_type >= PT_NUM && phdr->p_type != PT_GNU_EH_FRAME
+ && phdr->p_type != PT_GNU_STACK && phdr->p_type != PT_GNU_RELRO
++ && phdr->p_type != PT_PAX_FLAGS
+ /* Check for a known machine-specific type. */
+ && ebl_segment_type_name (ebl, phdr->p_type, NULL, 0) == NULL)
+ ERROR (gettext ("\