summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTuan Van <langthang@gentoo.org>2004-08-30 23:39:42 +0000
committerTuan Van <langthang@gentoo.org>2004-08-30 23:39:42 +0000
commita5e78828b5abf5f42865404dd2052878049b6fd2 (patch)
tree554025a2eb39d72171f86124421637ac65648959 /dev-libs
parentVersion bumped. Introduces a config file. Closes #53210. (Manifest recommit) (diff)
downloadgentoo-2-a5e78828b5abf5f42865404dd2052878049b6fd2.tar.gz
gentoo-2-a5e78828b5abf5f42865404dd2052878049b6fd2.tar.bz2
gentoo-2-a5e78828b5abf5f42865404dd2052878049b6fd2.zip
remove old ebuild. remove cache.
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/cyrus-sasl/cyrus-sasl-2.1.19-r1.ebuild4
-rw-r--r--dev-libs/cyrus-sasl/cyrus-sasl-2.1.19.ebuild187
-rw-r--r--dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.191
3 files changed, 2 insertions, 190 deletions
diff --git a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.19-r1.ebuild b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.19-r1.ebuild
index 010a5518ac4f..3830c90d85e8 100644
--- a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.19-r1.ebuild
+++ b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.19-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-2.1.19-r1.ebuild,v 1.1 2004/08/30 04:46:26 langthang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-2.1.19-r1.ebuild,v 1.2 2004/08/30 23:39:42 langthang Exp $
inherit eutils gnuconfig flag-o-matic java-pkg
@@ -84,7 +84,7 @@ src_unpack() {
# Recreate configure.
export WANT_AUTOCONF="2.5"
- rm -f configure config.h.in saslauthd/configure
+ rm -rf configure config.h.in autom4te.cache saslauthd/configure saslauthd/autom4te.cache
ebegin "Recreating configure"
aclocal -I cmulocal -I config && autoheader && autoconf || \
die "recreate configure failed"
diff --git a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.19.ebuild b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.19.ebuild
deleted file mode 100644
index ca66df54c848..000000000000
--- a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.19.ebuild
+++ /dev/null
@@ -1,187 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-2.1.19.ebuild,v 1.4 2004/08/10 20:39:31 langthang Exp $
-
-inherit eutils flag-o-matic gnuconfig
-
-DESCRIPTION="The Cyrus SASL (Simple Authentication and Security Layer)"
-HOMEPAGE="http://asg.web.cmu.edu/sasl/"
-SRC_URI="ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/${P}.tar.gz"
-
-LICENSE="as-is"
-SLOT="2"
-KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~s390 ~ppc64"
-IUSE="berkdb gdbm ldap mysql postgres kerberos static ssl java pam"
-
-RDEPEND="virtual/libc
- >=sys-libs/db-3.2
- gdbm? ( >=sys-libs/gdbm-1.8.0 )
- ldap? ( >=net-nds/openldap-2.0.25 )
- mysql? ( >=dev-db/mysql-3.23.51 )
- postgres? ( >=dev-db/postgresql-7.2 )
- pam? ( >=sys-libs/pam-0.75 )
- ssl? ( >=dev-libs/openssl-0.9.6d )
- kerberos? ( virtual/krb5 )
- java? ( virtual/jdk )"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4
- >=sys-devel/autoconf-2.58
- sys-devel/automake
- sys-devel/libtool"
-
-pkg_setup() {
- if use gdbm && use berkdb; then
- echo
- ewarn "You have both \"gdbm\" and \"berkdb\" in your USE flags."
- ewarn "Will default to GNU DB as your SASLdb database backend."
- ewarn "If you want to build with Berkeley DB support; hit Control-C now."
- ewarn "Change your USE flag -gdbm and emerge again."
- echo
- has_version ">=sys-apps/portage-2.0.50" && (
- einfo "It would be best practice to add the set of USE flags that you use for this"
- einfo "package to the file: /etc/portage/package.use. Example:"
- einfo "\`echo \"dev-libs/cyrus-sasl -gdbm berkdb\" >> /etc/portage/package.use\`"
- einfo "to build cyrus-sasl with Berkeley database as your SASLdb backend."
- )
- echo
- ewarn "Waiting 10 seconds before starting..."
- ewarn "(Control-C to abort)..."
- sleep 10
- fi
-
- echo
- einfo "This version include a "-r" option for saslauthd to instruct it to reassemble"
- einfo "realm and username into a username of "user@realm" form."
- echo
- einfo "If you are still using postfix->sasl->saslauthd->pam->mysql for"
- einfo "authentication, please edit /etc/conf.d/saslauthd to read:"
- einfo "SASLAUTHD_OPTS=\"\${SASLAUTH_MECH} -a pam -r\""
- einfo "Don't forget to restart the service: \`/etc/init.d/saslauthd restart\`."
- echo
- einfo "Pause 10 seconds before continuing."
- sleep 10
-}
-
-src_unpack() {
- unpack ${A} && cd "${S}"
-
-
- # Fix default port name for rimap auth mechanism.
- sed -e '/define DEFAULT_REMOTE_SERVICE/s:imap:imap2:' \
- -i saslauthd/auth_rimap.c || die "sed failed"
-
- # DB4 detection and versioned symbols.
- epatch "${FILESDIR}/cyrus-sasl-2.1.18-db4.patch"
-
- # Add configdir support.
- epatch "${FILESDIR}/${P}-configdir.patch"
-
- # Fix include path for newer PostgreSQL versions.
- epatch "${FILESDIR}/cyrus-sasl-2.1.17-pgsql-include.patch"
-
- # Add setuid/setgid check for SASL_PATH
- epatch "${FILESDIR}/${P}-sasl-path-fix.patch"
-
- # Recreate configure.
- export WANT_AUTOCONF="2.5"
- rm -f configure config.h.in saslauthd/configure
- ebegin "Recreating configure"
- aclocal -I cmulocal -I config && autoheader && autoconf || \
- die "recreate configure failed"
- eend $?
-
- cd "${S}/saslauthd"
- ebegin "Recreating saslauthd/configure"
- aclocal -I ../cmulocal -I ../config && autoheader && autoconf || \
- die "recreate configure failed"
- eend $?
-}
-
-src_compile() {
- local myconf="--enable-login --enable-ntlm --disable-krb4 --disable-otp"
- myconf="${myconf} `use_enable static`"
- myconf="${myconf} `use_with ssl openssl`"
- myconf="${myconf} `use_with pam`"
- myconf="${myconf} `use_with ldap`"
- myconf="${myconf} `use_enable kerberos gssapi`"
- myconf="${myconf} `use_with mysql` `use_enable mysql sql`"
- myconf="${myconf} `use_with postgres pgsql` `use_enable postgres sql`"
- myconf="${myconf} `use_enable java` `use_with java javahome ${JAVA_HOME}`"
-
- # fix for bug #59634. langthang 20040810.
- if ! use ssl; then
- myconf="${myconf} --without-des"
- fi
-
- if use mysql || use postgres ; then
- myconf="${myconf} --enable-sql"
- else
- myconf="${myconf} --disable-sql"
- fi
-
- if use gdbm && use berkdb; then
- einfo "build with GNU DB as database backend for your SASLdb."
- myconf="${myconf} --with-dblib=gdbm"
- elif use gdbm ; then
- einfo "build with GNU DB as database backend for your SASLdb."
- myconf="${myconf} --with-dblib=gdbm"
- elif use berkdb ; then
- einfo "build with Berkeley DB as database backend for your SASLdb."
- myconf="${myconf} --with-dblib=berkeley"
- else
- einfo "build without SASLdb support"
- myconf="${myconf} --with-dblib=none"
- fi
-
- # Compaq-sdk checks for -D_REENTRANT and -pthread takes care the cpp stuff.
- use alpha && append-flags -D_REENTRANT -pthread
-
- # Detect mips systems properly.
- gnuconfig_update
-
- econf \
- --with-saslauthd=/var/lib/sasl2 \
- --with-pwcheck=/var/lib/sasl2 \
- --with-configdir=/etc/sasl2 \
- --with-plugindir=/usr/lib/sasl2 \
- --with-dbpath=/etc/sasl2/sasldb2 \
- ${myconf} || die "econf failed"
-
- # Parallel build doesn't work.
- emake -j1 || die "compile problem"
-}
-
-src_install () {
- einstall
- keepdir /var/lib/sasl2 /etc/sasl2
-
- # Generate an empty sasldb2 with correct permissions.
- LD_OLD="${LD_LIBRARY_PATH}"
- export LD_LIBRARY_PATH="${D}/usr/lib" SASL_PATH="${D}/usr/lib/sasl2"
- echo "p" | "${D}/usr/sbin/saslpasswd2" -f "${D}/etc/sasl2/sasldb2" -p login
- "${D}/usr/sbin/saslpasswd2" -f "${D}/etc/sasl2/sasldb2" -d login
- export LD_LIBRARY_PATH="${LD_OLD}"
- chown root:mail "${D}/etc/sasl2/sasldb2"
- chmod 0640 "${D}/etc/sasl2/sasldb2"
-
- dodoc AUTHORS COPYING ChangeLog NEWS README doc/TODO doc/*.txt
- newdoc pwcheck/README README.pwcheck
- dohtml doc/*.html
-
- docinto examples
- dodoc sample/{*.[ch],Makefile}
-
- docinto saslauthd
- dodoc saslauthd/{AUTHORS,COPYING,ChangeLog,LDAP_SASLAUTHD,NEWS,README}
-
- if use pam ; then
- insinto /etc/pam.d
- newins "${FILESDIR}/saslauthd.pam" saslauthd
- fi
-
- exeinto /etc/init.d
- newexe "${FILESDIR}/pwcheck.rc6" pwcheck
- newexe "${FILESDIR}/saslauthd2.rc6" saslauthd
- insinto /etc/conf.d
- newins "${FILESDIR}/saslauthd-${PV}.conf" saslauthd
-}
diff --git a/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.19 b/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.19
deleted file mode 100644
index 1d5b1431c9ca..000000000000
--- a/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.19
+++ /dev/null
@@ -1 +0,0 @@
-MD5 ea76410ad88fa7b6c17a6aac424382c9 cyrus-sasl-2.1.19.tar.gz 1537350