summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2014-07-05 17:46:22 +0000
committerDaniel Pielmeier <billie@gentoo.org>2014-07-05 17:46:22 +0000
commitbb6bb5f33c40906f917a8d94e2f7f3c946e01da2 (patch)
tree8a93d3fe25539a1e0eb84b4c2e8e1e67152c4fbc /dev-libs
parentRelax dbus restarting postinst message wrt #514728 (diff)
downloadgentoo-2-bb6bb5f33c40906f917a8d94e2f7f3c946e01da2.tar.gz
gentoo-2-bb6bb5f33c40906f917a8d94e2f7f3c946e01da2.tar.bz2
gentoo-2-bb6bb5f33c40906f917a8d94e2f7f3c946e01da2.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 215AD14D)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libisofs/ChangeLog7
-rw-r--r--dev-libs/libisofs/libisofs-1.3.8.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-libs/libisofs/ChangeLog b/dev-libs/libisofs/ChangeLog
index 46c8b03c4cac..9db5813cb8ea 100644
--- a/dev-libs/libisofs/ChangeLog
+++ b/dev-libs/libisofs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libisofs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libisofs/ChangeLog,v 1.165 2014/03/24 19:31:07 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libisofs/ChangeLog,v 1.166 2014/07/05 17:46:22 billie Exp $
+
+*libisofs-1.3.8 (05 Jul 2014)
+
+ 05 Jul 2014; Daniel Pielmeier <billie@gentoo.org> +libisofs-1.3.8.ebuild:
+ Version bump.
24 Mar 2014; Daniel Pielmeier <billie@gentoo.org> -libisofs-1.3.2.ebuild:
Remove old.
diff --git a/dev-libs/libisofs/libisofs-1.3.8.ebuild b/dev-libs/libisofs/libisofs-1.3.8.ebuild
new file mode 100644
index 000000000000..948f90bacb18
--- /dev/null
+++ b/dev-libs/libisofs/libisofs-1.3.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libisofs/libisofs-1.3.8.ebuild,v 1.1 2014/07/05 17:46:22 billie Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="libisofs is an open-source library for reading, mastering and writing optical discs."
+HOMEPAGE="http://libburnia-project.org/"
+SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="acl debug static-libs verbose-debug xattr zlib"
+
+RDEPEND="acl? ( virtual/acl )
+ xattr? ( sys-apps/attr )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug) \
+ $(use_enable verbose-debug) \
+ $(use_enable acl libacl) \
+ $(use_enable xattr) \
+ $(use_enable zlib) \
+ --disable-libjte \
+ --disable-ldconfig-at-install
+}
+
+src_install() {
+ default
+
+ dodoc Roadmap doc/{*.txt,Tutorial}
+
+ prune_libtool_files --all
+}