summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-09-08 04:26:42 +0000
committerMike Frysinger <vapier@gentoo.org>2004-09-08 04:26:42 +0000
commitbe34fe896cd36670221066776c19f71956aea284 (patch)
tree4ae3a331dbcb436a74d43a1f8ba45ea1b89b8c39 /dev-libs
parent~ppc for #61747 (Manifest recommit) (diff)
downloadgentoo-2-be34fe896cd36670221066776c19f71956aea284.tar.gz
gentoo-2-be34fe896cd36670221066776c19f71956aea284.tar.bz2
gentoo-2-be34fe896cd36670221066776c19f71956aea284.zip
use gcc to get the compiler info
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xalan-c/xalan-c-1.7.0.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-libs/xalan-c/xalan-c-1.7.0.ebuild b/dev-libs/xalan-c/xalan-c-1.7.0.ebuild
index 058107f8e1d2..a5d5b1b851c5 100644
--- a/dev-libs/xalan-c/xalan-c-1.7.0.ebuild
+++ b/dev-libs/xalan-c/xalan-c-1.7.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xalan-c/xalan-c-1.7.0.ebuild,v 1.4 2004/06/24 23:37:58 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xalan-c/xalan-c-1.7.0.ebuild,v 1.5 2004/09/08 04:26:42 vapier Exp $
+
+inherit gcc
MY_PV=${PV//./_}
DESCRIPTION="XSLT processor for transforming XML into HTML, text, or other XML types"
@@ -21,7 +23,7 @@ S=${WORKDIR}/xml-xalan/c
src_compile() {
export XALANCROOT=${S}
export XERCESCROOT="/usr/include/xercesc"
- ./runConfigure -p linux -c gcc -x c++ -P /usr || die
+ ./runConfigure -p linux -c "$(gcc-getCC)" -x "$(gcc-getCXX)" -P /usr || die
emake -j1 || die
}