summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-02 06:47:25 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-02 06:47:25 +0000
commitbf3fbe267a6bdc91be2107dea1ca38fbb2832f8c (patch)
treed05aac1f6a0c7bcad3dceff46c3488d1a2657033 /dev-libs
parentVersion bump. (diff)
downloadgentoo-2-bf3fbe267a6bdc91be2107dea1ca38fbb2832f8c.tar.gz
gentoo-2-bf3fbe267a6bdc91be2107dea1ca38fbb2832f8c.tar.bz2
gentoo-2-bf3fbe267a6bdc91be2107dea1ca38fbb2832f8c.zip
Version bump and fix some typos #137532 by Joe Button.
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/rasqal/ChangeLog8
-rw-r--r--dev-libs/rasqal/files/digest-rasqal-0.9.123
-rw-r--r--dev-libs/rasqal/files/rasqal-0.9.12-typos.patch15
-rw-r--r--dev-libs/rasqal/rasqal-0.9.12.ebuild44
4 files changed, 69 insertions, 1 deletions
diff --git a/dev-libs/rasqal/ChangeLog b/dev-libs/rasqal/ChangeLog
index 5104035e76af..332c40b2e2cf 100644
--- a/dev-libs/rasqal/ChangeLog
+++ b/dev-libs/rasqal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/rasqal
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/rasqal/ChangeLog,v 1.5 2006/04/02 20:09:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/rasqal/ChangeLog,v 1.6 2006/07/02 06:47:25 vapier Exp $
+
+*rasqal-0.9.12 (02 Jul 2006)
+
+ 02 Jul 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/rasqal-0.9.12-typos.patch, +rasqal-0.9.12.ebuild:
+ Version bump and fix some typos #137532 by Joe Button.
02 Apr 2006; Mike Frysinger <vapier@gentoo.org> rasqal-0.9.10.ebuild,
rasqal-0.9.11.ebuild:
diff --git a/dev-libs/rasqal/files/digest-rasqal-0.9.12 b/dev-libs/rasqal/files/digest-rasqal-0.9.12
new file mode 100644
index 000000000000..856d8cd6e8e7
--- /dev/null
+++ b/dev-libs/rasqal/files/digest-rasqal-0.9.12
@@ -0,0 +1,3 @@
+MD5 403b95de5c23124f6a6491bdde3eba86 rasqal-0.9.12.tar.gz 914774
+RMD160 d67c865f649a9a4890ce4776ab717bc9d6ff0f89 rasqal-0.9.12.tar.gz 914774
+SHA256 f5b4d4d7f08da70e306f1cf40a544adc3dfed5d9373a1b863dce8851aa8f96f0 rasqal-0.9.12.tar.gz 914774
diff --git a/dev-libs/rasqal/files/rasqal-0.9.12-typos.patch b/dev-libs/rasqal/files/rasqal-0.9.12-typos.patch
new file mode 100644
index 000000000000..39fb924dc682
--- /dev/null
+++ b/dev-libs/rasqal/files/rasqal-0.9.12-typos.patch
@@ -0,0 +1,15 @@
+http://bugs.gentoo.org/137532
+
+--- configure
++++ configure
+@@ -21246,8 +21246,8 @@
+ RASQAL_EXTERNAL_CPPFLAGS="$RASQAL_EXTERNAL_CPPFLAGS $C"
+ RASQAL_EXTERNAL_LIBS="$RASQAL_EXTERNAL_LIBS $L"
+
+- PKGCONFIG_CFLAGS="PKGCONFIG_CFLAGS $C"
+- PKGCONFIG_LIBS="PKGCONFIG_LIBS $L"
++ PKGCONFIG_CFLAGS="$PKGCONFIG_CFLAGS $C"
++ PKGCONFIG_LIBS="$PKGCONFIG_LIBS $L"
+ unset C
+ unset L
+ fi
diff --git a/dev-libs/rasqal/rasqal-0.9.12.ebuild b/dev-libs/rasqal/rasqal-0.9.12.ebuild
new file mode 100644
index 000000000000..643ecbbe8750
--- /dev/null
+++ b/dev-libs/rasqal/rasqal-0.9.12.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/rasqal/rasqal-0.9.12.ebuild,v 1.1 2006/07/02 06:47:25 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="library that handles Resource Description Framework (RDF)"
+HOMEPAGE="http://librdf.org/rasqal/"
+SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
+
+LICENSE="LGPL-2 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="pcre xml"
+
+RDEPEND="sys-devel/flex
+ pcre? ( dev-libs/libpcre )
+ xml? ( dev-libs/libxml2 )
+ >=media-libs/raptor-1.4.9"
+DEPEND="${RDEPEND}
+ sys-devel/bison"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-typos.patch
+}
+
+src_compile() {
+ local regexlib
+ use pcre && regexlib="pcre" || regexlib="posix"
+ econf \
+ $(use_with pcre pcre-config) \
+ $(use_with xml xml2-config) \
+ --with-regex-library=${regexlib} \
+ --with-raptor=system \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc AUTHORS NEWS README
+}