summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-11-04 11:05:47 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-11-04 11:05:47 +0000
commitbf861e7b43ce9ffd8205402fb32695519c5b897f (patch)
tree5ba8232f814f3f70ff048a002b4f398e4fee7b64 /dev-libs
parentVersion bump. (diff)
downloadgentoo-2-bf861e7b43ce9ffd8205402fb32695519c5b897f.tar.gz
gentoo-2-bf861e7b43ce9ffd8205402fb32695519c5b897f.tar.bz2
gentoo-2-bf861e7b43ce9ffd8205402fb32695519c5b897f.zip
remove all warning CFLAGS as they can hinder successful compilation, see bugs 197999 and 196103
(Portage version: 2.1.3.16)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/qof/ChangeLog7
-rw-r--r--dev-libs/qof/files/qof-0.7.2-remove_spurious_CFLAGS.patch54
-rw-r--r--dev-libs/qof/qof-0.7.2.ebuild9
3 files changed, 68 insertions, 2 deletions
diff --git a/dev-libs/qof/ChangeLog b/dev-libs/qof/ChangeLog
index 8ca491bfc6f1..801dd01d7b4b 100644
--- a/dev-libs/qof/ChangeLog
+++ b/dev-libs/qof/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/qof
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/qof/ChangeLog,v 1.5 2007/11/03 23:46:01 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/qof/ChangeLog,v 1.6 2007/11/04 11:05:46 opfer Exp $
+
+ 04 Nov 2007; Christian Faulhammer <opfer@gentoo.org>
+ +files/qof-0.7.2-remove_spurious_CFLAGS.patch, qof-0.7.2.ebuild:
+ remove all warning CFLAGS as they can hinder successful compilation, see
+ bugs 197999 and 196103
03 Nov 2007; Olivier Crête <tester@gentoo.org> qof-0.7.2.ebuild:
Mark ~amd64 for bug #195986
diff --git a/dev-libs/qof/files/qof-0.7.2-remove_spurious_CFLAGS.patch b/dev-libs/qof/files/qof-0.7.2-remove_spurious_CFLAGS.patch
new file mode 100644
index 000000000000..38d9e49ffcc6
--- /dev/null
+++ b/dev-libs/qof/files/qof-0.7.2-remove_spurious_CFLAGS.patch
@@ -0,0 +1,54 @@
+--- /tmp/configure 2007-11-04 11:44:13.000000000 +0100
++++ configure 2007-11-04 11:51:58.000000000 +0100
+@@ -26367,18 +26367,18 @@
+ echo $ECHO_N "checking what extra warning flags to pass to the C compiler... $ECHO_C" >&6; }
+ if test ${GCC}x = yesx; then
+ warnFLAGS=
+- CFLAGS="${CFLAGS} -g2 -Wall"
++ CFLAGS="${CFLAGS}"
+ # Check whether --enable-error-on-warning was given.
+ if test "${enable_error_on_warning+set}" = set; then
+ enableval=$enable_error_on_warning; case "${enableval}" in
+- yes) warnFLAGS="${warnFLAGS} -Werror" ;;
++ yes) warnFLAGS="${warnFLAGS}" ;;
+ no) ;;
+ *) { { echo "$as_me:$LINENO: error: bad value ${enableval} for --enable-error-on-warning" >&5
+ echo "$as_me: error: bad value ${enableval} for --enable-error-on-warning" >&2;}
+ { (exit 1); exit 1; }; } ;;
+ esac
+ else
+- warnFLAGS="${warnFLAGS} -Werror"
++ warnFLAGS="${warnFLAGS}"
+ fi
+
+ GCC_VERSION=`${CC} -dumpversion`
+@@ -26386,10 +26386,10 @@
+ # This is gcc >= 3.x.x
+ if test `echo ${GCC_VERSION} | cut -d. -f2` -ge 4; then
+ # This is gcc >= 3.4.x
+- warnFLAGS="${warnFLAGS} -Wdeclaration-after-statement"
++ warnFLAGS="${warnFLAGS}"
+ else if test `echo ${GCC_VERSION} | cut -d. -f1` -ge 4; then
+ # This is gcc == 4.x.x
+- warnFLAGS="${warnFLAGS} -Wdeclaration-after-statement -Wno-pointer-sign"
++ warnFLAGS="${warnFLAGS}"
+ fi
+ fi
+ fi
+@@ -26408,16 +26408,6 @@
+ fi
+
+
+-if test "$GCC" = "yes" -a "$set_compile_warnings" != "no"; then
+- warnFLAGS="$warnFLAGS -Wcast-align -Wsign-compare \
+- -Wmissing-prototypes -Wmissing-declarations -Werror -Wmissing-include-dirs \
+- -Wstrict-prototypes -Winline -Wnested-externs -Wpointer-arith \
+- -Wmissing-field-initializers"
+-fi
+-
+-
+-
+-
+
+ DATADIR=`eval echo $datadir`
+ QSF_SCHEMA_DIR=`eval echo $DATADIR`"/xml/qof/qsf"
diff --git a/dev-libs/qof/qof-0.7.2.ebuild b/dev-libs/qof/qof-0.7.2.ebuild
index 73fe92a967cd..ac5d621aebbb 100644
--- a/dev-libs/qof/qof-0.7.2.ebuild
+++ b/dev-libs/qof/qof-0.7.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/qof/qof-0.7.2.ebuild,v 1.5 2007/11/03 23:46:01 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/qof/qof-0.7.2.ebuild,v 1.6 2007/11/04 11:05:46 opfer Exp $
+
+inherit eutils
DESCRIPTION="A Query Object Framework"
HOMEPAGE="http://qof.sourceforge.net/"
@@ -15,6 +17,11 @@ IUSE=""
DEPEND=""
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/${P}-remove_spurious_CFLAGS.patch"
+}
+
src_install() {
emake DESTDIR="${D}" install || die
}