summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2007-09-08 20:05:24 +0000
committerBenedikt Boehm <hollow@gentoo.org>2007-09-08 20:05:24 +0000
commitc3b4cb9d0293fef08fdefc148811a840a5194c24 (patch)
treee6104668f73360529b962dd809194cc5d7e09486 /dev-libs
parentOld CVS snapshots removed from tree. (diff)
downloadgentoo-2-c3b4cb9d0293fef08fdefc148811a840a5194c24.tar.gz
gentoo-2-c3b4cb9d0293fef08fdefc148811a840a5194c24.tar.bz2
gentoo-2-c3b4cb9d0293fef08fdefc148811a840a5194c24.zip
version bump; #191733
(Portage version: 2.1.3.7)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/apr/ChangeLog7
-rw-r--r--dev-libs/apr/apr-1.2.11.ebuild85
-rw-r--r--dev-libs/apr/files/digest-apr-1.2.113
3 files changed, 94 insertions, 1 deletions
diff --git a/dev-libs/apr/ChangeLog b/dev-libs/apr/ChangeLog
index c6cf8fa30b98..e26c4667ebbf 100644
--- a/dev-libs/apr/ChangeLog
+++ b/dev-libs/apr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/apr
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.90 2007/07/31 09:00:08 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.91 2007/09/08 20:05:24 hollow Exp $
+
+*apr-1.2.11 (08 Sep 2007)
+
+ 08 Sep 2007; Benedikt Böhm <hollow@gentoo.org> +apr-1.2.11.ebuild:
+ version bump; #191733
31 Jul 2007; Christian Heim <phreak@gentoo.org> apr-1.2.9.ebuild:
The version bump wasn't designed to go straight to stable.
diff --git a/dev-libs/apr/apr-1.2.11.ebuild b/dev-libs/apr/apr-1.2.11.ebuild
new file mode 100644
index 000000000000..e788434678de
--- /dev/null
+++ b/dev-libs/apr/apr-1.2.11.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-1.2.11.ebuild,v 1.1 2007/09/08 20:05:24 hollow Exp $
+
+inherit autotools
+
+DESCRIPTION="Apache Portable Runtime Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="ipv6 urandom debug"
+RESTRICT="test"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # for some reason not all the .m4 files that are referenced in
+ # configure.in exist, so we remove all references and include every
+ # .m4 file in build using aclocal via eautoreconf
+ # See bug 135463
+ sed -i -e '/sinclude/d' configure.in
+ AT_M4DIR="build" eautoreconf
+
+ epatch "${FILESDIR}"/config.layout.patch
+}
+
+src_compile() {
+ # For now we always enable ipv6. Testing has shown that is still works
+ # correctly in ipv4 systems, and currently, the ipv4-only support
+ # is broken in apr. (ipv6 is enabled by default)
+ #myconf="${myconf} $(use_enable ipv6)"
+
+ if use urandom; then
+ myconf="${myconf} --with-devrandom=/dev/urandom"
+ else
+ myconf="${myconf} --with-devrandom=/dev/random"
+ fi
+
+ use debug && myconf="${myconf} --enable-maintainer-mode"
+
+ # We pre-load the cache with the correct answer! This avoids
+ # it violating the sandbox. This may have to be changed for
+ # non-Linux systems or if sem_open changes on Linux. This
+ # hack is built around documentation in /usr/include/semaphore.h
+ # and the glibc (pthread) source
+ # See bugs 24215 and 133573
+ echo 'ac_cv_func_sem_open=${ac_cv_func_sem_open=no}' >> "${S}"/config.cache
+
+ econf --enable-layout=gentoo \
+ --enable-threads \
+ --enable-nonportable-atomics \
+ ${myconf} || die "econf failed!"
+
+ # Make sure we use the system libtool
+ sed -i 's,$(apr_builddir)/libtool,/usr/bin/libtool,' "${S}"/build/apr_rules.mk
+ sed -i 's,${installbuilddir}/libtool,/usr/bin/libtool,' "${S}"/apr-1-config
+ rm -f "${S}"/libtool
+
+ emake || die "Make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # This file is only used on AIX systems, which gentoo is not,
+ # and causes collisions between the SLOTs, so kill it
+ rm "${D}"/usr/$(get_libdir)/apr.exp
+
+ dodoc CHANGES NOTICE
+}
+
+pkg_postinst() {
+ ewarn "We are now using the system's libtool rather then bundling"
+ ewarn "our own. You will need to rebuild Apache and possibly other"
+ ewarn "software if you get a message similiar to the following:"
+ ewarn
+ ewarn " /usr/share/apr-1/build-1/libtool: No such file or directory"
+ ewarn
+}
diff --git a/dev-libs/apr/files/digest-apr-1.2.11 b/dev-libs/apr/files/digest-apr-1.2.11
new file mode 100644
index 000000000000..5f2ca43bd2cd
--- /dev/null
+++ b/dev-libs/apr/files/digest-apr-1.2.11
@@ -0,0 +1,3 @@
+MD5 afcf9541dc31551abeb6c53bb42c2596 apr-1.2.11.tar.gz 1114033
+RMD160 8b1c1831cd8281de17f41f84ffc5cfd9b6c35553 apr-1.2.11.tar.gz 1114033
+SHA256 fc7a14e8ded002c252cf5f3ccce6cd5636f01a85986188e373f9343a174c42ff apr-1.2.11.tar.gz 1114033