summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-01-28 21:24:41 +0000
committerChristian Heim <phreak@gentoo.org>2007-01-28 21:24:41 +0000
commitddd24666ed27c467723e8aae1883d40e07cba4bb (patch)
treee589b7bc1ad59d6a99cea53b4d1b814031d388f0 /dev-libs
parentremoved entries for old versions of dev-ada/{gtk,xml}ada, as these versions w... (diff)
downloadgentoo-2-ddd24666ed27c467723e8aae1883d40e07cba4bb.tar.gz
gentoo-2-ddd24666ed27c467723e8aae1883d40e07cba4bb.tar.bz2
gentoo-2-ddd24666ed27c467723e8aae1883d40e07cba4bb.zip
Version bump, new upstream version. Cleaning up the ebuild a bit.
(Portage version: 2.1.2-r4)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/apr/ChangeLog7
-rw-r--r--dev-libs/apr/apr-0.9.13.ebuild74
-rw-r--r--dev-libs/apr/files/digest-apr-0.9.133
3 files changed, 83 insertions, 1 deletions
diff --git a/dev-libs/apr/ChangeLog b/dev-libs/apr/ChangeLog
index 011a1cae4e79..e310f4b1249c 100644
--- a/dev-libs/apr/ChangeLog
+++ b/dev-libs/apr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/apr
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.76 2007/01/28 20:11:11 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.77 2007/01/28 21:24:41 phreak Exp $
+
+*apr-0.9.13 (28 Jan 2007)
+
+ 28 Jan 2007; Christian Heim <phreak@gentoo.org> +apr-0.9.13.ebuild:
+ Version bump, new upstream version. Cleaning up the ebuild a bit.
28 Jan 2007; Luca Longinotti <chtekk@gentoo.org> metadata.xml,
-apr-0.9.6-r3.ebuild, -apr-0.9.6-r4.ebuild, -apr-0.9.7.ebuild,
diff --git a/dev-libs/apr/apr-0.9.13.ebuild b/dev-libs/apr/apr-0.9.13.ebuild
new file mode 100644
index 000000000000..43ce2eb4ad8e
--- /dev/null
+++ b/dev-libs/apr/apr-0.9.13.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-0.9.13.ebuild,v 1.1 2007/01/28 21:24:41 phreak Exp $
+
+inherit eutils flag-o-matic libtool
+
+DESCRIPTION="Apache Portable Runtime Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ~ppc-macos ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
+IUSE="ipv6 urandom"
+RESTRICT="test"
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/apr-0.9.12-linking.patch
+ elibtoolize || die "elibtoolize failed"
+
+}
+
+src_compile() {
+ myconf="--datadir=/usr/share/apr-0"
+
+ myconf="${myconf} $(use_enable ipv6)"
+ myconf="${myconf} --enable-threads"
+ myconf="${myconf} --enable-nonportable-atomics"
+ if use urandom; then
+ einfo "Using /dev/urandom as random device"
+ myconf="${myconf} --with-devrandom=/dev/urandom"
+ else
+ einfo "Using /dev/random as random device"
+ myconf="${myconf} --with-devrandom=/dev/random"
+ fi
+
+ # We pre-load the cache with the correct answer! This avoids
+ # it violating the sandbox. This may have to be changed for
+ # non-Linux systems or if sem_open changes on Linux. This
+ # hack is built around documentation in /usr/include/semaphore.h
+ # and the glibc (pthread) source
+ # See bugs 24215 and 133573
+ echo 'ac_cv_func_sem_open=${ac_cv_func_sem_open=no}' >> "${S}"/config.cache
+
+ econf ${myconf} || die "econf failed!"
+ emake || die "emake failed!"
+}
+
+src_install() {
+ make DESTDIR="${D}" installbuilddir=/usr/share/apr-0/build install || die "make install failed!"
+
+ # bogus values pointing at /var/tmp/portage
+ sed -i -e 's:APR_SOURCE_DIR=.*:APR_SOURCE_DIR=/usr/share/apr-0:g' "${D}"/usr/bin/apr-config
+ sed -i -e 's:APR_BUILD_DIR=.*:APR_BUILD_DIR=/usr/share/apr-0/build:g' "${D}"/usr/bin/apr-config
+
+ sed -i -e 's:apr_builddir=.*:apr_builddir=/usr/share/apr-0/build:g' "${D}"/usr/share/apr-0/build/apr_rules.mk
+ sed -i -e 's:apr_builders=.*:apr_builders=/usr/share/apr-0/build:g' "${D}"/usr/share/apr-0/build/apr_rules.mk
+
+ cp -p build/*.awk "${D}"/usr/share/apr-0/build
+ cp -p build/*.sh "${D}"/usr/share/apr-0/build
+ cp -p build/*.pl "${D}"/usr/share/apr-0/build
+
+ dodoc CHANGES LICENSE NOTICE
+
+ # This file is only used on AIX systems, which gentoo is not,
+ # and causes collisions between the SLOTs, so kill it
+ rm "${D}"/usr/$(get_libdir)/apr.exp
+}
diff --git a/dev-libs/apr/files/digest-apr-0.9.13 b/dev-libs/apr/files/digest-apr-0.9.13
new file mode 100644
index 000000000000..95ddccf8f2df
--- /dev/null
+++ b/dev-libs/apr/files/digest-apr-0.9.13
@@ -0,0 +1,3 @@
+MD5 233894af598d8347fd68cf836e7dee91 apr-0.9.13.tar.gz 1051795
+RMD160 0183645d0065eb8b3eca0602820318ab3c89a179 apr-0.9.13.tar.gz 1051795
+SHA256 64bb493b634c442db4f18deac37a07deb8d37c994a2507f8eba756f926a26204 apr-0.9.13.tar.gz 1051795