summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-03 20:21:14 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-03 20:21:14 +0000
commite6634f23a3667125b755c5650bc0930237e8baea (patch)
treee95d391d74ab02724236d97874c4a8422383ff9c /dev-libs
parentoops, I forgot to commit the matching USE=aqua bits with my last commit (diff)
downloadgentoo-2-e6634f23a3667125b755c5650bc0930237e8baea.tar.gz
gentoo-2-e6634f23a3667125b755c5650bc0930237e8baea.tar.bz2
gentoo-2-e6634f23a3667125b755c5650bc0930237e8baea.zip
CVector is an ANSI C implementation of dynamic arrays to provide a crude approximation to the C++ vector class.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/cvector/ChangeLog16
-rw-r--r--dev-libs/cvector/cvector-1.0.3.ebuild48
-rw-r--r--dev-libs/cvector/files/1.0.3-LDFLAGS.patch17
-rw-r--r--dev-libs/cvector/metadata.xml8
4 files changed, 89 insertions, 0 deletions
diff --git a/dev-libs/cvector/ChangeLog b/dev-libs/cvector/ChangeLog
new file mode 100644
index 000000000000..f5743526c1ce
--- /dev/null
+++ b/dev-libs/cvector/ChangeLog
@@ -0,0 +1,16 @@
+# ChangeLog for dev-libs/cvector
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cvector/ChangeLog,v 1.1 2010/02/03 20:21:13 jlec Exp $
+
+ 03 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +files/1.0.3-LDFLAGS.patch, +cvector-1.0.3.ebuild, +metadata.xml:
+ CVector is an ANSI C implementation of dynamic arrays to provide a crude
+ approximation to the C++ vector class.
+
+*cvector-1.0.3 (03 Feb 2010)
+
+ 03 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +files/1.0.3-LDFLAGS.patch, +cvector-1.0.3.ebuild, +metadata.xml:
+ CVector is an ANSI C implementation of dynamic arrays to provide a crude
+ approximation to the C++ vector class.
+
diff --git a/dev-libs/cvector/cvector-1.0.3.ebuild b/dev-libs/cvector/cvector-1.0.3.ebuild
new file mode 100644
index 000000000000..2df7a5713811
--- /dev/null
+++ b/dev-libs/cvector/cvector-1.0.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cvector/cvector-1.0.3.ebuild,v 1.1 2010/02/03 20:21:13 jlec Exp $
+
+inherit eutils toolchain-funcs
+
+MY_PN=CVector
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="An ANSI C implementation of dynamic arrays to provide a crude approximation to the C++ vector class"
+HOMEPAGE="http://cvector.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-LDFLAGS.patch
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ CFLAGS="${CFLAGS}" \
+ all || die "compilation failed"
+}
+
+src_test() {
+ emake tests || die "test failed"
+}
+
+src_install() {
+ dobin bin/* || die
+ dolib.a lib/.libs/*.a || die
+
+ insinto /usr/include
+ doins *.h || die
+
+ dodoc README_CVector.txt || die
+}
diff --git a/dev-libs/cvector/files/1.0.3-LDFLAGS.patch b/dev-libs/cvector/files/1.0.3-LDFLAGS.patch
new file mode 100644
index 000000000000..7e54e8120245
--- /dev/null
+++ b/dev-libs/cvector/files/1.0.3-LDFLAGS.patch
@@ -0,0 +1,17 @@
+--- Makefile 2009-07-08 04:02:56.000000000 +0200
++++ Makefile.new 2009-07-25 11:59:27.000000000 +0200
+@@ -89,10 +89,10 @@
+ endif
+
+ COMPILE_COMMAND = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c
+-LIBRARY_LINK_COMMAND = $(LIBTOOL) --mode=link $(CC) -version-info $(VERSION) -release $(RELEASE) -no-undefined -rpath $(INSTALL_PREFIX)/lib
+-BUILD_COMMAND_LOCAL = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(INCLUDES)
+-BUILD_COMMAND_DYNAMIC = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -shared -I $(INSTALL_PREFIX)/include
+-BUILD_COMMAND_STATIC = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -static -I $(INSTALL_PREFIX)/include
++LIBRARY_LINK_COMMAND = $(LIBTOOL) --mode=link $(CC) -version-info $(VERSION) -release $(RELEASE) -no-undefined $(LDFLAGS)
++BUILD_COMMAND_LOCAL = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(INCLUDES) $(LDFLAGS)
++BUILD_COMMAND_DYNAMIC = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(LDFLAGS) -shared
++BUILD_COMMAND_STATIC = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(LDFLAGS) -static
+ INSTALL_COMMAND = $(LIBTOOL) --mode=install cp
+ INSTALL_FINISH_COMMAND = $(LIBTOOL) --mode=finish
+
diff --git a/dev-libs/cvector/metadata.xml b/dev-libs/cvector/metadata.xml
new file mode 100644
index 000000000000..efb490d78817
--- /dev/null
+++ b/dev-libs/cvector/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>sci@gentoo.org</email>
+</maintainer>
+</pkgmetadata>