summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-04-14 18:30:56 +0000
committerPacho Ramos <pacho@gentoo.org>2013-04-14 18:30:56 +0000
commitedceedcea05142c48c1b431fa5c4e697d0660263 (patch)
tree4605e58621331cb1940331d03a9c7d66b519ea45 /dev-libs
parentDrop old hard-masked kernels (diff)
downloadgentoo-2-edceedcea05142c48c1b431fa5c4e697d0660263.tar.gz
gentoo-2-edceedcea05142c48c1b431fa5c4e697d0660263.tar.bz2
gentoo-2-edceedcea05142c48c1b431fa5c4e697d0660263.zip
Version bump
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/gdl/ChangeLog7
-rw-r--r--dev-libs/gdl/gdl-3.8.1.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-libs/gdl/ChangeLog b/dev-libs/gdl/ChangeLog
index 31fa75a44721..eab2b54636ce 100644
--- a/dev-libs/gdl/ChangeLog
+++ b/dev-libs/gdl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/gdl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gdl/ChangeLog,v 1.93 2013/04/12 11:01:57 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gdl/ChangeLog,v 1.94 2013/04/14 18:30:56 pacho Exp $
+
+*gdl-3.8.1 (14 Apr 2013)
+
+ 14 Apr 2013; Pacho Ramos <pacho@gentoo.org> +gdl-3.8.1.ebuild:
+ Version bump
12 Apr 2013; Samuli Suominen <ssuominen@gentoo.org> gdl-2.30.1.ebuild:
Remove useless libtool archive libgdl-1.la wrt #465664 by Helmut Jarausch
diff --git a/dev-libs/gdl/gdl-3.8.1.ebuild b/dev-libs/gdl/gdl-3.8.1.ebuild
new file mode 100644
index 000000000000..0ab802420b8c
--- /dev/null
+++ b/dev-libs/gdl/gdl-3.8.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gdl/gdl-3.8.1.ebuild,v 1.1 2013/04/14 18:30:56 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="GNOME docking library"
+HOMEPAGE="https://developer.gnome.org/gdl/"
+
+LICENSE="LGPL-2.1+"
+SLOT="3/5"
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ dev-libs/glib:2
+ >=x11-libs/gtk+-3.0.0:3[introspection?]
+ >=dev-libs/libxml2-2.4:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.4
+ >=dev-util/intltool-0.40.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+ gnome2_src_configure $(use_enable introspection)
+}