summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-06-25 03:25:18 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-06-25 03:25:18 +0000
commitfa92ab79029f134adf3e4dd9eefad20eaffb1fc1 (patch)
tree104d73c766cb39e00e0c5e231c902c7e48f0c157 /dev-libs
parentAllow system-config-printer dep in old ebuild (bug #553198, thanks to Patrick... (diff)
downloadgentoo-2-fa92ab79029f134adf3e4dd9eefad20eaffb1fc1.tar.gz
gentoo-2-fa92ab79029f134adf3e4dd9eefad20eaffb1fc1.tar.bz2
gentoo-2-fa92ab79029f134adf3e4dd9eefad20eaffb1fc1.zip
fix out-of-source build with modified patch from Nikoli (bug #477310)
(Portage version: 2.2.18/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/d0_blind_id/ChangeLog7
-rw-r--r--dev-libs/d0_blind_id/d0_blind_id-0.5.ebuild23
2 files changed, 18 insertions, 12 deletions
diff --git a/dev-libs/d0_blind_id/ChangeLog b/dev-libs/d0_blind_id/ChangeLog
index d7654c2b280f..fbf65d37a2fa 100644
--- a/dev-libs/d0_blind_id/ChangeLog
+++ b/dev-libs/d0_blind_id/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/d0_blind_id
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/d0_blind_id/ChangeLog,v 1.12 2013/01/30 22:58:37 mr_bones_ Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/d0_blind_id/ChangeLog,v 1.13 2015/06/25 03:25:18 mr_bones_ Exp $
+
+ 25 Jun 2015; Michael Sterrett <mr_bones_@gentoo.org> d0_blind_id-0.5.ebuild:
+ fix out-of-source build with modified patch from Nikoli (bug #477310)
30 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org> -d0_blind_id-0.3.ebuild:
old
diff --git a/dev-libs/d0_blind_id/d0_blind_id-0.5.ebuild b/dev-libs/d0_blind_id/d0_blind_id-0.5.ebuild
index e1a404bd3f59..8b04df65fada 100644
--- a/dev-libs/d0_blind_id/d0_blind_id-0.5.ebuild
+++ b/dev-libs/d0_blind_id/d0_blind_id-0.5.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/d0_blind_id/d0_blind_id-0.5.ebuild,v 1.5 2012/05/04 18:35:54 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/d0_blind_id/d0_blind_id-0.5.ebuild,v 1.6 2015/06/25 03:25:18 mr_bones_ Exp $
-EAPI=4
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
inherit autotools-utils
DESCRIPTION="Blind-ID library for user identification using RSA blind signatures"
@@ -14,24 +15,26 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="static-libs"
-RDEPEND="dev-libs/gmp"
+RDEPEND="dev-libs/gmp:0"
DEPEND="${RDEPEND}
virtual/pkgconfig"
DOCS=( d0_blind_id.txt )
-AUTOTOOLS_IN_SOURCE_BUILD=1
+src_prepare() {
+ # fix out-of-source build
+ sed -i \
+ -e 's, d0_rijndael.c, "$srcdir/d0_rijndael.c",' \
+ configure.ac || die
+
+ autotools-utils_src_prepare
+}
src_configure() {
local myeconfargs=(
--enable-rijndael
--without-openssl
--without-tommath
- $(use_enable static-libs static)
)
autotools-utils_src_configure
}
-
-src_install() {
- autotools-utils_src_install
-}