summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2004-12-01 23:33:21 +0000
committerMichael Imhof <tantive@gentoo.org>2004-12-01 23:33:21 +0000
commitfcee0bfe612b6fb1d3a05ac1a15449c303a4ea8e (patch)
tree96d40ff7a7c302da352da80ba26f167793871670 /dev-libs
parentProper use of the usb use flag. Closes #54925. (Manifest recommit) (diff)
downloadgentoo-2-fcee0bfe612b6fb1d3a05ac1a15449c303a4ea8e.tar.gz
gentoo-2-fcee0bfe612b6fb1d3a05ac1a15449c303a4ea8e.tar.bz2
gentoo-2-fcee0bfe612b6fb1d3a05ac1a15449c303a4ea8e.zip
Bumped to -r2. Closes #71742.
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/ace/ChangeLog7
-rw-r--r--dev-libs/ace/Manifest4
-rw-r--r--dev-libs/ace/ace-5.4-r2.ebuild83
-rw-r--r--dev-libs/ace/files/digest-ace-5.4-r21
4 files changed, 93 insertions, 2 deletions
diff --git a/dev-libs/ace/ChangeLog b/dev-libs/ace/ChangeLog
index ecb6c91f5daa..ec2ca8ab5ff2 100644
--- a/dev-libs/ace/ChangeLog
+++ b/dev-libs/ace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/ace
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ChangeLog,v 1.22 2004/11/15 19:28:41 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ChangeLog,v 1.23 2004/12/01 23:33:21 tantive Exp $
+
+*ace-5.4-r2 (02 Dec 2004)
+
+ 02 Dec 2004; Michael Imhof <tantive@gentoo.org> +ace-5.4-r2.ebuild:
+ Bumped to -r2. Closes #71742.
15 Nov 2004; Gustavo Zacarias <gustavoz@gentoo.org> ace-5.4-r1.ebuild:
Stable on sparc
diff --git a/dev-libs/ace/Manifest b/dev-libs/ace/Manifest
index 9f36855c1ed3..6c08f4b232bf 100644
--- a/dev-libs/ace/Manifest
+++ b/dev-libs/ace/Manifest
@@ -1,7 +1,9 @@
-MD5 55446c3dfe0a77ffd34d998774b1dfed ChangeLog 2428
MD5 a202d56fd3622b28877ec98d87c14273 ace-5.3.ebuild 2036
MD5 4621efd43833273d01025f6118adef0f ace-5.4.ebuild 2182
+MD5 6808aca26ab1c510bd8f422745db5e72 ace-5.4-r2.ebuild 2585
+MD5 55446c3dfe0a77ffd34d998774b1dfed ChangeLog 2428
MD5 22c3bc48a181192de9d16fb670357ee3 ace-5.4-r1.ebuild 2509
+MD5 3e3d835be64fd3d448525a09dec99bba files/digest-ace-5.4-r2 61
MD5 b88f6bda8016adf15d1660b3f1e0312e files/digest-ace-5.3 60
MD5 3e3d835be64fd3d448525a09dec99bba files/digest-ace-5.4 61
MD5 3e3d835be64fd3d448525a09dec99bba files/digest-ace-5.4-r1 61
diff --git a/dev-libs/ace/ace-5.4-r2.ebuild b/dev-libs/ace/ace-5.4-r2.ebuild
new file mode 100644
index 000000000000..3572b9647665
--- /dev/null
+++ b/dev-libs/ace/ace-5.4-r2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ace-5.4-r2.ebuild,v 1.1 2004/12/01 23:33:21 tantive Exp $
+
+S=${WORKDIR}/ACE_wrappers
+DESCRIPTION="The Adaptive Communications Environment"
+SRC_URI="http://deuce.doc.wustl.edu/old_distribution/ACE-${PV}.tar.bz2"
+HOMEPAGE="http://www.cs.wustl.edu/~schmidt/ACE.html"
+
+SLOT="0"
+LICENSE="BSD as-is"
+KEYWORDS="x86 sparc ~ppc ~alpha ~amd64"
+IUSE="ipv6"
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/ace
+ use ipv6 && sed -e "s/#define ACE_HAS_PTHREADS$/#define ACE_HAS_PTHREADS\n#define ACE_HAS_IPV6/" config-linux.h >config.h
+ use ipv6 || cp config-linux.h config.h
+ cd ${S}/include/makeinclude
+ sed -e "s:-O3:${CFLAGS}:" platform_linux.GNU >platform_macros.GNU
+}
+
+src_compile() {
+ export ACE_ROOT=${S}
+ cd ${S}/ace
+ emake static_libs=1 || die
+}
+
+src_install() {
+ dodir /usr/include/ace /usr/lib /usr/share/man/man3
+ cd ${S}/ace
+ cp libACE.so ${D}/usr/lib/libACE.so.${PV}
+ cp libACE.a ${D}/usr/lib/libACE.a
+ cp libACE_RMCast.so ${D}/usr/lib/libACE_RMCast.so.${PV}
+ cp libACE_RMCast.a ${D}/usr/lib/libACE_RMCast.a
+ cd ${D}/usr/lib
+# ln -s libACE.so.${PV} libACE.so.`echo ${PV} | cut -f1 -d.`
+ ln -s libACE.so.${PV} libACE.so
+ ln -s libACE.so.${PV} libACE.so.${PV}.0
+# ln -s libACE_RMCast.so.${PV} libACE_RMCast.so.`echo ${PV} | cut -f1 -d.`
+ ln -s libACE_RMCast.so.${PV} libACE_RMCast.so
+ ln -s libACE_RMCast.so.${PV} libACE_RMCast.so.${PV}.0
+
+ cd ${S}/ace
+ #don't really need the .cpp's after it's built
+ #Hmm, 5.4 seems to need the .cpp's?
+# cp -r *.{h,hpp,i,inl} ${D}/usr/include/ace
+ cp -r * ${D}/usr/include/ace/
+ cp -r os_include ${D}/usr/include/ace/
+ chmod -R 644 ${D}/usr/include/ace/*
+ cd ${D}/usr/include/ace/
+ find -type d -exec chmod 755 \{\} \;
+
+ cd ${S}/man
+ cp -r man? ${D}/usr/share/man
+ chmod 644 ${D}/usr/share/man/man?/*
+ gzip -q ${D}/usr/share/man/man?/*
+
+ cd ${S}
+ dodoc ACE-INSTALL* AUTHORS COPYING FAQ PROBLEM-REPORT-FORM README
+ dodoc THANKS TODO VERSION
+ cd ${S}/docs
+ dodoc *
+ cd ${S}
+ docinto ChangeLogs
+ dodoc ChangeLog
+ cd ${S}/ChangeLogs
+ dodoc *
+}
+
+pkg_postinst() {
+ # This is required, as anything trying to compile against ACE will have
+ # problems with conflicting OS.h files if this is not done.
+
+ local CC_MACHINE=`gcc -dumpmachine`
+ local CC_VERSION=`gcc -dumpversion`
+ if [ -d "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace" ]; then
+ mv "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace" \
+ "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace.old"
+ fi
+}
diff --git a/dev-libs/ace/files/digest-ace-5.4-r2 b/dev-libs/ace/files/digest-ace-5.4-r2
new file mode 100644
index 000000000000..5af8e0d0bdcd
--- /dev/null
+++ b/dev-libs/ace/files/digest-ace-5.4-r2
@@ -0,0 +1 @@
+MD5 51e997b07ea8a9cf38361cc9f2b6fede ACE-5.4.tar.bz2 5934471