summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-05-11 10:58:26 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-05-11 10:58:26 +0000
commit0206c331ad3dc207a0fe296e27693bc1e6cb5d7c (patch)
treeabfbc372653ec8bf71f66feae53090964c2fb6ff /dev-lisp/cl-cells/cl-cells-20050511.ebuild
parentVersion bump. (diff)
downloadgentoo-2-0206c331ad3dc207a0fe296e27693bc1e6cb5d7c.tar.gz
gentoo-2-0206c331ad3dc207a0fe296e27693bc1e6cb5d7c.tar.bz2
gentoo-2-0206c331ad3dc207a0fe296e27693bc1e6cb5d7c.zip
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'dev-lisp/cl-cells/cl-cells-20050511.ebuild')
-rw-r--r--dev-lisp/cl-cells/cl-cells-20050511.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-lisp/cl-cells/cl-cells-20050511.ebuild b/dev-lisp/cl-cells/cl-cells-20050511.ebuild
new file mode 100644
index 000000000000..330bcc227de6
--- /dev/null
+++ b/dev-lisp/cl-cells/cl-cells-20050511.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-cells/cl-cells-20050511.ebuild,v 1.1 2005/05/11 10:58:26 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DESCRIPTION="Cells is a Common Lisp library providing a data flow extension to CLOS."
+HOMEPAGE="http://common-lisp.net/project/cells/
+ http://www.tilton-technology.com/cells_top.html"
+SRC_URI="mirrors://gentoo/cells-${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86 ~amd64 ~ppc"
+IUSE=""
+
+DEPEND="dev-lisp/cl-utils-kt"
+
+CLPACKAGE="cells cells-test"
+
+S=${WORKDIR}/cells
+
+# Note: To update this version, use
+# http://common-lisp.net/cgi-bin/viewcvs.cgi/cell-cultures/cells/?cvsroot=cells
+# and compare dates. Then use the "Download tarball" link.
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-gentoo.patch || die
+}
+
+src_install() {
+ dodir $CLSYSTEMROOT
+ insinto $CLSOURCEROOT/cells; doins *.{asd,lisp}
+ insinto $CLSOURCEROOT/cells-test; doins cells-test/*.{asd,lisp}
+ dosym $CLSOURCEROOT/cells/cells.asd $CLSYSTEMROOT
+ dosym $CLSOURCEROOT/cells-test/cells-test.asd $CLSYSTEMROOT
+ dodoc doc/*
+}
+