summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-01-31 05:59:01 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-01-31 05:59:01 +0000
commit24ff51f43423a2353ebf4a73a15933e839618e17 (patch)
treea4dc32dc6e4fb364896f49f24d079cd6b7a55718 /dev-lisp/cl-ironclad/cl-ironclad-0.12.ebuild
parent- get rid of compiler warning when using mcpu with newer gcc. no need to forc... (diff)
downloadgentoo-2-24ff51f43423a2353ebf4a73a15933e839618e17.tar.gz
gentoo-2-24ff51f43423a2353ebf4a73a15933e839618e17.tar.bz2
gentoo-2-24ff51f43423a2353ebf4a73a15933e839618e17.zip
New upstream version.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'dev-lisp/cl-ironclad/cl-ironclad-0.12.ebuild')
-rw-r--r--dev-lisp/cl-ironclad/cl-ironclad-0.12.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-lisp/cl-ironclad/cl-ironclad-0.12.ebuild b/dev-lisp/cl-ironclad/cl-ironclad-0.12.ebuild
new file mode 100644
index 000000000000..5eb7715cb88a
--- /dev/null
+++ b/dev-lisp/cl-ironclad/cl-ironclad-0.12.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-ironclad/cl-ironclad-0.12.ebuild,v 1.1 2006/01/31 05:59:01 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Ironclad is a Common Lisp library similar to OpenSSL, GNU TLS or Crypto++"
+HOMEPAGE="http://www.cliki.net/Ironclad"
+SRC_URI="http://www.cs.rice.edu/~froydnj/lisp/ironclad_${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND=""
+
+CLPACKAGE=ironclad
+
+S=${WORKDIR}/ironclad_${PV}
+
+src_install() {
+ common-lisp-install *.{lisp,asd}
+ common-lisp-system-symlink
+ insinto $CLSOURCEROOT/ironclad/test-vectors
+ doins test-vectors/*.lisp
+ dodoc README TODO NEWS LICENSE
+}