summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-03-04 21:56:45 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-03-04 21:56:45 +0000
commit5baf43201967616e2cfb848938fa7d5c7481b39c (patch)
treec515acbf7dcff6c0e900421757fcc3108ae98a47 /dev-lisp/cl-mcclim
parentCleanup submitted by Jonathan Heaney (Manifest recommit) (diff)
downloadgentoo-2-5baf43201967616e2cfb848938fa7d5c7481b39c.tar.gz
gentoo-2-5baf43201967616e2cfb848938fa7d5c7481b39c.tar.bz2
gentoo-2-5baf43201967616e2cfb848938fa7d5c7481b39c.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp/cl-mcclim')
-rw-r--r--dev-lisp/cl-mcclim/ChangeLog10
-rw-r--r--dev-lisp/cl-mcclim/Manifest6
-rw-r--r--dev-lisp/cl-mcclim/cl-mcclim-0.9.ebuild79
-rw-r--r--dev-lisp/cl-mcclim/files/0.9/system.lisp-gentoo.patch24
-rw-r--r--dev-lisp/cl-mcclim/files/TODO.Gentoo12
-rw-r--r--dev-lisp/cl-mcclim/files/digest-cl-mcclim-0.91
-rw-r--r--dev-lisp/cl-mcclim/metadata.xml22
7 files changed, 154 insertions, 0 deletions
diff --git a/dev-lisp/cl-mcclim/ChangeLog b/dev-lisp/cl-mcclim/ChangeLog
new file mode 100644
index 000000000000..cc8c969028b7
--- /dev/null
+++ b/dev-lisp/cl-mcclim/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/cl-mcclim
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-mcclim/ChangeLog,v 1.1 2004/03/04 21:56:45 mkennedy Exp $
+
+*cl-mcclim-0.9 (04 Mar 2004)
+
+ 04 Mar 2004; <mkennedy@gentoo.org> cl-mcclim-0.9.ebuild, metadata.xml,
+ files/TODO.Gentoo, files/0.9/system.lisp-gentoo.patch:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/cl-mcclim/Manifest b/dev-lisp/cl-mcclim/Manifest
new file mode 100644
index 000000000000..f00de1a17878
--- /dev/null
+++ b/dev-lisp/cl-mcclim/Manifest
@@ -0,0 +1,6 @@
+MD5 47d487fb3c8f3e8ce6d15ce7f26f8624 ChangeLog 365
+MD5 c8d8979589a5ef6d1310a74961af2636 metadata.xml 1191
+MD5 ad24b9a36ed90b1ecbb5585b141f3fe4 cl-mcclim-0.9.ebuild 2300
+MD5 f54ab82a0c7cd3535e08011827b6bd4a files/TODO.Gentoo 226
+MD5 91915558ef2580b27d0e99f555988c86 files/digest-cl-mcclim-0.9 60
+MD5 3f8a3f5066bf6c9b4035a9b40d426825 files/0.9/system.lisp-gentoo.patch 651
diff --git a/dev-lisp/cl-mcclim/cl-mcclim-0.9.ebuild b/dev-lisp/cl-mcclim/cl-mcclim-0.9.ebuild
new file mode 100644
index 000000000000..fd192efbeb8a
--- /dev/null
+++ b/dev-lisp/cl-mcclim/cl-mcclim-0.9.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-mcclim/cl-mcclim-0.9.ebuild,v 1.1 2004/03/04 21:56:45 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="McCLIM is a free software implementation of CLIM."
+HOMEPAGE="http://clim.mikemac.com/
+ http://clim.mikemac.com/spec/clim.html"
+SRC_URI="http://clim.mikemac.com/downloads/snapshots/src/McCLIM-${PV}.tgz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="dev-lisp/common-lisp-controller
+ dev-lisp/cmucl-source
+ dev-lisp/cl-clx-sbcl
+ doc? ( media-gfx/transfig
+ media-libs/netpbm
+ virtual/tetex )"
+
+CLPACKAGE="clim clim-clx clim-examples"
+
+S=${WORKDIR}/McCLIM
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}/system.lisp-gentoo.patch
+ mkdir ${S}/clim-spec
+}
+
+src_compile() {
+ if use doc; then
+ make -C Doc manual.ps
+ if [ -x /usr/bin/lisp ]; then
+ lisp -batch -noinit -nosite-init -eval "
+(progn
+ (compile-file \"Tools/gilbert/clim-doc-convert\")
+ (quit))"
+ lisp -batch -noinit -nositeinit \
+ -load Tools/gilbert/clim-doc-convert \
+ -eval "
+(progn
+ (defparameter clim-doc-convert::*mcclim-base-dir* \"${S}/\")
+ (defparameter clim-doc-convert::*output-directory* \"${S}/clim-spec/\")
+ (clim-doc-convert:run)
+ (quit))"
+ elif [ -x /usr/bin/sbcl ]; then
+ ewarn "Documentation cannot be built with SBCL at this time"
+ elif [ -x /usr/bin/clisp ]; then
+ ewarn "Documentation cannot be built with CLISP at this time"
+ fi
+ fi
+}
+
+src_install() {
+ insinto /usr/share/common-lisp/source/clim
+ doins *.lisp
+ for i in Apps Backends Examples Experimental Goatee Images Lisp-Dep Looks; do
+ cp -r ${i} ${D}/usr/share/common-lisp/source/clim/
+ done
+ dodir /usr/share/common-lisp/systems/
+
+ dosym /usr/share/common-lisp/source/clim/system.lisp /usr/share/common-lisp/systems/clim.asd
+
+ for i in clim-clx clim-examples; do
+ dosym /usr/share/common-lisp/source/clim /usr/share/common-lisp/source/${i}
+ dosym /usr/share/common-lisp/source/${i}/system.lisp /usr/share/common-lisp/systems/${i}.asd
+ done
+
+ dodoc README Copyright TODO INSTALL*
+
+ if use doc; then
+ dodoc Doc/manual.ps
+ insinto /usr/share/doc/${PF}/html/Spec
+ doins clim-spec/*
+ fi
+
+ find ${D} -type d -name CVS -print |xargs rm -rf
+}
diff --git a/dev-lisp/cl-mcclim/files/0.9/system.lisp-gentoo.patch b/dev-lisp/cl-mcclim/files/0.9/system.lisp-gentoo.patch
new file mode 100644
index 000000000000..4011b7b95271
--- /dev/null
+++ b/dev-lisp/cl-mcclim/files/0.9/system.lisp-gentoo.patch
@@ -0,0 +1,24 @@
+--- McCLIM/system.lisp.original 2004-03-04 14:54:12.750240760 -0600
++++ McCLIM/system.lisp 2004-03-04 14:58:50.797971080 -0600
+@@ -25,15 +25,12 @@
+
+ #+cmu
+ (progn
+- (unless (fboundp 'ext:stream-read-char)
+- (unless (ignore-errors (ext:search-list "gray-streams:"))
+- (setf (ext:search-list "gray-streams:")
+- '("target:pcl/" "library:subsystems/")))
+- (load "gray-streams:gray-streams-library"))
+- #-clx
+- (require :clx)
+- #-mk-defsystem
+- (load "library:subsystems/defsystem"))
++ (require :cmucl-graystream)
++ (require :cmucl-clx))
++
++#+sbcl
++(progn
++ (require :clx))
+
+ (pushnew :clim *features*)
+ (pushnew :mcclim *features*)
diff --git a/dev-lisp/cl-mcclim/files/TODO.Gentoo b/dev-lisp/cl-mcclim/files/TODO.Gentoo
new file mode 100644
index 000000000000..c0b563a39cc6
--- /dev/null
+++ b/dev-lisp/cl-mcclim/files/TODO.Gentoo
@@ -0,0 +1,12 @@
+
+-*- Outline -*-
+
+ * Investigate CLISP portability
+
+ * Provide packages for the Listener and SciGraph
+ (dev-lisp/cl-clim-listener and dev-lisp/cl-clim-scigraph
+
+ * catalog other CLIM source for inclusion into portage
+
+
+
diff --git a/dev-lisp/cl-mcclim/files/digest-cl-mcclim-0.9 b/dev-lisp/cl-mcclim/files/digest-cl-mcclim-0.9
new file mode 100644
index 000000000000..f93d39b37fd0
--- /dev/null
+++ b/dev-lisp/cl-mcclim/files/digest-cl-mcclim-0.9
@@ -0,0 +1 @@
+MD5 1d35c9ccedfd210ae996bb700793a7c6 McCLIM-0.9.tgz 3304356
diff --git a/dev-lisp/cl-mcclim/metadata.xml b/dev-lisp/cl-mcclim/metadata.xml
new file mode 100644
index 000000000000..967478aee53a
--- /dev/null
+++ b/dev-lisp/cl-mcclim/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+The Common Lisp Interface Manager (CLIM) is a powerful Lisp-based programming interface
+that provides a layered set of portable facilities for constructing user interfaces. These
+include basic windowing, input, output, and graphics services; stream-oriented input and
+output extended with facilities such as output recording, presentations, and context
+sensitive input; high level ``formatted output'' facilities; application building
+facilities; command processing; and a compositional toolkit similar to those found in the
+X world that supports look and feel independence.
+
+CLIM provides an API (applications programmer interface) to user interface facilities for
+the Lisp application programmer. CLIM does not compete with the window system or toolkits
+of the host machine (such as Motif or OpenLook), but rather uses their services (to the
+extent that it makes sense) to integrate Lisp applications into the host's window
+environment.
+
+McCLIM is a free software implementation of CLIM.
+</longdescription>
+</pkgmetadata>