summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-10-16 04:20:59 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-10-16 04:20:59 +0000
commitb0daf917c0b3090d8eb493a1f842dd97b58d529a (patch)
treeaa3b552b6108645aa4cb50caec42fc1492ac6bd9 /dev-lisp/cl-png
parentMark 0.2.36-r2 ~ia64. #141223 (diff)
downloadgentoo-2-b0daf917c0b3090d8eb493a1f842dd97b58d529a.tar.gz
gentoo-2-b0daf917c0b3090d8eb493a1f842dd97b58d529a.tar.bz2
gentoo-2-b0daf917c0b3090d8eb493a1f842dd97b58d529a.zip
Load /lib/libz.so
(Portage version: 2.1.2_pre2-r9)
Diffstat (limited to 'dev-lisp/cl-png')
-rw-r--r--dev-lisp/cl-png/ChangeLog10
-rw-r--r--dev-lisp/cl-png/cl-png-0.4-r1.ebuild29
-rw-r--r--dev-lisp/cl-png/files/digest-cl-png-0.42
-rw-r--r--dev-lisp/cl-png/files/digest-cl-png-0.4-r13
-rw-r--r--dev-lisp/cl-png/files/libz-path-gentoo.patch12
5 files changed, 54 insertions, 2 deletions
diff --git a/dev-lisp/cl-png/ChangeLog b/dev-lisp/cl-png/ChangeLog
index 511914d35222..412a2e6f5307 100644
--- a/dev-lisp/cl-png/ChangeLog
+++ b/dev-lisp/cl-png/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/cl-png
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-png/ChangeLog,v 1.9 2005/05/24 18:48:34 mkennedy Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-png/ChangeLog,v 1.10 2006/10/16 04:20:59 mkennedy Exp $
+
+*cl-png-0.4-r1 (16 Oct 2006)
+
+ 16 Oct 2006; Matthew Kennedy <mkennedy@gentoo.org>
+ +files/libz-path-gentoo.patch, +cl-png-0.4-r1.ebuild:
+ Load /lib/libz.so
24 May 2005; <mkennedy@gentoo.org> cl-png-0.4.ebuild:
Keywording ~sparc
diff --git a/dev-lisp/cl-png/cl-png-0.4-r1.ebuild b/dev-lisp/cl-png/cl-png-0.4-r1.ebuild
new file mode 100644
index 000000000000..2224c924bfc1
--- /dev/null
+++ b/dev-lisp/cl-png/cl-png-0.4-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-png/cl-png-0.4-r1.ebuild,v 1.1 2006/10/16 04:20:59 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Common Lisp package to read and write PNG image files"
+HOMEPAGE="http://www.pvv.ntnu.no/~musum/lisp/code/
+ http://www.cliki.net/PNG
+ http://packages.debian.org/unstable/devel/cl-png.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-png/cl-png_${PV}.orig.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND="dev-lisp/cl-uffi"
+
+CLPACKAGE=png
+
+src_unpack() {
+ unpack $A
+ epatch ${FILESDIR}/libz-path-gentoo.patch
+}
+
+src_install() {
+ common-lisp-install *.cl *.asd
+ common-lisp-system-symlink
+ dodoc COPYING README
+}
diff --git a/dev-lisp/cl-png/files/digest-cl-png-0.4 b/dev-lisp/cl-png/files/digest-cl-png-0.4
index c3164c3dffdf..56a8dce1dce7 100644
--- a/dev-lisp/cl-png/files/digest-cl-png-0.4
+++ b/dev-lisp/cl-png/files/digest-cl-png-0.4
@@ -1 +1,3 @@
MD5 58cb2a6bb6eb5e240a8d7c6e860f5384 cl-png_0.4.orig.tar.gz 33021
+RMD160 16f3dd0312fefba209d5fd1c002789a47e8999b9 cl-png_0.4.orig.tar.gz 33021
+SHA256 831ab8c5020147c9c91c7ed128563691c3ab824c11f75d32f717b11d5858b6f1 cl-png_0.4.orig.tar.gz 33021
diff --git a/dev-lisp/cl-png/files/digest-cl-png-0.4-r1 b/dev-lisp/cl-png/files/digest-cl-png-0.4-r1
new file mode 100644
index 000000000000..56a8dce1dce7
--- /dev/null
+++ b/dev-lisp/cl-png/files/digest-cl-png-0.4-r1
@@ -0,0 +1,3 @@
+MD5 58cb2a6bb6eb5e240a8d7c6e860f5384 cl-png_0.4.orig.tar.gz 33021
+RMD160 16f3dd0312fefba209d5fd1c002789a47e8999b9 cl-png_0.4.orig.tar.gz 33021
+SHA256 831ab8c5020147c9c91c7ed128563691c3ab824c11f75d32f717b11d5858b6f1 cl-png_0.4.orig.tar.gz 33021
diff --git a/dev-lisp/cl-png/files/libz-path-gentoo.patch b/dev-lisp/cl-png/files/libz-path-gentoo.patch
new file mode 100644
index 000000000000..5ae3ee1ac16f
--- /dev/null
+++ b/dev-lisp/cl-png/files/libz-path-gentoo.patch
@@ -0,0 +1,12 @@
+diff -ur cl-png-0.4.orig/zlib-from-cl-pdf.cl cl-png-0.4/zlib-from-cl-pdf.cl
+--- cl-png-0.4.orig/zlib-from-cl-pdf.cl 2004-03-06 22:44:17.000000000 -0600
++++ cl-png-0.4/zlib-from-cl-pdf.cl 2006-10-15 23:08:17.000000000 -0500
+@@ -19,7 +19,7 @@
+ ;; won't load the compiled file. Putting it in an eval-when in
+ ;; config.lisp doesn't work either.
+
+-(defvar *zlib-search-paths* '("/usr/local/lib/" "/usr/lib/")
++(defvar *zlib-search-paths* '("/lib/")
+ "The paths where to search the zlib shared library")
+
+ (defparameter *zlib-path*