summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-10-06 10:18:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-10-06 10:18:02 +0000
commit6e06ad7d41334fe98ffac8bf2ad1aaf77894cf1a (patch)
tree8a8269f6455829fcd0e3f5fd2ee632e0aff34828 /dev-lisp/cl-xmls/cl-xmls-0.5.ebuild
parentinitial import (diff)
downloadgentoo-2-6e06ad7d41334fe98ffac8bf2ad1aaf77894cf1a.tar.gz
gentoo-2-6e06ad7d41334fe98ffac8bf2ad1aaf77894cf1a.tar.bz2
gentoo-2-6e06ad7d41334fe98ffac8bf2ad1aaf77894cf1a.zip
initial import
Diffstat (limited to 'dev-lisp/cl-xmls/cl-xmls-0.5.ebuild')
-rw-r--r--dev-lisp/cl-xmls/cl-xmls-0.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-lisp/cl-xmls/cl-xmls-0.5.ebuild b/dev-lisp/cl-xmls/cl-xmls-0.5.ebuild
new file mode 100644
index 000000000000..e41178211636
--- /dev/null
+++ b/dev-lisp/cl-xmls/cl-xmls-0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-xmls/cl-xmls-0.5.ebuild,v 1.1 2003/10/06 10:18:00 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION=" Xmls is a small, simple, non-validating xml parser for Common Lisp. It's designed to be a self-contained, easily embedded parser that recognizes a useful subset of the XML spec. It provides a simple mapping from xml to lisp s-expressions and back."
+HOMEPAGE="http://www.caddr.com/lisp/xmls/
+ http://www.cliki.net/xmls"
+SRC_URI="http://www.caddr.com/lisp/xmls/xmls-${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=xmls
+
+S=${WORKDIR}/xmls-${PV}
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ dodoc ChangeLog COPYING
+ dohtml README.html
+ cp -r tests ${D}/usr/share/doc/${P}/
+ dodoc run-tests.sh
+}