summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-09-05 03:21:40 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-09-05 03:21:40 +0000
commit917835761a727c33bcc2d7bab2933614200c87d5 (patch)
tree99f6f41eb9fa5c33acacdde242c5c388ccfe16aa /dev-lisp/clisp/files
parentnew upstream version, enhanced module support etc. (diff)
downloadgentoo-2-917835761a727c33bcc2d7bab2933614200c87d5.tar.gz
gentoo-2-917835761a727c33bcc2d7bab2933614200c87d5.tar.bz2
gentoo-2-917835761a727c33bcc2d7bab2933614200c87d5.zip
new upstream version, enhanced module support etc.
Diffstat (limited to 'dev-lisp/clisp/files')
-rw-r--r--dev-lisp/clisp/files/2.31/bindings-glibc-linux.lisp-gentoo.patch22
-rw-r--r--dev-lisp/clisp/files/2.31/bindings-wildcard-fnmatch.c-gentoo.patch33
-rw-r--r--dev-lisp/clisp/files/digest-clisp-2.311
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-lisp/clisp/files/2.31/bindings-glibc-linux.lisp-gentoo.patch b/dev-lisp/clisp/files/2.31/bindings-glibc-linux.lisp-gentoo.patch
new file mode 100644
index 000000000000..48ef331feaba
--- /dev/null
+++ b/dev-lisp/clisp/files/2.31/bindings-glibc-linux.lisp-gentoo.patch
@@ -0,0 +1,22 @@
+diff -u clisp-2.31.orig/modules/bindings/glibc/linux.lisp clisp-2.31/modules/bindings/glibc/linux.lisp
+--- clisp-2.31.orig/modules/bindings/glibc/linux.lisp 2003-08-07 15:23:56.000000000 -0500
++++ clisp-2.31/modules/bindings/glibc/linux.lisp 2003-09-04 02:13:04.383537043 -0500
+@@ -873,8 +873,6 @@
+ ; (:arguments (x double-float) (iptr (c-ptr double-float) :out))
+ ; (:return-type double-float))
+ (def-call-out rint (:arguments (x double-float)) (:return-type double-float))
+-(def-call-out scalb (:arguments (x double-float) (n double-float))
+- (:return-type double-float))
+ (def-call-out nextafter (:arguments (x double-float) (y double-float))
+ (:return-type double-float))
+ (def-call-out remainder (:arguments (x double-float) (y double-float))
+@@ -964,8 +962,6 @@
+ ; (:arguments (x single-float) (iptr (c-ptr single-float) :out))
+ ; (:return-type single-float))
+ (def-call-out rintf (:arguments (x single-float)) (:return-type single-float))
+-(def-call-out scalbf (:arguments (x single-float) (n single-float))
+- (:return-type single-float))
+ (def-call-out nextafterf (:arguments (x single-float) (y single-float))
+ (:return-type single-float))
+ (def-call-out remainderf (:arguments (x single-float) (y single-float))
+Only in clisp-2.31/modules/bindings/glibc/: linux.lisp~
diff --git a/dev-lisp/clisp/files/2.31/bindings-wildcard-fnmatch.c-gentoo.patch b/dev-lisp/clisp/files/2.31/bindings-wildcard-fnmatch.c-gentoo.patch
new file mode 100644
index 000000000000..1e7cce411ae9
--- /dev/null
+++ b/dev-lisp/clisp/files/2.31/bindings-wildcard-fnmatch.c-gentoo.patch
@@ -0,0 +1,33 @@
+diff -u clisp-2.31.orig/modules/wildcard/Makefile.in clisp-2.31/modules/wildcard/Makefile.in
+--- clisp-2.31.orig/modules/wildcard/Makefile.in 2000-03-31 18:17:50.000000000 -0600
++++ clisp-2.31/modules/wildcard/Makefile.in 2003-09-04 03:24:14.869343640 -0500
+@@ -24,7 +24,7 @@
+ $(CC) $(CFLAGS) -I$(INCLUDES) -c wildcard.c
+
+ fnmatch.o : fnmatch.c fnmatch.h
+- $(CC) $(CFLAGS) -I. -DHAVE_CONFIG_H -D_LIBC -c fnmatch.c
++ $(CC) $(CFLAGS) -I. -DHAVE_CONFIG_H -c fnmatch.c
+
+ # Make a module
+ clisp-module : all
+Only in clisp-2.31/modules/wildcard: Makefile.in~
+diff -u clisp-2.31.orig/modules/wildcard/fnmatch.c clisp-2.31/modules/wildcard/fnmatch.c
+--- clisp-2.31.orig/modules/wildcard/fnmatch.c 1998-07-22 15:22:52.000000000 -0500
++++ clisp-2.31/modules/wildcard/fnmatch.c 2003-09-04 03:24:37.101169587 -0500
+@@ -37,9 +37,6 @@
+ program understand `configure --with-gnu-libc' and omit the object files,
+ it is simpler to just do this in the source for each such file. */
+
+-#if defined (_LIBC) || !defined (__GNU_LIBRARY__)
+-
+-
+ # if defined (STDC_HEADERS) || !defined (isascii)
+ # define ISASCII(c) 1
+ # else
+@@ -237,5 +234,3 @@
+
+ # undef FOLD
+ }
+-
+-#endif /* _LIBC or not __GNU_LIBRARY__. */
+Only in clisp-2.31/modules/wildcard: fnmatch.c~
diff --git a/dev-lisp/clisp/files/digest-clisp-2.31 b/dev-lisp/clisp/files/digest-clisp-2.31
new file mode 100644
index 000000000000..79487e6dcf81
--- /dev/null
+++ b/dev-lisp/clisp/files/digest-clisp-2.31
@@ -0,0 +1 @@
+MD5 44bf68b218721540be60250fc1259483 clisp-2.31.tar.bz2 5936744