summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-03-26 19:43:26 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-03-26 19:43:26 +0000
commit2b958c454ff50124da6e218feae662c42c919e66 (patch)
tree5f60d04359de1077a3c6abc0f28023038f5c7a5a /dev-lisp/clisp
parentgpl fix (diff)
downloadgentoo-2-2b958c454ff50124da6e218feae662c42c919e66.tar.gz
gentoo-2-2b958c454ff50124da6e218feae662c42c919e66.tar.bz2
gentoo-2-2b958c454ff50124da6e218feae662c42c919e66.zip
minor version bump
Diffstat (limited to 'dev-lisp/clisp')
-rw-r--r--dev-lisp/clisp/ChangeLog8
-rw-r--r--dev-lisp/clisp/clisp-2.30.ebuild47
-rw-r--r--dev-lisp/clisp/files/clisp-2.30-gentoo.patch32
-rw-r--r--dev-lisp/clisp/files/clisp-2.30-linux.lisp-upstream.patch122
-rw-r--r--dev-lisp/clisp/files/digest-clisp-2.301
5 files changed, 209 insertions, 1 deletions
diff --git a/dev-lisp/clisp/ChangeLog b/dev-lisp/clisp/ChangeLog
index 1d78d1e28533..4d41acadbbc5 100644
--- a/dev-lisp/clisp/ChangeLog
+++ b/dev-lisp/clisp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/clisp
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.5 2003/02/12 06:10:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.6 2003/03/26 19:43:26 mkennedy Exp $
+
+*clisp-2.30 (26 Mar 2003)
+
+ 26 Mar 2003; Matthew Kennedy <mkennedy@gentoo.org> clisp-2.30.ebuild,
+ files/clisp-2.30-gentoo.patch, files/clisp-2.30-linux.lisp-upstream.patch:
+ minor version bump
*clisp-2.29 (29 Jul 2002)
diff --git a/dev-lisp/clisp/clisp-2.30.ebuild b/dev-lisp/clisp/clisp-2.30.ebuild
new file mode 100644
index 000000000000..9ad5fbef388e
--- /dev/null
+++ b/dev-lisp/clisp/clisp-2.30.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.30.ebuild,v 1.1 2003/03/26 19:43:26 mkennedy Exp $
+
+IUSE="X threads"
+
+DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
+HOMEPAGE="http://clisp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
+S=${WORKDIR}/${P}
+DEPEND="X? ( x11-base/xfree )"
+RDEPEND="$DEPEND"
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~x86 ~ppc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} && patch -p1 <${FILESDIR}/${P}-gentoo.patch || die
+ cd ${S} && patch -p2 <${FILESDIR}/${P}-linux.lisp-upstream.patch || die
+}
+
+src_compile() {
+ local myconf="--with-dynamic-ffi
+ --with-dynamic-modules
+ --with-export-syscalls
+ --with-module=wildcard
+ --with-module=regexp
+ --with-module=bindings/linuxlibc6"
+
+# for the time being, these modules cause segv during build
+# use X && myconf="${myconf} --with-module=clx/new-clx"
+# use threads && myconf="${myconf} --with-threads=POSIX_THREADS"
+
+ einfo "Configuring with $myconf"
+ ./configure --prefix=/usr ${myconf} || die "./configure failed"
+ cd src && ./makemake ${myconf} > Makefile
+ make config.lisp
+ make || die
+}
+
+src_install () {
+ cd src && make DESTDIR=${D} prefix=/usr install-bin || die
+ doman clisp.1 clreadline.3
+ dodoc SUMMARY README* NEWS MAGIC.add GNU-GPL COPYRIGHT \
+ ANNOUNCE clisp.dvi clisp.html clreadline.dvi clreadline.html
+}
diff --git a/dev-lisp/clisp/files/clisp-2.30-gentoo.patch b/dev-lisp/clisp/files/clisp-2.30-gentoo.patch
new file mode 100644
index 000000000000..a3c8d5b2350f
--- /dev/null
+++ b/dev-lisp/clisp/files/clisp-2.30-gentoo.patch
@@ -0,0 +1,32 @@
+diff -ur clisp-2.30~/modules/wildcard/Makefile.in clisp-2.30/modules/wildcard/Makefile.in
+--- clisp-2.30~/modules/wildcard/Makefile.in 2000-03-31 18:17:50.000000000 -0600
++++ clisp-2.30/modules/wildcard/Makefile.in 2003-03-07 11:41:22.000000000 -0600
+@@ -24,7 +24,7 @@
+ $(CC) $(CFLAGS) -I$(INCLUDES) -c wildcard.c
+
+ fnmatch.o : fnmatch.c fnmatch.h
+- $(CC) $(CFLAGS) -I. -DHAVE_CONFIG_H -D_LIBC -c fnmatch.c
++ $(CC) $(CFLAGS) -I. -DHAVE_CONFIG_H -DLIBC -c fnmatch.c
+
+ # Make a module
+ clisp-module : all
+Only in clisp-2.30/modules/wildcard: Makefile.in~
+diff -ur clisp-2.30~/modules/wildcard/fnmatch.c clisp-2.30/modules/wildcard/fnmatch.c
+--- clisp-2.30~/modules/wildcard/fnmatch.c 1998-07-22 15:22:52.000000000 -0500
++++ clisp-2.30/modules/wildcard/fnmatch.c 2003-03-07 11:41:14.000000000 -0600
+@@ -37,7 +37,7 @@
+ program understand `configure --with-gnu-libc' and omit the object files,
+ it is simpler to just do this in the source for each such file. */
+
+-#if defined (_LIBC) || !defined (__GNU_LIBRARY__)
++#if defined (LIBC) || !defined (__GNU_LIBRARY__)
+
+
+ # if defined (STDC_HEADERS) || !defined (isascii)
+@@ -238,4 +238,4 @@
+ # undef FOLD
+ }
+
+-#endif /* _LIBC or not __GNU_LIBRARY__. */
++#endif /* LIBC or not __GNU_LIBRARY__. */
+Only in clisp-2.30/modules/wildcard: fnmatch.c~
diff --git a/dev-lisp/clisp/files/clisp-2.30-linux.lisp-upstream.patch b/dev-lisp/clisp/files/clisp-2.30-linux.lisp-upstream.patch
new file mode 100644
index 000000000000..b6e3ed363bab
--- /dev/null
+++ b/dev-lisp/clisp/files/clisp-2.30-linux.lisp-upstream.patch
@@ -0,0 +1,122 @@
+===================================================================
+RCS file: /cvsroot/clisp/clisp/modules/bindings/linuxlibc6/linux.lisp,v
+retrieving revision 1.16
+retrieving revision 1.18
+diff -u -r1.16 -r1.18
+--- clisp/clisp/modules/bindings/linuxlibc6/linux.lisp 2002/07/09 21:28:04 1.16 clisp_2_30-2002-09-15
++++ clisp/clisp/modules/bindings/linuxlibc6/linux.lisp 2003/02/09 23:27:40 1.18 HEAD
+@@ -403,8 +403,11 @@
+ ; ------------------------------ <errnos.h> -----------------------------------
+
+ (def-call-out __errno_location (:arguments) (:return-type (c-ptr int)))
++;; both are broken:
+ ;; (define-symbol-macro errno (deref (foreign-value (__errno_location))))
+-(def-c-var errno (:type ffi:int))
++;; *** - FFI::%DEREF: argument is not a foreign variable: 22
++;; (def-c-var errno (:type ffi:int))
++;; link error: "undefined reference to `errno'"
+
+ ; ------------------------------ <errno.h> ------------------------------------
+
+@@ -506,7 +509,7 @@
+ (defconstant PIPE_BUF 4096)
+ )
+
+-;;; ----------------------------- <local_lim.h> ---------------------------------
++;;; ----------------------------- <local_lim.h> -------------------------------
+
+ (defconstant _POSIX_THREAD_KEYS_MAX 128)
+ (defconstant PTHREAD_KEYS_MAX 1024)
+@@ -518,7 +521,10 @@
+ ;;; ---------------------------- <posix1_lim.h> ------------------------------
+
+ (defconstant SSIZE_MAX INT_MAX)
+-(defconstant NGROUPS_MAX _POSIX_NGROUPS_MAX)
++;; #ifndef NGROUPS_MAX
++;; # define NGROUPS_MAX _POSIX_NGROUPS_MAX
++;; #endif
++;; (defconstant NGROUPS_MAX _POSIX_NGROUPS_MAX)
+
+ ;;; ---------------------------- <posix2_lim.h> ------------------------------
+
+@@ -620,7 +626,7 @@
+ (defconstant EXIT_FAILURE 1)
+ (defconstant EXIT_SUCCESS 0)
+
+-(def-call-out __ctype_get_mb_cur_max (:arguments) (:return-type int))
++(def-call-out __ctype_get_mb_cur_max (:arguments) (:return-type size_t))
+ (define-symbol-macro MB_CUR_MAX (__ctype_get_mb_cur_max))
+
+ (def-call-out atof (:arguments (nptr c-string)) (:return-type double-float))
+@@ -657,10 +663,10 @@
+ (def-call-out random (:arguments) (:return-type int32_t))
+ (def-call-out srandom (:arguments (seed uint)) (:return-type nil))
+ (def-call-out initstate
+- (:arguments (seed uint) (statebuf c-pointer) (statelen size_t))
+- (:return-type c-pointer))
+-(def-call-out setstate (:arguments (statebuf c-pointer))
+- (:return-type c-pointer))
++ (:arguments (seed uint) (statebuf c-string) (statelen size_t))
++ (:return-type c-string))
++(def-call-out setstate (:arguments (statebuf c-string))
++ (:return-type c-string))
+
+ ;; (def-c-struct random_data ...)
+ (def-call-out random_r
+@@ -691,8 +697,8 @@
+ (:return-type long))
+ (def-call-out srand48 (:arguments (seedval long))
+ (:return-type nil))
+-(def-call-out seed48 (:arguments (seed16v (c-ptr (c-array ushort 3))))
+- (:return-type (c-ptr (c-array ushort 3)) :none))
++(def-call-out seed48 (:arguments (seed16v (c-array ushort 3)))
++ (:return-type (c-ptr ushort) :none))
+ (def-call-out lcong48 (:arguments (param (c-ptr (c-array ushort 7))))
+ (:return-type nil))
+
+@@ -755,7 +761,7 @@
+ (def-call-out setenv
+ (:arguments (name c-string) (value c-string) (replace boolean))
+ (:return-type int))
+-(def-call-out unsetenv (:arguments (name c-string)) (:return-type nil))
++(def-call-out unsetenv (:arguments (name c-string)) (:return-type int))
+
+ (def-call-out clearenv (:arguments) (:return-type int))
+
+@@ -778,7 +784,7 @@
+ (:arguments (name c-string)
+ (resolved (c-ptr (c-array-max character #.PATH_MAX))
+ :out :alloca))
+- (:return-type (c-ptr (c-array-max character #.PATH_MAX))))
++ (:return-type c-string))
+
+ (def-c-type comparison_fn_t
+ (c-function (:arguments (p1 c-pointer) (p2 c-pointer))
+@@ -1169,14 +1175,19 @@
+
+ (def-c-var environ (:type (c-array-ptr c-string)) (:read-only t))
+
+-;(def-call-out execve
+-; (:arguments (path c-string) (argv c-pointer) (envp c-pointer)) ; ??
+-; (:return-type int))
+-;(def-call-out fexecve
+-; (:arguments (fd int) (argv c-pointer) (envp c-pointer)) ; ??
+-; (:return-type int)) ; is a stub (see <gnu/stubs.h>)
+-;(def-call-out execv (:arguments (path c-string) (argv c-pointer)) ; ??
+-; (:return-type int))
++(def-call-out execv
++ (:arguments (path c-string) (argv (c-array-ptr c-string)))
++ (:return-type int)
++ (:name "execv"))
++(def-call-out execve
++ (:arguments (path c-string) (argv (c-array-ptr c-string))
++ (envp (c-array-ptr c-string)))
++ (:return-type int)
++ (:name "execv"))
++(def-call-out execvp
++ (:arguments (file c-string) (argv (c-array-ptr c-string)))
++ (:return-type int)
++ (:name "execvp"))
+
+ (def-call-out execle0
+ (:arguments (path c-string) (argv0 c-string) (null c-string)
diff --git a/dev-lisp/clisp/files/digest-clisp-2.30 b/dev-lisp/clisp/files/digest-clisp-2.30
new file mode 100644
index 000000000000..4c86d812cf54
--- /dev/null
+++ b/dev-lisp/clisp/files/digest-clisp-2.30
@@ -0,0 +1 @@
+MD5 29e80e430c6098c78dbd2e56334aaa90 clisp-2.30.tar.bz2 5652698