summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-05-21 18:04:15 +0000
committerUlrich Müller <ulm@gentoo.org>2007-05-21 18:04:15 +0000
commit2c9a1b4a5b8e275a27a26817da57dae51ae296e0 (patch)
tree599dbe8c4468abef6f02bff92103e49de00de6ba /dev-lisp/clisp
parentStable for HPPA (bug #178510). (diff)
downloadgentoo-2-2c9a1b4a5b8e275a27a26817da57dae51ae296e0.tar.gz
gentoo-2-2c9a1b4a5b8e275a27a26817da57dae51ae296e0.tar.bz2
gentoo-2-2c9a1b4a5b8e275a27a26817da57dae51ae296e0.zip
Fix compilation with sanitised linux-headers, bug #173050.
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-lisp/clisp')
-rw-r--r--dev-lisp/clisp/ChangeLog7
-rw-r--r--dev-lisp/clisp/clisp-2.41.ebuild4
-rw-r--r--dev-lisp/clisp/files/2.41-linux-headers.patch42
3 files changed, 51 insertions, 2 deletions
diff --git a/dev-lisp/clisp/ChangeLog b/dev-lisp/clisp/ChangeLog
index c7f76e76d5e1..c0a5c386f464 100644
--- a/dev-lisp/clisp/ChangeLog
+++ b/dev-lisp/clisp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/clisp
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.58 2007/03/03 23:26:44 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.59 2007/05/21 18:04:15 ulm Exp $
+
+ 21 May 2007; Ulrich Mueller <ulm@gentoo.org>
+ +files/2.41-linux-headers.patch, clisp-2.41.ebuild:
+ Apply patch from upstream to fix compilation with sanitised linux-headers.
+ Fixes bug #173050.
03 Mar 2007; Marius Mauch <genone@gentoo.org> clisp-2.38-r2.ebuild,
clisp-2.41.ebuild:
diff --git a/dev-lisp/clisp/clisp-2.41.ebuild b/dev-lisp/clisp/clisp-2.41.ebuild
index c6902ec87542..11b001a350a0 100644
--- a/dev-lisp/clisp/clisp-2.41.ebuild
+++ b/dev-lisp/clisp/clisp-2.41.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.41.ebuild,v 1.3 2007/03/03 23:26:44 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.41.ebuild,v 1.4 2007/05/21 18:04:15 ulm Exp $
inherit flag-o-matic eutils toolchain-funcs
@@ -40,7 +40,9 @@ pkg_setup() {
src_unpack() {
unpack ${A}
+ cd "${S}"
epatch ${FILESDIR}/2.41-fastcgi-Makefile-gentoo.patch
+ epatch ${FILESDIR}/2.41-linux-headers.patch
}
src_compile() {
diff --git a/dev-lisp/clisp/files/2.41-linux-headers.patch b/dev-lisp/clisp/files/2.41-linux-headers.patch
new file mode 100644
index 000000000000..6da6eefafe88
--- /dev/null
+++ b/dev-lisp/clisp/files/2.41-linux-headers.patch
@@ -0,0 +1,42 @@
+2007-05-20 Bruno Haible <bruno@clisp.org>
+
+ * unix.d [UNIX_LINUX && UNIX_GNU]: Don't include <asm/page.h>.
+ * lispbibl.d (UNIX_GNU): Move definition down.
+ Reported by Ulrich Müller <ulm@gentoo.org>.
+
+--- src/unix.d 2006/05/23 12:32:25 1.76
++++ src/unix.d 2007/05/20 13:59:43 1.77
+@@ -174,7 +174,7 @@
+ #ifdef UNIX_AUX
+ #include <sys/mmu.h> /* for SHMLBA */
+ #endif
+- #ifdef UNIX_LINUX
++ #if defined(UNIX_LINUX) && !defined(UNIX_GNU)
+ #include <asm/page.h> /* for SHMLBA on Linux 2.0 */
+ #endif
+ #if defined(UNIX_SUNOS4) || defined(UNIX_SUNOS5)
+--- src/lispbibl.d 2007/04/05 01:56:47 1.718
++++ src/lispbibl.d 2007/05/20 22:49:59 1.719
+@@ -376,9 +376,6 @@
+ #if defined(UNIX_MACOSX) && defined(HAVE_MSYNC)
+ #define UNIX_DARWIN # MacOS X, a.k.a. Darwin
+ #endif
+-#if (__GLIBC__ >= 2)
+- #define UNIX_GNU # glibc2 (may be UNIX_LINUX, UNIX_HURD or UNIX_FREEBSD)
+-#endif
+
+
+ # Choose the character set:
+@@ -1267,6 +1264,12 @@
+
+ #include <stdio.h> /* libc i/o */
+
++# A more precise classification of the operating system:
++# (This test works only after at least one system header has been included.)
++#if (__GLIBC__ >= 2)
++ #define UNIX_GNU # glibc2 (may be UNIX_LINUX, UNIX_HURD or UNIX_FREEBSD)
++#endif
++
+ # Determine the offset of a component 'ident' in a struct of the type 'type':
+ # See 0 as pointer to 'type', put a struct 'type' there and determine the
+ # address of its component 'ident' and return it as number: