summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-02-14 23:15:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-02-14 23:15:02 +0000
commitda359d3e99e54eb0628c941a50ee4ca28745a0e4 (patch)
treeaffc7121fc3d3764d6e6dd7cb8db54d4b21603ce /dev-lisp/ecls/ecls-0.9h-r1.ebuild
parentPatch to fix config file detection on amd64 by Bernard Cafarelli <voyageur@op... (diff)
downloadgentoo-2-da359d3e99e54eb0628c941a50ee4ca28745a0e4.tar.gz
gentoo-2-da359d3e99e54eb0628c941a50ee4ca28745a0e4.tar.bz2
gentoo-2-da359d3e99e54eb0628c941a50ee4ca28745a0e4.zip
Completed the work to support building with a C++ compiler; Resolves Bug #122236.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'dev-lisp/ecls/ecls-0.9h-r1.ebuild')
-rw-r--r--dev-lisp/ecls/ecls-0.9h-r1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-lisp/ecls/ecls-0.9h-r1.ebuild b/dev-lisp/ecls/ecls-0.9h-r1.ebuild
index 5360c894c9a7..92abca25fa5d 100644
--- a/dev-lisp/ecls/ecls-0.9h-r1.ebuild
+++ b/dev-lisp/ecls/ecls-0.9h-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-0.9h-r1.ebuild,v 1.1 2006/02/13 19:52:59 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-0.9h-r1.ebuild,v 1.2 2006/02/14 23:15:02 mkennedy Exp $
inherit eutils
@@ -9,8 +9,7 @@ SRC_URI="mirror://sourceforge/ecls/ecl-${PV}.tgz"
HOMEPAGE="http://ecls.sourceforge.net/"
SLOT="0"
LICENSE="BSD LGPL-2"
-# KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
-KEYWORDS="-*" # Pending Bug #122236
+KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
DEPEND="=dev-libs/gmp-4*
app-text/texi2html"
@@ -30,7 +29,9 @@ S=${WORKDIR}/ecl-${PV:0:4}
src_unpack() {
unpack ${A}
+ cd ${S}
epatch ${FILESDIR}/${PV}-headers-gentoo.patch || die
+ epatch ${FILESDIR}/${PV}-sockets-c++-gentoo.patch || die
}
src_compile() {