summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-03-13 09:53:00 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-03-13 09:53:00 +0000
commitc74e2fead65a863737536c45c558270b09acd107 (patch)
tree978c4634923314e6d0ef42daf09bb84401823159 /dev-lisp/hedgehog/hedgehog-2.0.0.ebuild
parentold (diff)
downloadgentoo-2-c74e2fead65a863737536c45c558270b09acd107.tar.gz
gentoo-2-c74e2fead65a863737536c45c558270b09acd107.tar.bz2
gentoo-2-c74e2fead65a863737536c45c558270b09acd107.zip
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-lisp/hedgehog/hedgehog-2.0.0.ebuild')
-rw-r--r--dev-lisp/hedgehog/hedgehog-2.0.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-lisp/hedgehog/hedgehog-2.0.0.ebuild b/dev-lisp/hedgehog/hedgehog-2.0.0.ebuild
new file mode 100644
index 000000000000..893c252f49e6
--- /dev/null
+++ b/dev-lisp/hedgehog/hedgehog-2.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/hedgehog/hedgehog-2.0.0.ebuild,v 1.1 2005/03/13 09:53:00 mkennedy Exp $
+
+inherit eutils
+
+DESCRIPTION="Hedgehog is a very concise implementation of a Lisp-like language for low-end and embedded devices."
+SRC_URI="http://hedgehog.oliotalo.fi/download/${P}.tar.gz"
+HOMEPAGE="http://hedgehog.oliotalo.fi/"
+SLOT="0"
+LICENSE="LGPL-2.1 BSD"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+# Documentation can't be built until weblint-perl and html2ps are added to
+# portage.
+
+src_unpack() {
+ unpack ${A}
+ pushd ${S}
+ cp configure configure.template \
+ && sed "s,CFLAGS=',CFLAGS='$CFLAGS ,g" \
+ < configure.template \
+ > configure || die
+}
+
+src_compile() {
+ mkdir build
+ cd build
+ ../configure linux /usr || die
+ make || die
+}
+
+src_install () {
+ make -C build install prefix=${D}/usr
+ dodoc LICENSE* README TODO
+}