summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-10-14 20:23:46 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-10-14 20:23:46 +0000
commit283fa25351abbe3ec54900db92cccb25d316c7ac (patch)
tree0f484261a3066321541a5b54e4787e88b7f92f43 /dev-lisp/mzscheme/mzscheme-205.ebuild
parentremove weird spelling of magicchicken (diff)
downloadgentoo-2-283fa25351abbe3ec54900db92cccb25d316c7ac.tar.gz
gentoo-2-283fa25351abbe3ec54900db92cccb25d316c7ac.tar.bz2
gentoo-2-283fa25351abbe3ec54900db92cccb25d316c7ac.zip
new version
Diffstat (limited to 'dev-lisp/mzscheme/mzscheme-205.ebuild')
-rw-r--r--dev-lisp/mzscheme/mzscheme-205.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-lisp/mzscheme/mzscheme-205.ebuild b/dev-lisp/mzscheme/mzscheme-205.ebuild
new file mode 100644
index 000000000000..36c401c979b9
--- /dev/null
+++ b/dev-lisp/mzscheme/mzscheme-205.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/mzscheme/mzscheme-205.ebuild,v 1.1 2003/10/14 20:23:37 george Exp $
+
+IUSE=""
+
+S=${WORKDIR}/plt
+DESCRIPTION="MzScheme scheme compiler"
+HOMEPAGE="http://www.plt-scheme.org/software/mzscheme/"
+SRC_URI="http://www.cs.utah.edu/plt/download/${PV}/${PN}/${P}.src.unix.tar.gz"
+DEPEND=">=sys-devel/gcc-2.95.3-r7"
+#RDEPEND=""
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86"
+
+src_compile() {
+ cd ${S}/src
+
+ econf || die "./configure failed"
+
+ make || die
+}
+
+src_install () {
+ cd ${S}/src
+ echo -e "n\n" | einstall || die "installation failed"
+ cd ${S}
+ dodoc README
+ dodoc notes/COPYING.LIB
+ dodoc notes/mzscheme/*
+
+ # 2002-09-06: karltk
+ # Normally, one specifies the full path to the collects,
+ # so this should work, but it's not been tested properly.
+ mv ${D}/usr/install ${D}/usr/bin/mzscheme-install
+
+ dodir /usr/share/mzscheme
+ mv ${D}/usr/collects/ ${D}/usr/share/mzscheme/collects/
+
+ rm -rf ${D}/usr/notes/
+
+ #the resultant files are infected with ${D} and Makefiles do not recognize
+ #standard conventions. Looks like the simples way out is to
+ #strip ${D}'s here
+ cd ${D}/usr
+ grep -rle "${D}" . | xargs sed -i -e "s:${D}:/:g"
+}