summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-08-07 11:36:22 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-08-07 11:36:22 +0000
commit01cff5f689a83503b8302ca5b9463886e2ea91a8 (patch)
tree2a47a9968b04555cabfffb6da5d66ede28afcfa1 /dev-lisp/sbcl
parentKeyworded ~x86-fbsd, #141142 thanks to Robert Annessi (diff)
downloadgentoo-2-01cff5f689a83503b8302ca5b9463886e2ea91a8.tar.gz
gentoo-2-01cff5f689a83503b8302ca5b9463886e2ea91a8.tar.bz2
gentoo-2-01cff5f689a83503b8302ca5b9463886e2ea91a8.zip
add graphviz dep, bug 187305
(Portage version: 2.1.3.3)
Diffstat (limited to 'dev-lisp/sbcl')
-rw-r--r--dev-lisp/sbcl/ChangeLog6
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.7-r2.ebuild15
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.8.ebuild4
3 files changed, 10 insertions, 15 deletions
diff --git a/dev-lisp/sbcl/ChangeLog b/dev-lisp/sbcl/ChangeLog
index f0a5508ad66a..d42bb7c15a1c 100644
--- a/dev-lisp/sbcl/ChangeLog
+++ b/dev-lisp/sbcl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lisp/sbcl
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.122 2007/07/25 17:52:16 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.123 2007/08/07 11:36:22 hkbst Exp $
+
+ 07 Aug 2007; Marijn Schouten <hkBst@gentoo.org> sbcl-1.0.7-r2.ebuild,
+ sbcl-1.0.8.ebuild:
+ add graphviz dep, bug 187305
25 Jul 2007; Marijn Schouten <hkBst@gentoo.org> -sbcl-0.9.4.ebuild,
-sbcl-0.9.17.ebuild, -sbcl-0.9.18.ebuild, -sbcl-1.0.ebuild,
diff --git a/dev-lisp/sbcl/sbcl-1.0.7-r2.ebuild b/dev-lisp/sbcl/sbcl-1.0.7-r2.ebuild
index 0e245dbe2fe3..a6ba494f0dca 100644
--- a/dev-lisp/sbcl/sbcl-1.0.7-r2.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.7-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.7-r2.ebuild,v 1.2 2007/07/21 10:32:56 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.7-r2.ebuild,v 1.3 2007/08/07 11:36:22 hkbst Exp $
inherit common-lisp-common-3 eutils flag-o-matic
@@ -32,7 +32,7 @@ KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="ldb source threads unicode doc"
-DEPEND="doc? ( sys-apps/texinfo )"
+DEPEND="doc? ( sys-apps/texinfo media-gfx/graphviz )"
PROVIDE="virtual/commonlisp"
@@ -50,11 +50,6 @@ pkg_setup() {
eerror "refer to Bug #119016 for more information."
die
fi
- if use ppc && use ldb; then
- ewarn "Building SBCL on PPC with LDB support is not a supported configuration"
- ewarn "in Gentoo. Please refer to Bug #121830 for more information."
- ewarn "Continuing with LDB support disabled."
- fi
}
enable_sbcl_feature() {
@@ -76,11 +71,7 @@ EOF
if use x86 || use amd64; then
use threads && enable_sbcl_feature ":sb-thread"
fi
- if use ppc && use ldb; then
- ewarn "Excluding LDB support for ppc."
- else
- use ldb && enable_sbcl_feature ":sb-ldb"
- fi
+ use ldb && enable_sbcl_feature ":sb-ldb"
disable_sbcl_feature ":sb-test"
! use unicode && disable_sbcl_feature ":sb-unicode"
cat >> "${S}/customize-target-features.lisp" <<'EOF'
diff --git a/dev-lisp/sbcl/sbcl-1.0.8.ebuild b/dev-lisp/sbcl/sbcl-1.0.8.ebuild
index 1177874a8dc6..fa04f9c99a14 100644
--- a/dev-lisp/sbcl/sbcl-1.0.8.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.8.ebuild,v 1.1 2007/07/25 17:32:04 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.8.ebuild,v 1.2 2007/08/07 11:36:22 hkbst Exp $
inherit common-lisp-common-3 eutils flag-o-matic
@@ -32,7 +32,7 @@ KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="ldb source threads unicode doc"
-DEPEND="doc? ( sys-apps/texinfo )"
+DEPEND="doc? ( sys-apps/texinfo media-gfx/graphviz )"
PROVIDE="virtual/commonlisp"