summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2003-09-06 18:03:55 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2003-09-06 18:03:55 +0000
commit05b43dc9ceca7eae35a29d85e40ba56ba1a6d56f (patch)
tree8854fd61302d31c71d272cf4cf6be06120dba2ce /dev-lisp
parentFixes #25740. (diff)
downloadgentoo-2-05b43dc9ceca7eae35a29d85e40ba56ba1a6d56f.tar.gz
gentoo-2-05b43dc9ceca7eae35a29d85e40ba56ba1a6d56f.tar.bz2
gentoo-2-05b43dc9ceca7eae35a29d85e40ba56ba1a6d56f.zip
Fixes #25740.
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/gauche/ChangeLog8
-rw-r--r--dev-lisp/gauche/Manifest4
-rw-r--r--dev-lisp/gauche/files/digest-gauche-0.7.11
-rw-r--r--dev-lisp/gauche/gauche-0.7.1.ebuild51
4 files changed, 61 insertions, 3 deletions
diff --git a/dev-lisp/gauche/ChangeLog b/dev-lisp/gauche/ChangeLog
index 3e21d4ea30d8..1c0b58c82781 100644
--- a/dev-lisp/gauche/ChangeLog
+++ b/dev-lisp/gauche/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/gauche
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gauche/ChangeLog,v 1.5 2003/02/12 06:11:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gauche/ChangeLog,v 1.6 2003/09/06 18:03:46 karltk Exp $
+
+*gauche-0.7.1 (06 Sep 2003)
+
+ 06 Sep 2003; Karl Trygve Kalleberg <karltk@gentoo.org>
+ gauche-0.7.1.ebuild:
+ New upstream version. Fixes #25740.
*gauche-0.6 (19 Jul 2002)
diff --git a/dev-lisp/gauche/Manifest b/dev-lisp/gauche/Manifest
index 9662dcddd8ea..08f64bca33cd 100644
--- a/dev-lisp/gauche/Manifest
+++ b/dev-lisp/gauche/Manifest
@@ -1,7 +1,7 @@
-MD5 00695691a4c8d0d96b88131ca699ab5f ChangeLog 1117
+MD5 d54082431eb3db46bf35ea225e8cc9df ChangeLog 1265
MD5 5185ad5c5285f88c43bbff0304a960aa gauche-0.5.7.ebuild 926
MD5 73656ea837aa4cc7ea1a87a7291b74a1 gauche-0.6.ebuild 924
-MD5 d0dcb7b3ab2468b3b8fbf0ebdd25c7f8 gauche-0.7.1.ebuild 1025
+MD5 59f51c54bbaa44dffa2610de36339a52 gauche-0.7.1.ebuild 1249
MD5 c18c00a2c663b57c0da69ccc7d589d39 files/digest-gauche-0.5.7 62
MD5 970a94ed0e9da51ed4b007b7a3456111 files/digest-gauche-0.6 60
MD5 8e1c8c57c6a2b38a3d62148d0e358a91 files/digest-gauche-0.7.1 62
diff --git a/dev-lisp/gauche/files/digest-gauche-0.7.1 b/dev-lisp/gauche/files/digest-gauche-0.7.1
new file mode 100644
index 000000000000..fe4f6421cccb
--- /dev/null
+++ b/dev-lisp/gauche/files/digest-gauche-0.7.1
@@ -0,0 +1 @@
+MD5 f07345c81f2434516cc175cebde77901 Gauche-0.7.1.tgz 2219061
diff --git a/dev-lisp/gauche/gauche-0.7.1.ebuild b/dev-lisp/gauche/gauche-0.7.1.ebuild
new file mode 100644
index 000000000000..21a083d7dabc
--- /dev/null
+++ b/dev-lisp/gauche/gauche-0.7.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gauche/gauche-0.7.1.ebuild,v 1.1 2003/09/06 18:03:46 karltk Exp $
+
+inherit flag-o-matic
+
+# 2003-09-06: karltk
+# Original submission used the non-exisiting utf8 flag, changed to nls for now
+IUSE="ipv6 nls"
+HOMEPAGE="http://gauche.sf.net"
+DESCRIPTION="A Unix system friendly Scheme Interpreter"
+SRC_URI="mirror://sourceforge/gauche/Gauche-${PV}.tgz"
+LICENSE="BSD"
+KEYWORDS="~x86"
+SLOT="0"
+S="${WORKDIR}/Gauche-${PV}"
+
+DEPEND="virtual/glibc
+ >=sys-libs/gdbm-1.8.0-r5"
+
+src_compile() {
+ local myconf
+
+ use ipv6 && myconf="--enable-ipv6"
+
+ if [ "`use nls`" ]; then
+ myconf="$myconf --enable-multibyte=utf-8"
+ else
+ myconf="$myconf --enable-multibyte=euc-jp"
+ fi
+
+ sed -e "67s/\$(LIB_INSTALL_DIR)/\$(DISTDIR)\$(LIB_INSTALL_DIR)/" \
+ src/Makefile.in > src/Makefile.in.tmp
+ rm -f src/Makefile.in
+ mv src/Makefile.in.tmp src/Makefile.in
+
+ filter-flags -fforce-addr
+
+ CFLAGS="" CXXFLAGS="" econf $myconf --enable-threads=pthreads
+ emake OPTFLAGS="$CFLAGS"
+
+ make check
+}
+
+src_install () {
+# einstall
+ make install DESTDIR=${D}
+
+ dodoc AUTORS COPYING ChangeLog HACKING INSTALL INSTALL.eucjp README
+}
+