summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2012-12-14 07:21:23 +0000
committerAndrey Grozin <grozin@gentoo.org>2012-12-14 07:21:23 +0000
commit0e30865875936e85feb1fe46cd400e3dc842f56b (patch)
treef8eacff0e9a1ac088b064900fe6ac670ffa0664d /dev-lisp
parentInitial import. New dependency for dev-ruby/adhearsion. (diff)
downloadgentoo-2-0e30865875936e85feb1fe46cd400e3dc842f56b.tar.gz
gentoo-2-0e30865875936e85feb1fe46cd400e3dc842f56b.tar.bz2
gentoo-2-0e30865875936e85feb1fe46cd400e3dc842f56b.zip
Version bump
(Portage version: 2.2.0_alpha148/cvs/Linux i686, unsigned Manifest commit)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/ecls/ChangeLog8
-rw-r--r--dev-lisp/ecls/ecls-12.12.1.ebuild79
-rw-r--r--dev-lisp/ecls/files/12.12.1-headers-gentoo.patch17
3 files changed, 103 insertions, 1 deletions
diff --git a/dev-lisp/ecls/ChangeLog b/dev-lisp/ecls/ChangeLog
index b668a2ffe087..aaf9d3f2a295 100644
--- a/dev-lisp/ecls/ChangeLog
+++ b/dev-lisp/ecls/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/ecls
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.43 2012/08/23 04:32:11 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.44 2012/12/14 07:21:23 grozin Exp $
+
+*ecls-12.12.1 (14 Dec 2012)
+
+ 14 Dec 2012; Andrey Grozin <grozin@gentoo.org>
+ +files/12.12.1-headers-gentoo.patch, +ecls-12.12.1.ebuild:
+ Version bump
23 Aug 2012; Christoph Junghans <ottxor@gentoo.org> ecls-12.7.1.ebuild:
added prefix keywords (bug #341985)
diff --git a/dev-lisp/ecls/ecls-12.12.1.ebuild b/dev-lisp/ecls/ecls-12.12.1.ebuild
new file mode 100644
index 000000000000..aa1eb1a2a32b
--- /dev/null
+++ b/dev-lisp/ecls/ecls-12.12.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-12.12.1.ebuild,v 1.1 2012/12/14 07:21:23 grozin Exp $
+
+EAPI=4
+
+inherit eutils multilib
+MY_P=ecl-${PV}
+
+DESCRIPTION="ECL is an embeddable Common Lisp implementation."
+HOMEPAGE="http://ecls.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
+
+LICENSE="BSD LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug emacs gengc precisegc threads +unicode X"
+
+RDEPEND="dev-libs/gmp
+ virtual/libffi
+ >=dev-libs/boehm-gc-7.1[threads?]"
+DEPEND="${RDEPEND}
+ app-text/texi2html
+ emacs? ( virtual/emacs >=app-admin/eselect-emacs-1.12 )"
+PDEPEND="dev-lisp/gentoo-init"
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ if use gengc || use precisegc; then
+ ewarn "USE flags gengc and precisegc are experimental"
+ ewarn "Don't use them if you want a stable ecl"
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-headers-gentoo.patch
+}
+
+src_configure() {
+ econf \
+ --with-system-gmp \
+ --enable-boehm=system \
+ --enable-longdouble \
+ $(use_enable gengc) \
+ $(use_enable precisegc) \
+ $(use_with debug debug-cflags) \
+ $(use_enable threads) \
+ $(use_with threads __thread) \
+ $(use_enable unicode) \
+ $(use_with X x) \
+ $(use_with X clx)
+}
+
+src_compile() {
+ if use emacs; then
+ local ETAGS=$(eselect --brief etags list | sed -ne '/emacs/{p;q}')
+ [[ -n ${ETAGS} ]] || die "No etags implementation found"
+ pushd build > /dev/null || die
+ emake ETAGS=${ETAGS} TAGS
+ popd > /dev/null
+ else
+ touch build/TAGS
+ fi
+
+ #parallel fails
+ emake -j1
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+
+ dodoc ANNOUNCEMENT Copyright
+ dodoc "${FILESDIR}"/README.Gentoo
+ pushd build/doc > /dev/null
+ newman ecl.man ecl.1
+ newman ecl-config.man ecl-config.1
+ popd > /dev/null
+}
diff --git a/dev-lisp/ecls/files/12.12.1-headers-gentoo.patch b/dev-lisp/ecls/files/12.12.1-headers-gentoo.patch
new file mode 100644
index 000000000000..635fc5d4afde
--- /dev/null
+++ b/dev-lisp/ecls/files/12.12.1-headers-gentoo.patch
@@ -0,0 +1,17 @@
+diff -Naur ecl-8.12.0.orig/src/h/object.h ecl-8.12.0/src/h/object.h
+--- ecl.orig/src/h/object.h 2008-12-17 16:41:53.000000000 +0100
++++ ecl/src/h/object.h 2008-12-17 19:35:05.000000000 +0100
+@@ -23,8 +23,13 @@
+ Integer and boolean types (see config.h)
+ */
+
++#ifndef TRUE
+ #define TRUE 1 /* boolean true value */
++#endif
++
++#ifndef FALSE
+ #define FALSE 0 /* boolean false value */
++#endif
+
+ #if !defined(__cplusplus) && !defined(bool)
+ typedef int bool;